ERROR: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] unknown error (_ssl.c:833)>


#1

hi there, was wondering if anyone might have a clue to why as of jan23 I started receiving this error when running speedtest-cli on openwrt.. it currently worked for years. but now I get this error

ERROR: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] unknown error (_ssl.c:833)>

I uninstalled it upgraded python and then reinstalled speedtest-cli but still gives the same errors--
I can seam to find anything useful with a websearch perhaps some know the issue and how to resolve it


#2

Perhaps the certificate at the far end expired?


#3

but if I install speedtest-cli on other version of linux it still works fine .. so it would seam the certificate would be fine on the remote side and not broken universally


#4

okay did a fresh install of armbian on my pi device installed pip and then installed pip install speedtest-cli - worked fine

do a fresh install of openwrt - then install pip then speedtest-cli - the same error -- the problem is on openwrt it would seam to be.. any suggestion how one can fix it some google searches suggest that openssl it too outdated.


#5

spoke to speedtest.net

Hey Stephen, we don't support third party applications - with that said, we recently enforced HTTPS for and it looks like there is something wrong with your server's OpenSSL configuration. Try updating your CA certificates and OpenSSL.

seams that openssl and The CA certificates are out of date- would someone have a suggestion how to update these components


#6

okay figured it out - I never had ca- certificates and bundle installed as it was not required before after installing the them it started to work again


closed #7

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.