Error Share USB Hard-drive with Samba (Tp-Link Archer C2600)

2 days ago I installed OpenWRT on my Tp-link archer c2600 because I had problems with 2.4ghz wifi and it been fixed, in stock firmware I had a streaming HDD connected to the router to play movies on Roku, computers and on my smartphone and now With OpenWRT I can't. I already saw tutorials and installed everything necessary (Drivers and Samba) but something is not working well, I can mount the unit but transferring a file over a network takes too long and even straming fails to try to read the file. All this did not happen to me with the stock firmware. I will show you a imagen about my configuration that I have and I´ve tried but without success. I hope you can help me.

Try change server max protocol = LANMAN1 or server max protocol = NT1

Not sure which version your devices support, but usually older stuff only works with smb1 aka "LANMAN1", while newer devices should work with smb2 or even smb3 (Win8+). Yet smb3 is only available via Samba4 or smbd from packages.

I've try with SMB1 and didn't work for security problem, now its running on SMB2 but is the same problem even SMB3, I cant use the USB as streaming.

I can write on USB on windows 10 or android but it takes too long or imposible and I cant read

What filesystem did you use to format the usb drive?

I've try NTFS, now Exfat

Neither of those are very good for samba, grab partitionwizard-portable and use ext3.

PS: If this works, long-term you might want to switch to F2FS for flash devices (SSD/USB stick) but you can't format this on Windows, so you need to create/boot to a live iso of gparted. The iso can be booted via using rufus to create a bootable live cd.

You also need to add the kernel mods for F2FS to openwrt via opkg/software manager.

I've try ext3 and I couldn't mount the device i dont know why but now Im trying ext4 but now appears that ''i dont have permissions'' with the same config

run via shell chmod 0777 /mnt/sda1 to ensure access to the shares rootfolder

Thanks Andy it works now I can stream :grinning: :love_you_gesture:

Do you know another config for improve the write speed? or manual (site) for improve my network
The router has usb3 ports and the HDD is usb3 too, I guess the speed should be higher, right?

Yeah kinda low, but "USB3" is not the important factor here, its how the usb3 ports are actually implemented on the chip and how high your cpu usage is during transfer. You can check the cpu via htop package from the shell. If its maxed than its a potentially cpu problem and all you can try is either samba4 or smbd.

There should also be guides on how to test raw read/write speeds on openwrt via shell, to check for potentially bad usb hardware implementations.