Error reverting WR840N from OpenWrt to Stock firmware

Hello. I have OpenWRT installed on my device, but I want to revert to the original software due to speed drops. After installing the stock software from the tp-link official site and flashing it with tftpd64, the lights of the device begin to flash. I tried several times but the result is the same. For this reason I have to go back to OpenWrt software. According to what I read in the forum, I learned that I need to command dd if="name_of_file_of_firmware" of=tp_recovery.bin skip=1 bs=512 with dd program. But even if I download the dd program and try, it doesn't work. Probably because I don't know how to use the program. Very happy if you help:)

Is the file located in the directory?

By the way, I might have misunderstood. what is in my file directory?

No clue what's in your file directory currently; but this file should be located there:

So if you have an idea about this subject, can you help me or leave a link on which path I should follow?

I think I found it. I put the file in the tmp folder and applied the operations. but i got an error like this

No !
you are doing it wrong
tp_recovery.bin is intended to be transmitted over tftp at boot time

so, you need

  1. PC with network settings:
  2. TFTP server for windows
  3. modified tp_recovery.bin in TFTP directory
  4. ethernet cable plugged into WAN port and PC LAN
  5. press reset button while powering on TP-LINK router

if everything went OK, you will see message in TFTP program that transfer is started and TP-LINK will flash new FW

I hadn't tried that before. Device lights start blinking and won't turn on.

I shared with you how I did it and what kind of mistake it was after as a video. I shared it via Samsung Quick Share link sharing. I tried on all lan and wan ports but same problem.

ok, as i see in video, all steps are OK
bin file is transfered to device and flashing is started

only problem is now, to put a right BIN file in TFTP folder

so you need to first prepare tp_recovery with DD from official FW file
it is painful process, some FW file contains uboot, some don't
furthermore, there was a situation for example, that tp-link was v5 but uboot/tftpd process required V4 image ... real mess
there is no other options, only to repeat process DD then TFTP with different FW files until you success

1 Like

I did and it happened. Thank you very much

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.