Error installing package

installing pixiexps package always fails even it it's from local storage

error : * pkg_hash_fetch_best_installation_candidate: Packages for pixiewps found, but incompatible with the architectures configured

cd /tmp
root@LEDE:/tmp# opkg install --force-depends *.ipk
Package pixiewps version 1.4.2-2 has no valid architecture, ignoring.
Unknown package 'pixiewps'.
Package reaver (1.6.5-1) installed in root is up to date.
Collected errors:
 * pkg_hash_fetch_best_installation_candidate: Packages for pixiewps found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package pixiewps.

What device, what openwrt version?

2 Likes

And where did you get the .ipk?
Are you sure that it is compiled exactly for your package target?

The error "no valid architecture" sounds like it would be either non-openwrt or made for a quite different OpenWrt version (if the proposed arch does not match yours).

3 Likes

i got it from a tutorial video in youtube and yes it's for openwrt about this :
Are you sure that it is compiled exactly for your package target?
i don't know because i'm using now LEDE Reboot 17.01.4 r3560 and it's not working but when i use the latest version like 22.1.03 it can install it any way to fix it ???

device : Huawei EchoLife HG556a (version A)
openwrt version : LEDE Reboot 17.01.4 r3560

Yes, I'd suggest keep running the more up-to-date and secure versions and find the correct IPK.

Version 17 is end-of-support and has known vulnerabilities. Additionally, there was a change in how packages were compiled since that time. That's likely why it doesn't work.

1 Like

that's what i did i updated to the latest OpenWrt 22.03.2

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.