Error installing OpenWrt firmware on TP-Link Archer C60

I have a TP-Link Archer C60 v2 with Korean firmware and by following I couldn't flash the firmware via the web gui. I get "invalid file type" error. I renamed the file to "tp_recover.bin". I also I tried changing to an EU stock firmware and it shows the same error. But when I use the same Korean firmware, the file was accepted.

I even tried the TFTP method to add the tp_recovery.bin and the weird thing is I couldn't even change the firmware. It still goes back to the same stock firmware with the web gui.

Did anyone manage to install openwrt on c60 before? How did you do it?

Hi There
For Archer C60 v1.x, v2.0, v2.1 installing OpenWrt is confirmed to work by simply uploading the OpenWrt firmware in the stock OEM's firmware-upgrade page. Please note however that this page will refuse to install firmware uploaded with a long filename. To bypass this limitation, download the relevant factory-flash bin-file and then rename the file to something shorter like firmware.bin before uploading