Error "ifup But that file is already provided by package * netifd"

when I try to make custom image I get this error but I haven't selected ifup in my config.

 * check_data_file_clashes: Package busybox wants to install file /home/me/projects/openwrt/sources/master-branch/build_dir/target-arm_cortex-a9+vfpv3_musl_eabi/root-mvebu/sbin/ifup
        But that file is already provided by package  * netifd
 * opkg_install_cmd: Cannot install package busybox.

Seems you customized your busybox settings and they got out of sync with master. Go to menuconfig and disable the ifup/ifdown busybox applets. Save, exit and continue with make package/busybox/clean; make

i have checked
they are unchecked.
ifconfig is unset too.
I dont understand why it still happens.

this is weird.
I removed the staging and build folders and remade the image.
now it gives the error about brctl and when I deselect it from busybox I still get the same error.
but when I deselect the bridge utility then the error goes away.
what is happening?
Is it because I am using git version?
I check and there are three different bridge executable file selectable :
1 brctl applet from busybox BUSYBOX_CONFIG_BRCTL
2 PACKAGE_bridge
3 PACKAGE_ip-bridge

I had all of them selected.(which wasnt an issue before)
but now I have to deselect both PACKAGE_bridge and PACKAGE_ip-bridge because if I dont deselect PACKAGE_ip-bridge then it gives and error about busybox, which the weird part cause that one is already deselected.
I think this a bug of make system that is introduced recently.
before removing my build and staging folder I would get the busybox error bu about the ifup applet that was also deselected.

so after many tries I got the brctl and ip-bridge both maybe it is ok?