Error code 18005 (TP-Link)

hi guys, been reading the topics to do with the Archer cC7 v2 and haven't yet found one that helps me with my 18005 error.
So currently the stock tp-link
firmware version : 3.15.3 Build 180305 Rel.51282n
hardware version : Archer C7 v2 00000000

I've tried changing the .bin name to firmware, factory, even removing spaces from the filename like ledefactory for example..

The router still won't except it.
I enter the file from my folder, then click on the upgrade button. A window pops up: "the site says... Are you sure to upgrade the firmware?" I click on OK..
next I see:
" Error code: 18005
Upgrade unsuccessfully because the version of the upgrade file was incorrect. Please check the file name."

Just reinstalled the same firmware that was already on it and it completed. the filename was: ArcherC7v2_en_eu_3_15_3_up_boot(180305).bin

I've even tried renaming the lede firmware .bin file to the same as the stock tp-link firmware .bin name. But still the same error.

Anyone have a idea why this is happening?


Have you read the articles in wiki and forum about the error?

It seems to be about your regionally locked TP-Link firmware...


i think i may have downloaded the eu firmware instead of my au/nz firmware

so got the openwrt firmware on router. Had the eu firmware instaalled not the au/nz firmware . all fixed with openwrt running..

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.