Error building custom image

I'm trying to build a custom image with BTF enabled for raspberry pi 4 B. When I run make, I get the following error after a while

touch /root/openwrt/build_dir/host/cmake-3.25.2/.built
touch /root/openwrt/staging_dir/host/stamp/.cmake_installed
make[3]: Leaving directory '/root/openwrt/tools/cmake'
time: tools/cmake/compile#1437.18#115.69#815.02
make[2]: Leaving directory '/root/openwrt'
make[1]: *** [tools/Makefile:215: /root/openwrt/staging_dir/host/stamp/.tools_compile_nyyynyynnyyyyynyyyyyyynyynnynyynnynnyyyyyyyyyyyyyyyyynynnyyyyyyy] Error 2
make[1]: Leaving directory '/root/openwrt'
make: *** [/root/openwrt/include/ world] Error 2

Am I doing something wrong here? Can someone help me please?

1st error is building using root, it's not supported.


FORCE_UNSAFE_CONFIGURE=1 I thought this was supposed to override that?

And we would know you applied it, how exactly?

Uh sorry, I set this before starting build.

I tried to do it on a non root user and I still get the same error.

If you building parallel way, the actual error might be somewhat earlier.
And you need to compile with verbose logging, with make V=s

(Also do not set parallel with -j something, so that logging is linear)


Thanks @hnyman.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.