ENS620EXT Firmware Upgrade System page only

Hi to all,

I have been using openwrt for a long time. However, I think that I break my device few days ago and I can't solve the problem.

Device: EnGenius ENS620EXT
Install OpenWrt from original firmware:

After install and configuration I decide to install it again using:

Well, after that I only have this page avaiable:

I can only upload a sysupgrade, not anything else ans I can't recover the device.

I would like to ask you some help.

Kind regards,

The factory images are used to convert from vendor's firmware to OpenWrt.
After that, when you already run OpenWrt, you should use the sysupgrade images.

1 Like

Thank you for your reply,

Ok, however at this moment I only can access to the page for firmware upgrade. Even if I upload a sysupgrade image, I can't recover the device. Only what I get is the same page that I show in the picture.

Thank you again.

Regarding the 2 versions available for the factory image you can see the explanation in the page.


Check the currently installed vendor firmware. If it's 3.5.x or newer, you need the -factory_35.bin image. Otherwise, you need -factory_30.bin

Now this page doesn't look to me like Luci, so most likely it is from the factory.
Follow these instructions:

Note: Reset router to factory defaults if it has been previously configured and you don't have the admin password. To reset, power the device and wait for it to fully boot. Then press the reset button for 11 seconds until the sys led starts flashing. Release the button and wait for the device to reboot.

Then try to flash the OEM firmware, since the sysupgrade won't work.

It's not Luci, but it's not the original as well. I installed the -factory_35.bin as they say.

Now, I only have that page. The page only can upload the sysupgrade file, any other fail and says that is invalid and don't upload.

Not OEM firmware, not anything else. Just accept and perform upload and write till 100% for sysupgrade files from openwrt. After that it's not possible to have luci or enter failsafe mode. By access the page again, we get the same upload page.

Sorry to bother you... and thanks

Then I am out of ideas. Maybe your best shot is to connect serial cable on the device and see if you can salvage it from there.

same issue i'm encountering, if any of you has a solution to access the device and make it work to be able to configure it please do let me know, detailed how to guide will be appreciated too.

I'm going to try to connect via serial and try to recover from there. Maybe the "factory_35.bin" have some issue or I used it in a wrong way. "factory_30.bin" worked but I was unable to activate DHCP. So I decide to flash it with factory_40.bin and I can't access anymore. Just that page that permite upgrade the system and accept only sysupgrade files. I already try to access via FTP, TFTP, SSH, trying to enter in fail-safe mode.... nothing works.

Serial connection is the next step. I already purchase a serial 3V3 adapter, I need to disassemble and put the wires in place. Hopefully will work.... :confused:

You were not supposed to use them both. You use only one according to the version of the vendor firmware. Then you would upgrade to OpenWrt, but most likely the second factory.bin flashing messed it up.

Now It's messed! Not any way to recover? Serial Flashing, sysupgrade recovery? Anything?

I would try with serial cable, if there is some meaningful output.

Solved! :slight_smile:

In order to be able to access it again, from the upgrade page. (Not necessary access to serial)

  1. Access link: https://www.engeniusnetworks.eu/products/wireless/outdoor-access-points/ens620ext
  2. Download: [ENS620EXT FW v1.0.0_c1.8.53] zip file
  3. Decompress it
  4. Flash the file: 1.ENS620EXTaddCAPWAP.bin
  5. From now on it's possible to access to the original EnGenius page

Thanks for the help, If anyone have any issue or need extra help to recover, I'm available!

1 Like

Since the problem is solved, feel free to mark the topic accordingly .

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.