Enabling PPTP Passthru on OpenWrt

I have installed OpenWRT Ver 19.07.4 on a Netgear R6220 router. I am not an OpenWRT guru, so I am using LuCI to configure the router. I have a very basic configuration.

I have a laptop connected to the router via wifi. Everything works fine, except that I can't establish a PPTP VPN connection to my office. I suspect that PPTP passthru is not enabled on the router.

How can I enable this using LuCI?

In "System > Software", update package lists, then install the "kmod-nf-nathelper-extra" package.

1 Like

What is CLI? Exactly how do I do this?

Please join https://meet.google.com/ysa-oppc-rur (edit: nobody joined, so I am closing the tab) and I will guide you through the procedure. No CLI needed, and the conntrack helper advice is outdated.

1 Like

See also https://www.reddit.com/r/openwrt/comments/f6joge/changed_routers_to_one_running_openwrt_cant/

@vgaetera there is a checkbox, "Automatic helper assignment", on the firewall zone editing tab. So adding the the sysctl via CLI is not needed (it is a global setting that does the same, and even better, the checkbox is already on by default). And the rest of the actions in the doc (that is, updating the package list and installing kmod-nf-nathelper-extra) can be done via GUI.

1 Like

Sorry put I don't see any checkbox like that.

Here's a screenshot:

Click Edit, then go to the "Conntrack Settings" tab.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.