Enabling packet steering seems to cause loss of hostnames on pi-hole

Enabling packet steering on my dumb AP causes all DNS requests from wireless clients to show up as _gateway in pihole rather than as their respective hostname. Is there any way to pass hostnames along and have this featured enabled?

You enabled something else. Do you have alternate dhcp server in your network? Like on LAN side of OpenWRT dumb ap?

No, I believe that was the only change I made. I will test it again to verify.

OK... I see now you are correct: this setting has no effect on the number of entries... they are all due to one of my VLANs I think I will open a new thread if i cannot figure this out.

EDIT: my issues that that particular interface was setup to bypass pi-hole and use the router's DNS entries. I solved the hostname issue by adding DNS Option in the interface on the router/firewall of 6,1.1.1.1,1.0.0.1. Hopefully this will be useful for someone else.

Again, the problem has NOTHING to do with the packet steering option.

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.