Enabling channel 12 and 13 on Ath

Hi I've been trying to enable channel 12 and 13 on my Qualcomm Atheros QCA9533

I am not in america and it is legal where I live
I already tried changing my country to any other one and phy#0 still shows up as US
I am ready to change any config or anything

I saw someone about ath9k regd patch I think it's helpful for doing this, please and thank you

I am also willing to compile and reflash if needed

they just work here in Australia when I set my country to match
but some devices still default to US so 13 will not always work on the adapter side
so you have to get up-to-date drivers for you adapters & set the country there as well

Works here in the United Kingdom.

Which router model are you having issues with?

If this is US version of a device, the channels might be additionally restricted in the art partition, but usually the country code would be used for that. If the country code still shows as US, what's the output of iw reg get? You could try iw reg set plus the (two-character) country code.

1 Like

you do not need any reg patch, you you need a reg.db with different information in US section, like use US section with EU information.
all is in /lib/firmware

What do I do? can I have some steps please?
thank you

iw reg get

country US: DFS-FCC
        (902 - 904 @ 2), (N/A, 30), (N/A)
        (904 - 920 @ 16), (N/A, 30), (N/A)
        (920 - 928 @ 8), (N/A, 30), (N/A)
        (2400 - 2472 @ 40), (N/A, 30), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5350 @ 80), (N/A, 24), (0 ms), DFS, AUTO-BW
        (5470 - 5730 @ 160), (N/A, 24), (0 ms), DFS
        (5730 - 5850 @ 80), (N/A, 30), (N/A), AUTO-BW
        (5850 - 5895 @ 40), (N/A, 27), (N/A), NO-OUTDOOR, AUTO-BW, PASSIVE-SCAN
        (5925 - 7125 @ 320), (N/A, 12), (N/A), NO-OUTDOOR, PASSIVE-SCAN
        (57240 - 71000 @ 2160), (N/A, 40), (N/A)

doing iw reg set(my country) and then doing iw reg get still gets the exact same result nothing changes

the work around is to have the infos of your contry, in US section.
to do that you need create a new reg.db in lib/firmware. do not ask me here please how do that, seach for that. so you can legally set your country.

1 Like

you can't just change on the fly
do reboot or make sure you eve power down and reboot
the device for charges to take affect

I already did restart many times

It still shows up as phy#0 country code US

just checking but you are changing the setting in luci or the /etc/config/wireleess file

both, they show up the same yet it's still on US when I do the command

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.