[Solved] Enable Wi-Fi and Connect to a Network on First Boot

If I fill everything out except 'type' and 'path' will those two settings be filled in automatically and the WiFi should come up on the first boot?

Not clear as I only use wifi config with no /etc/config/wireless in place. It would surprise me if it worked as you might hope with an incomplete /etc/config/wireless

Edit: From /lib/wifi/mac80211.sh

                uci -q batch <<-EOF
                        set wireless.radio${devidx}=wifi-device
                        set wireless.radio${devidx}.type=mac80211
                        set wireless.radio${devidx}.channel=${channel}
                        set wireless.radio${devidx}.hwmode=11${mode_band}
                        ${dev_id}
                        ${ht_capab}
                        set wireless.radio${devidx}.disabled=1

                        set wireless.default_radio${devidx}=wifi-iface
                        set wireless.default_radio${devidx}.device=radio${devidx}
                        set wireless.default_radio${devidx}.network=lan
                        set wireless.default_radio${devidx}.mode=ap
                        set wireless.default_radio${devidx}.ssid=OpenWrt
                        set wireless.default_radio${devidx}.encryption=none
EOF
                uci -q commit wireless

so, no, it will overwrite

2 Likes

Nothing is changed unless the file does not exist at all. In other words if you have an incomplete or erroneous /etc/config/wireless, the firstboot scripts won't change it at all.

Simplest thing would be to get the type and path from a working instance on the same hardware and copy it into your file.

2 Likes

So the /lib/wifi/mac80211.sh script won't overwrite the wireless config if it's already exists?

I'm pretty sure 'type' is mac80211

WikiDevi page on the EX3700:

WI1 chip1: MediaTek MT7620A
WI2 chip1: MediaTek MT7612EN

OpenWrt doc on /etc/config/wireless:

Used values are broadcom on brcm47xx, or mac80211 for all other platforms.

I'm having trouble finding anything online showing the contents of the wireless config for this device, so I'm not sure about the value of 'path'. Do you know how the /sbin/wifi command obtains that value?

Typically run-time probing. It's pretty clear in the code. Start reading at

     70         for _dev in /sys/class/ieee80211/*; do
1 Like

Thanks. That seems to suggest that I won't be able to get those values without running it on the hardware itself unless I can find someone who had posted their config somewhere.

I just found this post:

He's got the same device as me and he posted the contents of his /etc/config/wireless file.

These appear to be the values I've been looking for:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/10180000.wmac'

Should I configure the /etc/config/network file before the first boot, too?

It’s unclear to me what problem you’re trying to solve. In any memory of mine, I’ve always just flashed a device, configured basic networking with hand edits, and be done with it in 15 min or less. For fancy config (mesh with multiple VLANs, for example), I’ll then use git and a remote.

1 Like

I want to flash from stock to OpenWrt without using the ethernet port. I'm trying to enable wireless and have it start in AP mode at the first boot so that I can connect to it over WiFi and configure it wirelessly.

I'm unpacking the image builder now.

1 Like

This is what i use ( not perfect but shows basics ) ...

In imagebuilder...

mkdir -p files/etc/uci-defaults

Put the script there...

#!/bin/sh

i=$(basename $0)
D="`date +%Y%m%d-%h%m`"

ecmd="echo "
#ecmd="logger -t $i "

test -f /root/.firstboot.$i && exit 0

$ecmd "Checking default wifi settings"

wifiname2="wifi-`date +%s`-2"
wifiname5="wifi-`date +%s`-5"

$ecmd "Checking 2G or radio0"
sleep 1

if uci show wireless | grep encryption | grep -q none; then
	echo "wireless-default-encryption-none is set"
	uci -q set wireless.default_radio0.encryption='psk2+ccmp'
	uci -q set wireless.default_radio0.key='albertbubbaschnookle'
fi

if uci show wireless | grep ssid | grep -q OpenWrt; then
	echo "wireless-default-ssid is set"
	uci -q set wireless.default_radio0.ssid=$wifiname2
fi

if uci show wireless | grep country | grep -q '00'; then
	echo "wireless-default-country is 00"
	uci -q set wireless.radio0.country='AU'
fi

if uci show wireless | grep disabled | grep -q "=\'1\'"; then
	echo "wireless-default-disabled is 1 > enabling"
	uci -q set wireless.radio0.disabled='0'
fi


$ecmd "Checking 5G or radio1"
sleep 1

if uci show wireless | grep encryption | grep -q none; then
	echo "wireless-default-encryption-none is set"
	uci -q set wireless.default_radio1.encryption='psk2+ccmp'
	uci -q set wireless.default_radio1.key='albertbubbaschnookle'
fi

if uci show wireless | grep ssid | grep -q OpenWrt; then
	echo "wireless-default-ssid is set"
	uci -q set wireless.default_radio1.ssid=$wifiname5
fi

if uci show wireless | grep country | grep -q '00'; then
	echo "wireless-default-country is 00"
	uci -q set wireless.radio1.country='AU'
fi

if uci show wireless | grep disabled | grep -q "=\'1\'"; then
	echo "wireless-default-disabled is 1 > enabling"
	uci -q set wireless.radio1.disabled='0'
fi

uci commit wireless

$ecmd "wifi reload"
wifi reload

touch /root/.firstboot.$i
exit 0

Adapt to whatever you need to change...

2 Likes

EDIT: @anon50098793 thanks! Looks like I might be able to use that too. Is that one script enough to enable your wireless adapter and connect to a WiFi network? you don't do anything to /etc/config/network before the first boot? btw, your WiFi key is visible in your post. :yum:

EDIT2: Oops. Looking over your script more carefully it looks like it sets up a wireless AP instead of connecting to a wireless network? Clever use of the date command to create a random WiFi name. I'm assuming that is to avoid naming conflicts. BTW, does it matter what filename the script is saved as?

--

So to add custom files with image builder I create a subdirectory in the top level directory and then add FILES=/path/to/subdirectory to the end of the make command?

i.e.

mkdir -p files/etc/config
nano files/etc/config/wireless
nano files/etc/config/network
make image PROFILE=netgear_ex3700 FILES=files/

?

1 Like

Yes use something like...

uci -q set wireless.radio1.mode='sta'

etc. etc. for the settings you need

uci commit wireless
wifi reload
exit 0

at the bottom and your good to go! ( no filename does not matter )

1 Like


It worked. :grin::+1:

1 Like

In case someone comes across this in the future here are the three files I added to the image builder directory:

Configs updated: See next post below

@lleachii @jeff @mk24 @anon50098793 Thanks for all your help!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

I'm posting my configs again. I had to make some changes because I wasn't able to ping or connect to any host outside of my network. Here are my current configs.

One interface connects to my main router in client mode("sta") over 2.4 GHz which I've labeled the "wan" connection, then there is an additional 2.4 GHz interface plus a 5 GHz interface. Both of these are access points created by the device to extend the Wi-Fi network.

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'ex37005'
        option encryption 'psk2'
        option key 'supersecret'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '6'
        option path 'platform/10180000.wmac'
        option disabled '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'ex37002'
        option encryption 'psk2'
        option key 'supersecret'

config wifi-iface 'extender_radio1'
        option device 'radio1'
        option network 'wan'
        option mode 'sta'
        option ssid 'Ranger'
        option encryption 'psk2'
        option key 'supersecret'

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.3'
        option netmask '255.255.255.0'
        option ipv6 '0'

config device 'lan_dev'
        option name 'eth0'
        option macaddr 'f7:48:fd:94:b5:10'

config interface 'wan'
        option 'proto' 'static'
        option ipaddr '192.168.1.3'
        option netmask '255.255.255.0'
        option ipv6 '0'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

/etc/config/firewall

config zone
        option name       'lan'
        option network    'lan'
        option input      'ACCEPT'
        option output     'ACCEPT'
        option forward    'ACCEPT'

config zone
        option name	'wan'
        option network	'wan'
        option input	'REJECT'
        option output	'ACCEPT'
        option forward	'REJECT'
        option masq	'1'
        option mtu_fix	'1'

config 'forwarding'
        option 'src' 'lan'
        option 'dest' 'wan' 

config 'forwarding'
        option 'src' 'wan'
        option 'dest' 'lan'

for my U25CWF ( only wifi no lan ) :

i place a 99_enable_wifi in openwrt\package\base-files\files\etc\uci-defaults\

#!/bin/sh
uci set wireless.@wifi-device[0].disabled=0
uci commit wireless
exit 0

i compile and no problem wifi start always

1 Like

So you know for the future, this is not a “100%” thing. In general, the AP won’t come up until the client connects.

(See the Travelmate package for ways to handle AP and client on the same radio more robustly.)

I'll check it out. Do you know why my WiFi would be running slower than it was in stock? On stock firmware I was getting 30mbps on 2.4ghz and 50mbps on 5ghz, but I've been getting between 17mbps and 21mbps today on OpenWrt.

Speed test on 2.4 GHz Extender WiFi

Speed test on 5 GHz Extender WiFi

Speed test when connected to upstream WiFi network

iw phy phy0 info


Wiphy phy0
	max # scan SSIDs: 4
	max scan IEs length: 2247 bytes
	max # sched scan SSIDs: 0
	max # match sets: 0
	max # scan plans: 1
	max scan plan interval: -1
	max scan plan iterations: 0
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Device supports RSN-IBSS.
	Supported Ciphers:
		* WEP40 (00-0f-ac:1)
		* WEP104 (00-0f-ac:5)
		* TKIP (00-0f-ac:2)
		* CCMP-128 (00-0f-ac:4)
		* CCMP-256 (00-0f-ac:10)
		* GCMP-128 (00-0f-ac:8)
		* GCMP-256 (00-0f-ac:9)
		* CMAC (00-0f-ac:6)
		* CMAC-256 (00-0f-ac:13)
		* GMAC-128 (00-0f-ac:11)
		* GMAC-256 (00-0f-ac:12)
	Available Antennas: TX 0x3 RX 0x3
	Configured Antennas: TX 0x3 RX 0x3
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * monitor
		 * mesh point
	Band 2:
		Capabilities: 0x1ff
			RX LDPC
			HT20/HT40
			SM Power Save disabled
			RX Greenfield
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			RX STBC 1-stream
			Max AMSDU length: 3839 bytes
			No DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 4 usec (0x05)
		HT TX/RX MCS rate indexes supported: 0-15
		VHT Capabilities (0x318001b0):
			Max MPDU length: 3895
			Supported Channel Width: neither 160 nor 80+80
			RX LDPC
			short GI (80 MHz)
			TX STBC
			RX antenna pattern consistency
			TX antenna pattern consistency
		VHT RX MCS set:
			1 streams: MCS 0-9
			2 streams: MCS 0-9
			3 streams: not supported
			4 streams: not supported
			5 streams: not supported
			6 streams: not supported
			7 streams: not supported
			8 streams: not supported
		VHT RX highest supported: 0 Mbps
		VHT TX MCS set:
			1 streams: MCS 0-9
			2 streams: MCS 0-9
			3 streams: not supported
			4 streams: not supported
			5 streams: not supported
			6 streams: not supported
			7 streams: not supported
			8 streams: not supported
		VHT TX highest supported: 0 Mbps
		Bitrates (non-HT):
			* 6.0 Mbps
			* 9.0 Mbps
			* 12.0 Mbps
			* 18.0 Mbps
			* 24.0 Mbps
			* 36.0 Mbps
			* 48.0 Mbps
			* 54.0 Mbps
		Frequencies:
			* 5180 MHz [36] (22.0 dBm)
			* 5200 MHz [40] (22.0 dBm)
			* 5220 MHz [44] (22.0 dBm)
			* 5240 MHz [48] (22.0 dBm)
			* 5260 MHz [52] (22.0 dBm) (radar detection)
			* 5280 MHz [56] (22.0 dBm) (radar detection)
			* 5300 MHz [60] (22.0 dBm) (radar detection)
			* 5320 MHz [64] (22.0 dBm) (radar detection)
			* 5500 MHz [100] (22.0 dBm) (radar detection)
			* 5520 MHz [104] (22.0 dBm) (radar detection)
			* 5540 MHz [108] (22.0 dBm) (radar detection)
			* 5560 MHz [112] (22.0 dBm) (radar detection)
			* 5580 MHz [116] (22.0 dBm) (radar detection)
			* 5600 MHz [120] (22.0 dBm) (radar detection)
			* 5620 MHz [124] (22.0 dBm) (radar detection)
			* 5640 MHz [128] (22.0 dBm) (radar detection)
			* 5660 MHz [132] (22.0 dBm) (radar detection)
			* 5680 MHz [136] (22.0 dBm) (radar detection)
			* 5700 MHz [140] (22.0 dBm) (radar detection)
			* 5745 MHz [149] (22.0 dBm)
			* 5765 MHz [153] (22.0 dBm)
			* 5785 MHz [157] (22.0 dBm)
			* 5805 MHz [161] (22.0 dBm)
			* 5825 MHz [165] (22.0 dBm)
	Supported commands:
		 * new_interface
		 * set_interface
		 * new_key
		 * start_ap
		 * new_station
		 * new_mpath
		 * set_mesh_config
		 * set_bss
		 * authenticate
		 * associate
		 * deauthenticate
		 * disassociate
		 * join_ibss
		 * join_mesh
		 * set_tx_bitrate_mask
		 * frame
		 * frame_wait_cancel
		 * set_wiphy_netns
		 * set_channel
		 * set_wds_peer
		 * probe_client
		 * set_noack_map
		 * register_beacons
		 * start_p2p_device
		 * set_mcast_rate
		 * testmode
		 * connect
		 * disconnect
		 * channel_switch
		 * set_qos_map
		 * set_multicast_to_unicast
	Supported TX frame types:
		 * IBSS: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * AP: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * AP/VLAN: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * mesh point: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * P2P-device: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
	Supported RX frame types:
		 * IBSS: 0x40 0xb0 0xc0 0xd0
		 * managed: 0x40 0xd0
		 * AP: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
		 * AP/VLAN: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
		 * mesh point: 0xb0 0xc0 0xd0
		 * P2P-client: 0x40 0xd0
		 * P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
		 * P2P-device: 0x40 0xd0
	software interface modes (can always be added):
		 * AP/VLAN
		 * monitor
	valid interface combinations:
		 * #{ IBSS } <= 1, #{ managed, AP, mesh point } <= 8,
		   total <= 8, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }

	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing
	Device supports TX status socket option.
	Device supports HT-IBSS.
	Device supports SAE with AUTHENTICATE command
	Device supports low priority scan.
	Device supports scan flush.
	Device supports AP scan.
	Device supports per-vif TX power setting
	Driver supports full state transitions for AP/GO clients
	Driver supports a userspace MPM
	Device supports active monitor (which will ACK incoming frames)
	Device supports configuring vdev MAC-addr on create.
	Supported extended features:
		* [ VHT_IBSS ]: VHT-IBSS
		* [ RRM ]: RRM
		* [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
		* [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
		* [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
		* [ AIRTIME_FAIRNESS ]: airtime fairness scheduling

iw phy phy1 info


Wiphy phy1
	max # scan SSIDs: 4
	max scan IEs length: 2257 bytes
	max # sched scan SSIDs: 0
	max # match sets: 0
	max # scan plans: 1
	max scan plan interval: -1
	max scan plan iterations: 0
	Retry short long limit: 2
	Coverage class: 0 (up to 0m)
	Device supports RSN-IBSS.
	Supported Ciphers:
		* WEP40 (00-0f-ac:1)
		* WEP104 (00-0f-ac:5)
		* TKIP (00-0f-ac:2)
		* CCMP-128 (00-0f-ac:4)
		* CCMP-256 (00-0f-ac:10)
		* GCMP-128 (00-0f-ac:8)
		* GCMP-256 (00-0f-ac:9)
	Available Antennas: TX 0 RX 0
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * monitor
		 * mesh point
	Band 1:
		Capabilities: 0x2fe
			HT20/HT40
			SM Power Save disabled
			RX Greenfield
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			RX STBC 2-streams
			Max AMSDU length: 3839 bytes
			No DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 2 usec (0x04)
		HT TX/RX MCS rate indexes supported: 0-15, 32
		Bitrates (non-HT):
			* 1.0 Mbps
			* 2.0 Mbps (short preamble supported)
			* 5.5 Mbps (short preamble supported)
			* 11.0 Mbps (short preamble supported)
			* 6.0 Mbps
			* 9.0 Mbps
			* 12.0 Mbps
			* 18.0 Mbps
			* 24.0 Mbps
			* 36.0 Mbps
			* 48.0 Mbps
			* 54.0 Mbps
		Frequencies:
			* 2412 MHz [1] (30.0 dBm)
			* 2417 MHz [2] (30.0 dBm)
			* 2422 MHz [3] (30.0 dBm)
			* 2427 MHz [4] (30.0 dBm)
			* 2432 MHz [5] (30.0 dBm)
			* 2437 MHz [6] (30.0 dBm)
			* 2442 MHz [7] (30.0 dBm)
			* 2447 MHz [8] (30.0 dBm)
			* 2452 MHz [9] (30.0 dBm)
			* 2457 MHz [10] (30.0 dBm)
			* 2462 MHz [11] (30.0 dBm)
			* 2467 MHz [12] (disabled)
			* 2472 MHz [13] (disabled)
			* 2484 MHz [14] (disabled)
	Supported commands:
		 * new_interface
		 * set_interface
		 * new_key
		 * start_ap
		 * new_station
		 * new_mpath
		 * set_mesh_config
		 * set_bss
		 * authenticate
		 * associate
		 * deauthenticate
		 * disassociate
		 * join_ibss
		 * join_mesh
		 * set_tx_bitrate_mask
		 * frame
		 * frame_wait_cancel
		 * set_wiphy_netns
		 * set_channel
		 * set_wds_peer
		 * probe_client
		 * set_noack_map
		 * register_beacons
		 * start_p2p_device
		 * set_mcast_rate
		 * testmode
		 * connect
		 * disconnect
		 * set_qos_map
		 * set_multicast_to_unicast
	Supported TX frame types:
		 * IBSS: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * AP: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * AP/VLAN: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * mesh point: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
		 * P2P-device: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
	Supported RX frame types:
		 * IBSS: 0x40 0xb0 0xc0 0xd0
		 * managed: 0x40 0xd0
		 * AP: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
		 * AP/VLAN: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
		 * mesh point: 0xb0 0xc0 0xd0
		 * P2P-client: 0x40 0xd0
		 * P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
		 * P2P-device: 0x40 0xd0
	software interface modes (can always be added):
		 * AP/VLAN
		 * monitor
	valid interface combinations:
		 * #{ managed, AP, mesh point } <= 8,
		   total <= 8, #channels <= 1
	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing
	Device supports TX status socket option.
	Device supports HT-IBSS.
	Device supports SAE with AUTHENTICATE command
	Device supports low priority scan.
	Device supports scan flush.
	Device supports AP scan.
	Device supports per-vif TX power setting
	Driver supports full state transitions for AP/GO clients
	Driver supports a userspace MPM
	Device supports configuring vdev MAC-addr on create.
	Supported extended features:
		* [ RRM ]: RRM
		* [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
		* [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211

iw dev wlan0 info


Interface wlan0
	ifindex 63
	wdev 0x10
	addr 3c:37:86:73:5f:11
	ssid ex37005
	type AP
	wiphy 0
	channel 149 (5745 MHz), width: 80 MHz, center1: 5775 MHz
	txpower 20.00 dBm
	multicast TXQ:
		qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcol	tx-bytes	tx-packets
		0	0	1277	0	0	0	0	238455		1285

iw dev wlan1 info


Interface wlan1
	ifindex 61
	wdev 0x10000001d
	addr 3c:37:86:73:5f:12
	ssid Ranger
	type managed
	wiphy 1
	channel 6 (2437 MHz), width: 20 MHz, center1: 2437 MHz
	txpower 20.00 dBm

iw dev wlan1-1 info


Interface wlan1-1
	ifindex 62
	wdev 0x10000001e
	addr 3c:37:86:73:5f:13
	ssid ex37002
	type AP
	wiphy 1
	channel 6 (2437 MHz), width: 20 MHz, center1: 2437 MHz
	txpower 20.00 dBm

/etc/config/wireless


config wifi-device 'radio0'
        option type 'mac80211'
	option htmode 'VHT80'
	option hwmode '11a'
        option channel 'auto'
	option country 'US'
	option txpower '20'
	option channels '36 149'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option log_level '1'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'ex37005'
        option encryption 'psk2+aes'
        option key 'supersecret'

config wifi-device 'radio1'
        option type 'mac80211'
	option hwmode '11g'
	option htmode 'HT20'
	option country 'US'
	option txpower '20'
        option channel '6'
        option path 'platform/10180000.wmac'
        option disabled '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'ex37002'
        option encryption 'psk2+aes'
        option key 'supersecret'

config wifi-iface 'extender_radio1'
        option device 'radio1'
        option network 'wan'
        option mode 'sta'
        option ssid 'Ranger'
        option encryption 'psk2+aes'
        option key 'supersecret'

/etc/config/network


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.3'
        option netmask '255.255.255.0'
        option ipv6 '0'

config device 'lan_dev'
        option name 'eth0'
        option macaddr 'f7:48:fd:94:b5:10'

config interface 'wan'
        option 'proto' 'static'
        option ipaddr '192.168.1.3'
        option netmask '255.255.255.0'
        option ipv6 '0'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

/etc/config/firewall


config zone
        option name       'lan'
        option network    'lan'
        option input      'ACCEPT'
        option output     'ACCEPT'
        option forward    'ACCEPT'

config zone
	option name	'wan'
	option network	'wan'
	option input	'REJECT'
	option output	'ACCEPT'
	option forward	'REJECT'
	option masq	'1'
	option mtu_fix	'1'

config 'forwarding'
        option 'src' 'lan'
        option 'dest' 'wan' 

config 'forwarding'
        option 'src' 'wan'
        option 'dest' 'lan'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.