Enable script at startup with procd: permission changed


When I create a script with procd, I noticed that I can't run by default when I generate an image even if it is in init.d folder. The reasons are 2:

  • 1 - permissions are not set right even if I change it in the host machine, in the target machine are different
  • 2 - the script is not enabled by default but I need to do this manually.

Is there a way to keep permissions across compilation and make a script enabled by default in OpenWrt avoiding the manual process to enable it?



Is this an OpenWrt-related question?

  • Perhaps you left out some information?
  • Are you making a custom image or something?

Solved, I was trying to build an image by myself, I am using a distro derived by OpenWRT, so the solution was removing old files. Once the permissions have been set correctly then the program was starting as expected using procd

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.