Emergency Help

Hi, I had openwrt 22.03.4 installed on a xiaomi 4a giga router and everything was fine untill I tried to install a custom build from the official firmware builder https://firmware-selector.openwrt.org
The firmware was built successfully with no errors and I tried to flash it from luci. the image uploaded without any problems and it started flashing but now, the router doesn't boot up and I can't establish a persistent connection to it. What do I have to do to fix this?
It's been around 10 minutes and the router isn't booting yet. I turned it off and I'm waiting for someone to help

The first thing that comes to mind: Custom builds from the firmware selector do not contain LuCI (the user interface) by default, unless you specifically included it. Have you tried accessing your device via SSH (See how: https://openwrt.org/docs/guide-quick-start/sshadministration)?

I had luci among the packages to be installed. What I'm saying now that the router is not booting at all. I'm connected to the router by a LAN cable but the adaptor still says that cable is unplugged!

I imagine it would be helpful for debugging and for maintainers and other users of that device, if there were more info:

  • the version number of your custom build (was it snapshot, or stable OpenWrt?)
  • the custom packages you installed
  • did you choose to retain the old configuration files during flash or not?
  • what was your initial flash method to bring OpenWrt to this device? - The device page lists multiple ones.
  • does the device really not boot (e.g. light-bulbs do not shine etc.) or is there simply no connection to the client?
  • ...

I found some info about debricking this device, so you could try those methods: https://openwrt.org/inbox/toh/xiaomi/xiaomi_mi_router_4a_gigabit_edition#debricking

That said, since you used a custom build, the risk was on you...

Since I don't own this device and have not followed its history and support tickets, maybe some other forum members can step up.

1 Like

plus the size of the image.

Nevermind, I debricked the router using the official xiaomi miwifi repair tool as specified in the router page. Thanks anyway

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.