EDUP EP-RT2960 AX1800 - Strange OpenWRT router

Good News.
I took an deep dive and tried the firmares.
First i tried the SIMAX1800T. After the upload the openwrt installed says that it´s not compatible with the version HAR-20S2U1.
So I tried the HAR-20S2U1 version, and it accepted the firmware without complains and flashed perfectly, even with the same configuration.
I´ll test a little better.
If it´s working normally, how I could report that this EDUP is compatible with HAR-20S2U1?

Great,

I'm with @brada4 here, the layout is exactly the same.

How and where I can report that this firmware works?

You would just report it here.

Three things that can be done, to make it official.

  1. We can create a data entry on Table of Hardware for this model:
    https://openwrt.org/supported_devices/adding_to_toh
    After this the model can be found on the ToH and we can link to the existing images for the HAR-20S2U1.
    (There is a slight problem, that the brand name doesn't exist on the ToH yet. We would need help of a Wiki admin for adding a new brand)
  2. Document the support on the device wiki page.
    The existing device page https://openwrt.org/toh/sim/simax1800t needs a bit of work.
  3. Someone can create a PR and add the EP-RT2960 as alternative model of the HAR-20S2U1 in the Makefile.
    When this gets merged the model can be found on the firmware selector as well.
    Only for snapshots first and then for the later releases.
1 Like

The typical tests are radio calibration data, like you cannot exceed 10dBm is a problem, and if MAC addresses match those in OEM firmware and device labels.

Also worth checking all leds on/off, if something is wired differently it might be one LED control GPIO is wired to 5GHz wifi power but seems unlikely.

1 Like

I brick my router … the router has serial pin soldered :smile: :smile: flashed with TFTP from server 192.168.1.254; Router is 192.168.1.14 (openwrt-23.05.3-ramips-mt7621-haier_har-20s2u1-initramfs-kernel.bin)

After that I flashed my EDUP EP-RT2960 AX1800 with openwrt-23.05.3-ramips-mt7621-haier_har-20s2u1-squashfs-sysupgrade.bin >>it works
I confirm LED work correctly, I have disabled

Welcome to the party (forums). Can you check MAC and wifi power are ok?

wifi power work great test 2g 5g from 1mw to 100mw
for MAC ??? i have mac in wifi Vendor / Company Shenzhen Century Xinyang Technology Co., Ltd Country Code CN

1 Like

Where do I get it?

ip link
ethttool -P eth0

1C:BF:CE Shenzhen Century Xinyang Technology Co., Ltd

Please delete your post and hide MAC addresses, it was enough to confirm MAC address matches one on the box/label and does not change rebooting

Does the mesh capability work?

I didn´t test it. I´m using it as an access point with 3 vlans with 7 SSIDs in total with more or less 30 clients. And it works perfectly.

1 Like

I also got this router - it shipped with snapsot version : OPENWRT 24.04_b202405071017 Noble / LuCI (no branch) branch 24.127.50611~98705ec
and kernel 6.6.30.

Can anyone confirm that flash with openwrt-23.05.3-ramips-mt7621-haier_har-20s2u1-squashfs-sysupgrade.bin all features works properly and what speed did you get out of it?

Mine is working perfectly.