Edimax EW-7478APC not accessible after installing, defaulting to dumb switch mode


I have an Edimax EW-7478APC router on which I'm trying to install OpenWRT. I followed this wiki (https://openwrt.org/toh/edimax/ew-7478apc) and installed OpenWRT v22.03.2 through the OEM GUI. The upgrade process went without errors and the router restarted. After coming back online, the following happened:

  • Wifi 2.4/5 Ghz: Off
  • ISP connection to WAN port: Nothing happens
  • Laptop to LAN: No DHCP. Tried setting manual to - 1.2 - 2.1 - 0.1 without success. ssh also not working.

Then I tried to plug my ISP into one of the LAN ports and suddenly got DHCP on my laptop from the main ISP router. This leads me to believe that the router is acting as a dumb switch.

Is there a way to prevent it from defaulting to a switch after installation? As switches don't have IPs, I will not be able to access it to change configuration.

I'm able to re-flash the OEM firmware through tftp.

Thank you,

This is the default in openwrt.

Then your flash probably wasn't successful, unless you ISP is caching MACs.

Even a dead/bricked router will do this.

Check your router's manual if the bootloader have any type of web or tftp recovery option.
If not then get a USB to serial converter
For example CP2102
Connect it with your router's serial pins & post the serial dump here.