EdgeRouterX bricked: why did it happen?

I bricked a router: Edgerouter X with OpenWRT. I did manage to reflash it, so everything is OK now.
But I want to know why it got bricked: I just wanted to create a new interface with vlan 17, with IP range 192.168.0.xx. The only mistake I know I made was, I set the interface with a static IP, while a port with untagged vlan 17 was connected to a switch with a static IP

I clicked “save and apply”, then I got a phone call and had to go, I waited till “applying config changes” message goes away, took my laptop out and left. All my access points lost connection right after that, and as I came back, my laptop got no IP, I couldn’t get into Luci or ssh, either with DHCP or Static IP (the management interface is 192.168.1.xx, it was left intact, but it didn’t work).
I don't think I did anything else wrong, because after I reflashed the router, I created the same thing, but this time, with, and it was all fine.

I know it’s wrong and bad, but is bricking of the router expected as a consequence of this kind of mistake? And, if I had left my laptop connected, then would the router have reverted the “save and apply” ?

Like I said, it's now all fine, but I would like to know why this happened. I would appreciate your info!

It's unclear without details of your configuration what you did that caused no access.
While you advise it was bricked, you would have still been able to connect via UART to the prepopulated serial port and changed the configuration or reset without having to reflash.

Why would it have been bricked? An IP conflict like you suggest yourself would have similar symptoms (your EdgeRouter being unreachable because the IP was already taken).

1 Like

Thank you for your replies!
The main IP address, so to say, of the router is, and that belongs to VLAN16. I have two more VLANs: 11, and 15, with address range and I wanted to create another one with, in order to see if I can access to the TP-Link switch I recently bought as used: I couldn't get to GUI using static IP on my laptop. But then I forgot that should be avoided. But I still had a VLAN16 untagged port, and I connected my laptop using that port, as I discovered that I'm not getting IP address. If the conflict of was the only issue, I would guess that the problem is within 0.xx network, I should have been able to access to the router under as usual. And all my APs have IP addresses 1.xx, and I don't understand why they didn't work anymore....

Could that be that, since this TP-Link switch is actually defect, it killed EdgeRouter?

All these UART or opening up the router/AP and soldering to serial port kind of things are still a bit too advance for me.... besides my EdgeRouterX is relatively new, I don't want to void the warranty...

If you are inside the US opening a device does not void the warranty regardless of what the manufacturer leads to you to believe.

1 Like

It doesn't make sense to add additional networks to your main router to access these devices (aside from creating a management network, if desired) -- instead, the switch should be configured to work within your existing subnets.

You should follow the TP-Link instructions for resetting the switch to defaults (since you don't know what state it is in from the previous owner), and then you should configure it (using the manual as needed) by directly connecting your computer to the switch such that it work with the subnet that you wish to use for management (be that your trusted lan, or a separate infrastructure/management network).

Possible, but unlikely that it is defective. It is more likely you set a bad configuration on your ER-X.

As @RaylynnKnight stated, you can open the device without voiding your warranty. No soldering required -- the pins are already populated. You just need a USB to UART-serial adapter (3.3V).

Thank you for your replies!

I didn't know ! (Except, I'm in Germany, not in the US. Is it also the case?)

I did a factory reset in the way I understood from the manual, pressing the reset button for more than xx seconds. I could ping to But using static IP on my laptop directly connecting, I couldn't open the GUI. More precisely, it looked like it did open, but only an empty page shows up. I changed the browser, deleted cache etc, but didn't make difference.
Later the seller confirmed that he never configured anything, he never tried to open admin page (i.e. he just used the switch as a non-managed switch), and let it just stored for 3 years, and put it for sale without testing again. (He decided to give money back to me, so it's OK.)

Now, I omitted the explanation why I wanted to set up a network for it: this switch comes with a management software, which is usually not necessary. But since static IP+GUI didn't work, I wanted to give it a try. Now, it's only for WIN, and I only have WIN inside Virtualbox. Using static IP for Virtualbox is a bit annoying, because I have to set my Mac static IP, set the Virtualbox WIN with bridge-adapter, then inside Win I have to set static IP (and then I have to reverse the process in order to access other devices in my network) But if I create a network with 0.1, then I only have to set VB to bridge-adapter, that's why I did so.

Since I already reflashed ERX, I don't need UART for it, but I would like to try it on this dead Switch SG105E. Does it also work for it?

Now, in case someone is interested, I'm going to write what happened with SG105E: it turned out to have a bug with DHCP forwarding, as TP-Link acknowledges on their webpage. This SG105E "Version 1", does not have a web-GUI.
I was scared of connecting the switch to the router again at all, so in the end I just did Static IP on my PC and Virtualbox, and used the management software from TP-Link: I did get to the switch. I flashed the new firmware, where they fixed the bug. Then it worked !

I still haven't understood why ERX got brick.... but I think I don't quite understand how "devices" (in OpenWRT) work, I guess, if the router has various IPs,, and 2.1 and so on, then if another hardware with conflicting static IP comes in, everything gets messed up. Is that right?