Edgerouter X wiki points to not working .BIN and other thingies

Couldn't agree more - getting a TTL cable was life changing..

I've bricked ERX after trying to revert from OpenWRT snapshot to EdgeOS - and at that point getting the cable was the only option. The benefit is now I can play with flashing the ERX without any fear as there's always a TTL cable around.

On another note, I also had to get initramfs-factory.TAR from the same source as you did - that was about a year ago.

Photos of the TTL cable connected to the ERX: https://i.imgur.com/xNX2CiX.jpg ; https://i.imgur.com/L3E2yhl.jpg


Is the only way to upgrade an Edgeroute X to Openwrt 19.07.01 via a ttl cable then if you are running 18.06?

Yes, AFAIK the only way which seems to be reliable (as in "will work almost certain") by now is using a ttl cable. Even if you try another way (which might work as some report it does for them) you should consider having one as it is your "last line of defense"

1 Like

If I buy a new one EdgeRouter X ER-X, will I be able to install openwrt 19.07.1 without cables?

My results (I had a batch of 10 new devices): Most of the times I was able to first install 18.06.6 which is the only one providing a suiteable small install image and then upgrade to the latest 19.07. But also during this time at least 3 devices went into the reported boot loop. Installing 19.07 directly via serial cable command interface was working for these devices.

So keep your serial cable prepared. You might be lucky but it might fail as well. I was not able to find the differences between the working and the non working devices.


After using it for a couple of weeks I notice the device will freeze or something.

All the LAN ports and WAN port will blink like there is traffic but the device becomes unreachable via the network and all NAT traffic on all ports to WAN stop also.

When this happens I pull the power plug and after 15 seconds or so I put it back in to boot it again.

This happened three times now already. First with 18.06, then later again with 19.07 and now 2 weeks later with 19.07.1 again.

Seems something isn't going right after awhile. I read somewhere that it might be hardware offloading but I did not enable or disable it on 19.07.*.

1 Like

Can you may be connect a console to collect the output when the issue arrives?

Mine used to sometimes freeze on snapshots - though I haven't been running those roughly since August. Also I build from source, so I've always presumed I screwed up some kernel parameters, hence it was acting wonky.

18.0* and 19.07.*. - both build from source without touching make kernel_menuconfig options have been running fairly well - I don't recall the last time I had to powercycle the thing.

1 Like

I noticed one crash on 18.06.07 and random switch port drops as well. It turns out there are one or more bugs related to the mt7530 switch used in the ER-X. It seems to manifest most often under significant switch load and use of ethernet "pause frames". I found it interesting to read about, but I'm not sure how to help along a solution.

Has anyone been able to successfully upgrade from 18.06 or any other version to 19.07 on the ERX (without using a TTL cable)? I'm currently stuck

I had no problems so far.

Started on v1.10, downgraded to 1.7, flashed LEDE r4434-b91a38d, then 18.06.5 and finally did an upgrade to 19.07 and 19.07.1.

Though I have to say that I build my images using image builder and do the upgrade using sysupgrade via ssh, not luci. So far I never needed the TTL cable though I bought one just to be sure.

Hi @gone - as per my statistics the upgrade from 18.06.x to 19.07.x is not always working.
I do have several devices without issues and others that did not went successfully. I'm not sure if this issue is related to some HW revision or another trigger hits in. I'm sure that also the reason why some ppl reporting successful updates while others don't.
In my case I only updated every devices once, so I can elaborate more.
Have a nice day!

1 Like

Updated firmware on ER-X from 18.06 to 19.07.02 directly from ssh cli in /tmp with sysupgrade -n parameter.

Works perfectly, though atm only with software offloading. Fix for this can be found here:

1 Like

I've tried 19.07.1 and 19.07.2 on my ER-X (keeping settings), and the WAN DHCP client would not get an IP address from my ISP. I lost internet access. In each case, I flashed the current snapshot and everything worked fine again. I'm currently running r12464 snapshot, which has run perfectly stable since 19.07.2 failed (27 days and counting). Very frustrating - but no complaints - r12464 is running like a champ.

@csensitive : are you running multiple VLAN's on your ER-X? Differences in my configuration that differ from the default are: I have multiple VLANs defined, each providing a DHCP server to each VLAN, for home LAN, IOT, guest WiFi and security; software flow offload is checked; and I'm running layer CAKE SQM on my WAN (bonded VDSL2 2/40 ISP). Other than that, nothing weird in my set up. I'm a fan of using stable, but not when it doesn't work - so I'm curious about your working install of 19.07 on your ER-X.

1 Like

@csensitive : are you running multiple VLAN's on your ER-X?

I'm running the default VLAN settings (wan and lan).

I changed the WAN IP from dynamic to static, but before I changed it obtained a dynamic IP from DHCP. But I changed to static immediately so I can't confirm if it worked properly.

I've noticed some issues from my own setup when sysupgrading and especially when when between major upgrades and when resetting. I haven't been looking into if it's my ISP or the firmware, but sometimes I have to wait some time (from minutes to hours) before I have throughput from my wan to my wan gateway. Have you tried waiting some hours to check if it clears?

I used to have hardware offload enabled, but until it merges I just have default for now without any offloading. Might build HW offloading it into 19.7.2 if I get impatient.

Btw. be careful with keeping settings if you experince issues. You could try with a fresh 19.7.2 firmware without your normal setup and check if works. If it does build it again and keep checking where it breaks.

Good luck.

1 Like

Operational OpenWrt 19.07.2 Factory Tar file for EdgeRouter X helped me get over the 18.x -> 19.x upgrade hurdle. Hope it helps other folks as well.

1 Like

What you need to do, as sysupgrading from 18.X to 19.x doesn't work, is to reflash your router with its original EdgeOS firmware, and then do the trick I have mentionned in my posts.

It works.

I did it several times.

If you need the Ubiquiti signed factory image of the original firmware of the router, you can find it on ubiquiti website, or if you want I can send you a link of the copy I have from it.

Once your router is back with its original EdgeOS firmware, you follow my procedure, and it will work. Garanteed. If you need more help, ask.

You may not know how to reinstall the original EdgeOS firmware.
You need to tftp the ubiquiti edgeOS firmware.

I can write a small procedure to describe you how to do this, but it is also available on ubiquiti website.


Do you know the procedure to restore the EdgeOS on your router ?

Have you ever done this famous restore TFTP procedure to address to restore the original factory EdgeOS firmware ?

The procedure I have described in my post you are refering to with the operational Tar file was intended to install OpenWRT 19.07.2 on top of a EdgeRouter with what ever version of EdgeOS installed on it (With the EdgeOS "add system image" command).

But NOT TO UPGRADE a 18.x to 19.x OpenWRT on your EdgeRouter with openWRT command "sysupgrade", which is known NOT TO WORK. It should but it doesn't. Sysupgrade only works well between 18.x versions, or 19.x versions, but doesn't work for sysupgrading from 18.x to 19.x, this is why I am asking you to restore the original EdgeOS on your router, and then, from here, use the Tar file I provided.

  • Factory Tar files are for initial installs under EdgeOS with "add system image" command.
  • Sysupgrade Bin files are for successive OpenWRT system upgrade under OpenWRT "sysupgrade" command.
1 Like

That worked.

I installed 19.07.3 without keeping settings, installed the packages I use, rebuilt my configuration from scratch and rebooted both my router and bonded VDSL2 modem (a Sagemcom Fast 4320 in bridge mode).

19.07.3 is working fine on my EdgeRouter X now. Must have been a gremlin in my old configuration somewhere.


Hello, sorry for replying to an old post. I'm hoping you see this and can assist me in flashing openwrt onto my edgerouter x. It's currently running stock edgeos firmware (1.*).

I'm a complete noob when it comes to these things, I've read your post but still don't understand any of the commands. I've also read the wiki for the edgerouter x but there's so much info jumbled up I don't know what is what. Are you able to provide step by step instructions so I don't mess anything up? Keep in mind I've never done anything like this before. At the moment all I have downloaded is PuTTY which will be my first time using as well. Appreciate any help, thank you.