EdgeRouter-X DSA, what is it?

What is the "dsa", how can I use it and is it worth the effort ?

Are you aware that we have search engines for www content? This is a somehow easy to answer question...
Spoiler, yes you need it.

I watched two video where they dove into dsa, but networking just isn't one of my strong points. Then I read the dsa-mini-tutorial and got even more confused. I think all n all my searches did more harm than good.

So I understand your pov but no, I have no clue.

The device named "dsa" is an internal connection that exists in the kernel and thus appears in this list which is simply a dump of all kernel devices.

Don't use it in configurations. It isn't possible to send usable packets directly to or from it.

1 Like

Query: Linux Kernel DSA. That's the first hit: https://www.kernel.org/doc/Documentation/networking/dsa/dsa.txt

Skip the implementation details but the overview might explain it.
If you still have questions, sure, ask them...

1 Like

Here we go, so can i deduct that dsa can be used some sort of offloading ?

I was thinking to replace the current:

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'eth2'
	list ports 'eth3'
	list ports 'eth4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.1'
	list dns '192.168.1.1'

with this:

config switch 'switch0'
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan 'vlan1'
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth1.1 eth2.1 eth3.1 eth4.1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

That would do it ?

Nope. That will break it. Soft-brick specifically.

What are you trying to achieve? If you are not using VLANs, you don’t need to mess with it at all.

1 Like

I'd like to use the dsa chip to offload. At least that is what I got from the information I read, but to be honest, I'm still clueless.

Dsa is the “distributed switch architecture “. It only relates to switching.

Are you talking about routing offloading? Or just making sure that the lan-to-lan traffic flows through the switch itself?

Would there be any utility in hiding it for simplicity? if it can't be used?

Just my minimalism/less is more thought

Are you talking about the LuCi entry called Ethernet Switch: "dsa" or the entire thing?

LuCI just reflects what is available at the kernel. It would require special code to suppress that, which could have unintended consequences.

Nobody ever said that it couldn't be used. DSA is a required part of the system. That specific entry in LuCI should not be used, but the rest of the stuff you see there, and critically all of the DSA related configs in the text configuration file are necessary and useful.

1 Like

I see, thanks

That's what I wanted, to use the switch inside the ERX.

If you're using your ER-X as a router where eth0 is the wan and eth1-eth4 are the lan ports, you don't need to make any changes. All lan-lan connections that go through eth1-eth4 will be sent through the switch per the default configuration.

If this is not your use case and/or you have other questions, please provide specifics about what you are trying to achieve.

1 Like

Ya I think your right why even have a Openwrt forum when Google knows everything,In fact don't stop at openwrt forum get rid of all forums Google is so smart

Are you so young that you no longer know the concept of giving even the slightest amount of attempting and try to find answers to a question on your own at first, and only bother others if you get stuck?

In that case, I'm good :smiley:

Oh, and before I forgot. I could not figure out why performance had gone down, which was mainly the reason for this endeavor. But I forgot to turn on hardware offloading :blush: and that made me go at ~50%. Turned it on, and back performance.

Yay!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.