ECONNREFUSED - Verbindung durch Server verweigert

Hi,

I am very new here. Searched for my problem but didn't find answer.

I changed the original firmware for my TP-Link Archer C7 V5. I used the openwrt-ath79-generic-tplink_archer-c7-v5-squashfs-factory.bin. It updated. The router starts. But I just cannot reach it. When I connect directly to my PC, the IP is 192.168.1.1.... sounds good... but something still must be wrong. My browser says "Fehler: Netzwerk-Zeitüberschreitung" (engl: It takes to long for an answer) and an ftp-programme says:

Status: Verbinde mit 192.168.1.1:21...
Status: Verbindungsversuch fehlgeschlagen mit "ECONNREFUSED - Verbindung durch Server verweigert".
Fehler: Herstellen der Verbindung zum Server fehlgeschlagen
Status: Nächsten Versuch abwarten...

Anybody any ideas? :open_mouth:

Thank you,
Torsten

You have installed a snapshot version of OpenWrt, which does not come with preinstalled LuCI.

https://openwrt.org/releases/snapshot
https://openwrt.org/docs/guide-user/luci/luci.essentials

Thank you.

So you think it worked and i „just“ have to complete my work?

I will do my best!
Torsten

You should be able to connect via ssh.

Hi there,

I can connect and log on. I have also uploaded the needed installation files:

luci_0.11.1-1_ar71xx.ipk
luci-app-firewall_0.11.1-1_ar71xx.ipk
luci-i18n-english_0.11.1-1_ar71xx.ipk
luci-i18n-german_0.11.1-1_ar71xx.ipk
luci-lib-core_0.11.1-1_ar71xx.ipk
luci-lib-ipkg_0.11.1-1_ar71xx.ipk
luci-lib-nixio_0.11.1-1_ar71xx.ipk
luci-lib-sys_0.11.1-1_ar71xx.ipk
luci-lib-web_0.11.1-1_ar71xx.ipk
luci-mod-admin-core_0.11.1-1_ar71xx.ipk
luci-mod-admin-full_0.11.1-1_ar71xx.ipk
luci-proto-core_0.11.1-1_ar71xx.ipk
luci-proto-ppp_0.11.1-1_ar71xx.ipk
luci-sgi-cgi_0.11.1-1_ar71xx.ipk
luci-theme-base_0.11.1-1_ar71xx.ipk
luci-theme-openwrt_0.11.1-1_ar71xx.ipk

But when I want to install the first package it says:

root@OpenWrt:~# opkg install luci-proto-core_0.11.1-1_ar71xx.ipk
Unknown package 'luci-proto-core'.
Collected errors:

  • pkg_hash_fetch_best_installation_candidate: Packages for luci-proto-core found, but incompatible with the architectures configured
  • opkg_install_cmd: Cannot install package luci-proto-core.

I am pretty sure I down- and uploaded the right package for the Archer C7 V5... but what can be the reason that it is incompatible?
Torsten

These files are ancient, and for the wrong architecture. Please grab them from here: https://downloads.openwrt.org/snapshots/packages/mips_24kc/luci/

Which of the thousands? :scream:

I am so sorry... think I am not made for this... :roll_eyes: but now I have to finish it somehow...

I think it is simpler to configure internet connectivity via the SSH terminal and then install luci using the package manager. What kind of connectivity do you have? Cable, DSL or something else?

cable. but I use the Archer C7 just as an access point. It is behind a modem/router in my network and when uploading/removing/installing files I put it directly to the PC at the moment to connect with ssh

Then I suggest the following:

Assuming your network uses 192.168.10.*, run the following commands via SSH:

uci set network.lan.ipaddr=192.168.10.123  # pick a free IP
uci set network.lan.netmask=255.255.255.0
uci set network.lan.gateway=192.168.10.1  # IP of your modem/router
uci set network.lan.dns=8.8.8.8  # Google DNS
uci commit network

Change 192.168.10.123 and 192.168.10.1 accordingly if your network differs.

Connect the Archer with one if its LAN ports to one of the modem/routers LAN ports and powercycle the Archer.

You should now be able to simultaneously SSH to your Archer at 192.168.10.123 (or whatever IP you've chosen), be connected to your normal network with your PC and have the Archer download things from the internet.

Verify connectivity on the Archer: ping -c1 google.com and proceed with opkg update; opkg install luci; reboot

okay... I will do my best and let you know.

Thanks a lot so far :smiley:

WOW :smiley:

I am SOOOO thankful... It worked! You did a really great job in coaching me! Thanks, thanks, thanks!

:smiley:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.