EasyBox 904xDSL - Lan1 port as wan HELP

Hi
I recently got an free Vodafone EasyBox 904xDSL, which has nice specs and openwrt support. I want to use it as an DHCP client behind an router to replace my current old TP Link.
After installing Openwrt and configuring it, it started to work. But the problem is, that the WAN/DSL port is only
100M/Base-T which sucks. The other 4 Lan ports work just fine on 1Gig. I used lan ports as wan ports other routers on Openwrt and it worked fine, but here are 2 switches, one lantiq xrx200 and one rtl8367. The xrx200 indentifies as switch0 and the rtl as switch1. I cant get LAN1 port to work as wan. Please help. @Zuzia

//Thanks for help, thats my first post so maybe I posted it wrong or so

Do yourself a favour, pick some other hardware for your endeavour. Aside from the EB-904xDSL not being formally supported by OpenWrt yet, the switch setup and wireless situation are rather tricky (very tricky). For the details you will have to walk through the initial device exploration on the archived (old) forum threads, but it's going to be complicated - and devices that will beat (single-core lantiq at 500 MHz mips 24Kc is not fast by today's standards) the EB 904xDSL in every regard (apart from the display, which comes with its own share of pain in terms of OpenWrt support or just making it do anything but the default setup) start around 5-10 EUR on the used markets.

@Baticzek
It is possible to use one of the LAN ports as a WAN. First install OpenWrt, the 'WAN for ETH' version:

Change the network configuration, you can use the terminal from Luci: http://192.168.1.1/cgi-bin/luci/admin/services/ttyd

sed -i 's|eth0.2|eth0.7|g' /etc/lcd4linux.conf
sed -i 's|eth0.2|eth0.7|g' /etc/speed
uci set network.@device[2].name='eth0.7'
uci set network.wan.device='eth0.7'
uci set network.@switch_vlan[2].ports='0 1 2 4 6t'
uci commit network
cat << EOF >> /etc/config/network

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option vid '7'
	option fid '7'
	option ports '0t 6t'

config switch_vlan
	option device 'switch1'
	option vlan '7'
	option ports '3 6t'

EOF

Restart the router. The port labeled 4 is now working as WAN.

1 Like

Thanks fot the reply @Zuzia . I ran all commands but it still doesnt work :confused:
It changed wan from eth0.2 to eth0.7 but it doesnt get an IP.

I installed this firmware: openwrt-lantiq-xrx200-arcadyan_vgv952cjw33-e-ir-smp-eth-squashfs-sysupgrade.bin

Here are som screenshots.


Cable plugged into LAN4 Port

NEVERMIND
It Works, i had to reset the router and type reboot instead of flipping the switch. Now everything works. Thanks you saved the router from being trashed @Zuzia

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.