I have two EAP225:
TP-Link EAP225-Outdoor v1
TP-Link EAP225-Outdoor v3
I already checked the network cables by connecting them directly to my computer and I have 300 megabytes on both, the problem is that the router's WiFi only gives me 40-60 megabytes in the 2.4 G network and in 5G hopefully 80 megabytes.
Any idea what the problem could be? I have tried to export its configurations to show them but I don't know how to do it. If you can explain them to me, I will gladly attach them.
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:

Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
This is me configuration for one:
root@EAP225-Medidor:~# ubus call system board
{
"kernel": "5.15.137",
"hostname": "EAP225-Medidor",
"system": "Qualcomm Atheros QCA956X ver 1 rev 0",
"model": "TP-Link EAP225-Outdoor v1",
"board_name": "tplink,eap225-outdoor-v1",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.2",
"revision": "r23630-842932a63d",
"target": "ath79/generic",
"description": "OpenWrt 23.05.2 r23630-842932a63d"
}
}
root@EAP225-Medidor:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd8f:6411:0d25::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'lan'
option device 'br-lan'
option proto 'dhcp'
root@EAP225-Medidor:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'pci0000:00/0000:00:00.0'
option channel 'auto'
option band '5g'
option htmode 'HT40'
option cell_density '0'
option txpower '23'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/ahb/18100000.wmac'
option channel 'auto'
option band '2g'
option htmode 'HT40'
option txpower '23'
option cell_density '0'
config wifi-iface 'wifinet2'
option device 'radio0'
option mode 'ap'
option ssid 'VentaInternet_86283885_5G_1'
option encryption 'none'
option key 'FamiliaCV2019'
option network 'lan'
config wifi-iface 'wifinet3'
option device 'radio1'
option mode 'ap'
option ssid 'VentaInternet_86283885_1'
option encryption 'none'
option key 'FamiliaCV2019'
option network 'lan'
root@EAP225-Medidor:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option localservice '1'
option ednspacket_max '1232'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config domain
option name 'lle.login.internet.in'
option ip '10.5.50.1'
And for the other i have this:
root@EAP225-Colegio:~# ubus call system board
{
"kernel": "5.15.137",
"hostname": "EAP225-Colegio",
"system": "Qualcomm Atheros QCA956X ver 1 rev 0",
"model": "TP-Link EAP225-Outdoor v3",
"board_name": "tplink,eap225-outdoor-v3",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.2",
"revision": "r23630-842932a63d",
"target": "ath79/generic",
"description": "OpenWrt 23.05.2 r23630-842932a63d"
}
}
root@EAP225-Colegio:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd75:8848:173c::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'lan'
option device 'br-lan'
option proto 'dhcp'
root@EAP225-Colegio:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'pci0000:00/0000:00:00.0'
option channel 'auto'
option band '5g'
option htmode 'HT40'
option txpower '23'
option cell_density '0'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/ahb/18100000.wmac'
option channel 'auto'
option band '2g'
option txpower '23'
option cell_density '0'
option htmode 'HT40'
config wifi-iface 'wifinet3'
option device 'radio0'
option mode 'ap'
option ssid 'VentaInternet_86283885_5G_2'
option encryption 'none'
option key 'FamiliaCV2019'
option network 'lan'
config wifi-iface 'wifinet4'
option device 'radio1'
option mode 'ap'
option ssid 'VentaInternet_86283885_2'
option encryption 'none'
option key 'FamiliaCV2019'
option network 'lan'
root@EAP225-Colegio:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option localservice '1'
option ednspacket_max '1232'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config domain
option name 'lle.login.internet.in'
option ip '10.5.50.1'
Are you using a 2x2 wifi-5/6 device to measure the speeds? (Most smartphones are only 1x1)
fwiw, the EAP225 is a 2x2 AC wifi device with underpowered QCA95xx chipset. imho, you will get best speeds using stock firmwares.
If you change the 5 GHz wifi to use 80 MHz bandwidth, you may be able to raise the speed above 80 Mbps. Unlikely you will achieve 450+ Mbps with OpenWrt btw.
Hello,
The problem is I don't have the option to use 40 MHz in 5G.
Try changing the mode. Wireless N only supports up to 40 MHz
This fix for version V3 but nor for the version V1.
Perhaps check if the missing 80 MHz issue exist in older OpenWrt 21 and 22. (Do no 'keep settings' and make sure you select the correct squashfs-sysupgrade file to prevent bricking your v1)
Otherwise, raise a bug report. fwiw, don't expect a fix real soon.
https://openwrt.org/bugs
(I can see bug reports for EAP225 v3. None for v1)