EAP-TLS WiFi Repeater initial connection problem

Hello everyone,

i have configured an eap-tls wifi repeater on a 8devices lima board. EAP-TLS Repeater config

This works pretty well so far except for one problem.

Clients cannot connect to the repeater's access point after booting. If i restart the wifi manually the clients can connect without problems. I reboot the wifi via the web interface or the wifi command.

I have tested it with an ios device an android device and a windows 11 device. All with the same behavior.

Originally the whole thing ran on openwrt 22.03.5 in the meantime i also tried it with OpenWrt snapshot r23676-57fda4b743. Both versions showed the same behavior.

I also tried to replace wpad-openssl with wpad-mbedtls but again both variants behave identically.

I also thought it might be the automatic channel selection, but the error also occurs with fixed channels.

The Radius server runs with freeradius 3.

If a client cannot authenticate there is no response on the radius server.

Maybe someone has an idea what could still be debugged or recognizes something.

Configuration

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd25:7e0c:4f75::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.0.175'
	option netmask '255.255.255.0'
	option gateway '192.168.0.222'
	list dns '192.168.0.222'
	option ip6assign '60'
	option broadcast '192.168.0.255'

config interface 'wwan'
	option proto 'dhcp'
	option device 'phy0-sta0'

config interface 'relay'
	option proto 'relay'
	option ipaddr '192.168.0.175'
	list network 'lan'
	list network 'wwan'

/etc/config/wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option channel 'auto'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'
	option log_level '0'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'sta'
	option network 'wwan'
	option ssid 'RADIUS-AP'
	option encryption 'wpa2'
	option eap_type 'tls'
	option priv_key_pwd 'test123'
	option identity 'repeater.accesspoint@test.com'
	option ca_cert '/etc/ssl/repeater/ca.pem'
	option client_cert '/etc/ssl/repeater/client.crt'
	option priv_key '/etc/ssl/repeater/client.key'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Radius-Test-10'
	option encryption 'wpa2'
	option auth_server '192.168.0.44'
	option auth_secret 'authPassword123'
	option network 'lan'
Logs

Client authentication fail

Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: authentication OK (open system)
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 MLME: MLME-AUTHENTICATE.indication(ee:a9:be:a1:7e:a5, OPEN_SYSTEM)
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 MLME: MLME-DELETEKEYS.request(ee:a9:be:a1:7e:a5)
Fri Aug  4 08:32:08 2023 daemon.info hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: authenticated
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: association OK (aid 1)
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: did not acknowledge association response
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: authentication OK (open system)
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: event 0 notification
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 MLME: MLME-AUTHENTICATE.indication(ee:a9:be:a1:7e:a5, OPEN_SYSTEM)
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 MLME: MLME-DELETEKEYS.request(ee:a9:be:a1:7e:a5)
Fri Aug  4 08:32:08 2023 daemon.info hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: authenticated
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: association OK (aid 1)
Fri Aug  4 08:32:08 2023 daemon.info hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: associated (aid 1)
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 MLME: MLME-ASSOCIATE.indication(ee:a9:be:a1:7e:a5)
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 MLME: MLME-DELETEKEYS.request(ee:a9:be:a1:7e:a5)
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: binding station to interface 'phy0-ap0'
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: event 1 notification
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: start authentication
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: start authentication
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: unauthorizing port
Fri Aug  4 08:32:08 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-STARTED ee:a9:be:a1:7e:a5
Fri Aug  4 08:32:08 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=1
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 1)
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAP packet (code=2 id=1 len=26) from STA: EAP Response-Identity (1)
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: STA identity 'tim.smith@test.com'
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: RADIUS Sending RADIUS message to authentication server
Fri Aug  4 08:32:08 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 3 seconds
Fri Aug  4 08:32:11 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Resending RADIUS message (id=0)
Fri Aug  4 08:32:11 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 6 seconds
Fri Aug  4 08:32:13 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAPOL-Start from STA
Fri Aug  4 08:32:13 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: event 5 notification
Fri Aug  4 08:32:13 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: aborting authentication
Fri Aug  4 08:32:13 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-STARTED ee:a9:be:a1:7e:a5
Fri Aug  4 08:32:13 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=1
Fri Aug  4 08:32:13 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 22)
Fri Aug  4 08:32:13 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAP packet (code=2 id=22 len=26) from STA: EAP Response-Identity (1)
Fri Aug  4 08:32:13 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: STA identity 'tim.smith@test.com'
Fri Aug  4 08:32:13 2023 daemon.debug hostapd: phy0-ap0: RADIUS Sending RADIUS message to authentication server
Fri Aug  4 08:32:13 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 3 seconds
Fri Aug  4 08:32:16 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Resending RADIUS message (id=1)
Fri Aug  4 08:32:16 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 1 seconds
Fri Aug  4 08:32:17 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Resending RADIUS message (id=0)
Fri Aug  4 08:32:17 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 5 seconds
Fri Aug  4 08:32:18 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAPOL-Start from STA
Fri Aug  4 08:32:18 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: event 5 notification
Fri Aug  4 08:32:18 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: aborting authentication
Fri Aug  4 08:32:18 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-STARTED ee:a9:be:a1:7e:a5
Fri Aug  4 08:32:18 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=1
Fri Aug  4 08:32:18 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: unauthorizing port
Fri Aug  4 08:32:18 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-STARTED ee:a9:be:a1:7e:a5
Fri Aug  4 08:32:18 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=1
Fri Aug  4 08:32:18 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 35)
Fri Aug  4 08:32:18 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: event 3 notification
Fri Aug  4 08:32:18 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 MLME: MLME-DEAUTHENTICATE.indication(ee:a9:be:a1:7e:a5, 23)
Fri Aug  4 08:32:18 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 MLME: MLME-DELETEKEYS.request(ee:a9:be:a1:7e:a5)
Fri Aug  4 08:32:22 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Resending RADIUS message (id=1)
Fri Aug  4 08:32:22 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 7 seconds
Fri Aug  4 08:32:23 2023 daemon.info hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: deauthenticated due to local deauth request
Fri Aug  4 08:32:23 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Removing pending RADIUS authentication message for removed client
Fri Aug  4 08:32:23 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Removing pending RADIUS authentication message for removed client

Client authentication success

Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: authentication OK (open system)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 MLME: MLME-AUTHENTICATE.indication(ee:a9:be:a1:7e:a5, OPEN_SYSTEM)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 MLME: MLME-DELETEKEYS.request(ee:a9:be:a1:7e:a5)
Fri Aug  4 08:44:38 2023 daemon.info hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: authenticated
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: association OK (aid 1)
Fri Aug  4 08:44:38 2023 daemon.info hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: associated (aid 1)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 MLME: MLME-ASSOCIATE.indication(ee:a9:be:a1:7e:a5)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 MLME: MLME-DELETEKEYS.request(ee:a9:be:a1:7e:a5)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: binding station to interface 'phy0-ap0'
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: event 1 notification
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: start authentication
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: start authentication
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: unauthorizing port
Fri Aug  4 08:44:38 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-STARTED ee:a9:be:a1:7e:a5
Fri Aug  4 08:44:38 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=1
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 236)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAP packet (code=2 id=236 len=26) from STA: EAP Response-Identity (1)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: STA identity 'tim.smith@test.com'
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: RADIUS Sending RADIUS message to authentication server
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 3 seconds
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received 64 bytes from RADIUS server
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received RADIUS message
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Received RADIUS packet matched with a pending request, round trip time 0.00 sec
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: decapsulated EAP packet (code=1 id=237 len=6) from RADIUS server: EAP-Request-TLS (13)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 237)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAP packet (code=2 id=237 len=161) from STA: EAP Response-TLS (13)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: RADIUS Sending RADIUS message to authentication server
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 3 seconds
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received 1068 bytes from RADIUS server
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received RADIUS message
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Received RADIUS packet matched with a pending request, round trip time 0.00 sec
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: decapsulated EAP packet (code=1 id=238 len=1004) from RADIUS server: EAP-Request-TLS (13)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 238)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAP packet (code=2 id=238 len=6) from STA: EAP Response-TLS (13)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: RADIUS Sending RADIUS message to authentication server
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 3 seconds
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received 1068 bytes from RADIUS server
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received RADIUS message
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Received RADIUS packet matched with a pending request, round trip time 0.00 sec
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: decapsulated EAP packet (code=1 id=239 len=1004) from RADIUS server: EAP-Request-TLS (13)
Fri Aug  4 08:44:38 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 239)
Fri Aug  4 08:44:41 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-RETRANSMIT2 ee:a9:be:a1:7e:a5
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 239)
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAP packet (code=2 id=239 len=6) from STA: EAP Response-TLS (13)
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: RADIUS Sending RADIUS message to authentication server
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 3 seconds
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received 1068 bytes from RADIUS server
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received RADIUS message
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Received RADIUS packet matched with a pending request, round trip time 0.00 sec
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: decapsulated EAP packet (code=1 id=240 len=1004) from RADIUS server: EAP-Request-TLS (13)
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 240)
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAP packet (code=2 id=240 len=6) from STA: EAP Response-TLS (13)
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: RADIUS Sending RADIUS message to authentication server
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 3 seconds
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received 167 bytes from RADIUS server
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received RADIUS message
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Received RADIUS packet matched with a pending request, round trip time 0.00 sec
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: decapsulated EAP packet (code=1 id=241 len=109) from RADIUS server: EAP-Request-TLS (13)
Fri Aug  4 08:44:41 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 241)
Fri Aug  4 08:44:44 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-RETRANSMIT2 ee:a9:be:a1:7e:a5
Fri Aug  4 08:44:44 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 241)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAP packet (code=2 id=241 len=1276) from STA: EAP Response-TLS (13)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Sending RADIUS message to authentication server
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 3 seconds
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received 64 bytes from RADIUS server
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received RADIUS message
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Received RADIUS packet matched with a pending request, round trip time 0.00 sec
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: decapsulated EAP packet (code=1 id=242 len=6) from RADIUS server: EAP-Request-TLS (13)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 242)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAP packet (code=2 id=242 len=1276) from STA: EAP Response-TLS (13)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Sending RADIUS message to authentication server
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 3 seconds
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received 64 bytes from RADIUS server
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received RADIUS message
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Received RADIUS packet matched with a pending request, round trip time 0.00 sec
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: decapsulated EAP packet (code=1 id=243 len=6) from RADIUS server: EAP-Request-TLS (13)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 243)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAP packet (code=2 id=243 len=281) from STA: EAP Response-TLS (13)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Sending RADIUS message to authentication server
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 3 seconds
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received 119 bytes from RADIUS server
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received RADIUS message
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Received RADIUS packet matched with a pending request, round trip time 0.00 sec
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: decapsulated EAP packet (code=1 id=244 len=61) from RADIUS server: EAP-Request-TLS (13)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 244)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: received EAP packet (code=2 id=244 len=6) from STA: EAP Response-TLS (13)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Sending RADIUS message to authentication server
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Next RADIUS client retransmit in 3 seconds
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received 189 bytes from RADIUS server
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: RADIUS Received RADIUS message
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: Received RADIUS packet matched with a pending request, round trip time 0.00 sec
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.11: binding station to interface 'phy0-ap0'
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: old identity 'tim.smith@test.com' updated with User-Name from Access-Accept 'tim.smith@test.com'
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: decapsulated EAP packet (code=3 id=244 len=4) from RADIUS server: EAP Success
Fri Aug  4 08:44:46 2023 daemon.notice hostapd: phy0-ap0: CTRL-EVENT-EAP-SUCCESS2 ee:a9:be:a1:7e:a5
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: Sending EAP Packet (identifier 244)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: sending 1/4 msg of 4-Way Handshake
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: received EAPOL-Key frame (2/4 Pairwise)
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: sending 3/4 msg of 4-Way Handshake
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: received EAPOL-Key frame (4/4 Pairwise)
Fri Aug  4 08:44:46 2023 daemon.info hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 WPA: pairwise key handshake completed (RSN)
Fri Aug  4 08:44:46 2023 daemon.notice hostapd: EAPOL-4WAY-HS-COMPLETED ee:a9:be:a1:7e:a5
Fri Aug  4 08:44:46 2023 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED ee:a9:be:a1:7e:a5 auth_alg=open
Fri Aug  4 08:44:46 2023 daemon.debug hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: authorizing port
Fri Aug  4 08:44:46 2023 daemon.info hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 RADIUS: starting accounting session 30C2B4E9D81CA083
Fri Aug  4 08:44:46 2023 daemon.info hostapd: phy0-ap0: STA ee:a9:be:a1:7e:a5 IEEE 802.1X: authenticated - EAP type: 13 (TLS)