EA8500 Install Advice

Unfortunately my brand new EA8500 arrived today and the stock UI firmware upgrade refuses to allow the factory .bin for LEDE. The unit arrived with firmware SSH isn't offered as an admin option. Downgrade to firmware also fails (invalid firmware file error). Does anyone know whether a TFTP update bypasses the firmware version check?

Please post back what you find out. While I needed to get the bootlogs of both LEDE and stock fw off my device I haven't installed signed Linksys firmware on my router ( precisely because I was afraid it would lock it down.

I was able to use TFTP but over the serial connection, as I needed to access the bootloader to trigger it.
I can confirm that version check is not enforced by bootloader, so you can flash from there.
If you are willing to open your device, the serial pins are clearly visible.
The pins are not marked, but you can find the right connectors order in:
Openwrt device page.

Thanks all. I'll pursue the serial port approach. Right now, I'm having trouble prying the case top off - my plastic pry tool is useless and I'm reluctant to use a screwdriver for fear of really messing up the case. I'll figure something out and post back when I have results.

It takes a bit of determination to separate the top cover as stated in the wiki. Start from the sides, as they are easier to separate.

Install went easily once the case was open. Though there were no headers for the serial port, I was able to flash without soldering by holding a philco header with the correct signals physically against the pads with a "third hand" tool.

Glad you've soldiered thru, but locked firmware and removal of headers on the serial connection is a big reason not to get this router anymore. :frowning:

Can you post/PM me a photo of the underside label?

1 Like


What do you mean? Did they lock the firmware of bootloader from the latest firmware?

I inferred that much from OP:

That was my experience. In the end, I had to pry it open and solder wires to the serial port pads. Not only did my board not have headers there, but the holes were filled with something other than solder - I couldn't clear it, even with flux. So I tacked on tiny pigtails and got into the serial port. From there, no problems. LEDE works wonderfully on the device.

Second that, once you get LEDE installed, it's super-stable and everything works. Have been running it for 6-7 months.

Considering the price of EA8500 and the fact that newer units are being locked down, WRT1x00 or WRT3200 might be a better choice.

I have not figured out how to enable the 160 mhz channels. How do I accomplish this?

Found out that it uses Qualcomm Atheros QCA9980 which does not support 160 Mhz or 80 Mhz + 80 Mhz channels.

I have two of these routers. My first attempt to replace stock firmware had the same results as those of OP.

However, I managed to implement the instructions I found here on one of the two routers. It was a pain, and that was before I discovered LEDE, but I'm guessing the same procedure would work with the LEDE firmware instead of the DD-WRT firmware. I've not tried this yet (though I may soon). Hope this helps.

Myself, I'm now debating whether I should install LEDE or DD-WRT on the second router which is still running factory firmware. The fact that I've already successfully implemented mrjcd's instructions on one router argues in favor of me installing DD-WRT on the second router too, but I'm beginning to suspect that LEDE may offer more features than DD-WRT so I'm not sure. Maybe I should use LEDE firmware on the second router but just use mrjcd's instructions with LEDE firmware instead of DD-WRT. If I use LEDE on router2, then I'll probably overwrite DD-WRT on router1 with LEDE too, but I understand that carries significant risk of bricking the router. I want to use these routers with each other in WDS mode, and although I'm pretty sure that I could do this with one router running DD-WRT and the other running LEDE, my initial preference would be to have the same firmware running on both routers.

I'd enjoy reading others' thoughts on this decision.


Please keep the same questions in one thread.

Earlier, you were asking about forum posting etiquette. That's one that's pretty common on any forum site.

The same applies to posting the same question on different forum sites at the same time (called "cross-posting"). In that case, providing a link on each forum showing where else you have posted helps prevent confusion and wasted time, since everyone knows what has been going on. Some sites don't allow it.

Your alternate threads...


A few things to consider:

  1. My (older) EA8500 came with the anti-tampering sticker.
  2. The tabs holding two halves of the housing together are prone to breaking.
  3. (From what I've heard) the newer EA8500 don't have serial headers soldered on.

So you may damage the anti-tampering sticker and potentially break away tabs only to discover there're no serial headers on the board and unless you're very good with soldering you'll end up with the unit which you can't return and out of warranty.

If you still can -- return your unmolested EA8500 for a refund and get something from the WRT1x00 series.

1 Like

I successfully converted the DD-wrt firmware to LEDE.

I followed http://mrjcd.com/EA8500_DD-WRT/ to install the DD-wrt firmware successfully.

I thought to give Lede a try.

In order to do this I had to reverse with the same instructions to the original firmware make sure you don't use Linksys firmware ver or newer!


You will not be able to install Lede with newer versions.

Than I installed Lede directly within the linksys interface.

Worked good for me

Hey guys, I need a bit of help: I was able to open my ea8500, solder some wires for the serial connection. The problem that I'm facing now is that I can't get my computer to understand the router over serial. I see garbled characters in the console window which makes me think that I did not use the correct serial settings on the computer. Can somebody share what settings worked for them?

Serial connection parameters: 115200 / 8N1

Make sure the GND connection is o.k. and never ever connect Vcc.