Ea8300 wifi issues

Hello everyone - I am new user to OpenWRT and am using EA8300. I have been having a lot of trouble in getting openwrt to work as it should and am at my wits ends. Hoping veterans of OpenWRT and EA8300 can help or point me in the right direction. The EA8300 is a 2nd router connected to the primary router. The EA8300 has its own subnet and DHCP is active on it.

I flashed v 22 on the router. went through the instructions. increased kernel size etc. installed v23.05.5. the system comes online as it should. I am using stock config/no changes. my wifi connection is so much worse than it was before. here are the challenges I am facing

  1. wifi ssid does not show up in most of the devices where it used to during OEM firmware days
  2. when it does show up in one machine, it takes for ever to show up under the available networks.
  3. connection keeps disconnecting and is never usable.

Things I have tried using info from this forum and Chatgpt

  1. set default country to US
  2. changed beacon interval to 15 and DTIM to 1 (made no diff)
  3. forced 40Mhz on 2.4GHz network (minimal change noticed)
  4. changed channels manually (no change)
  5. changed channels to auto (no change at all)
  6. changed RCS to 500 (no change either)
  7. changed cell density to very high (some diff noticed)
  8. change distance optimization to 60

I reflashed to the orig 23.05.5 image to get a clean start and hoping I can get pointers
all of my configs are noted below for reference

system Config (/etc/config/system)

config system
        option hostname 'OpenWrt'
        option timezone 'UTC'
        option ttylogin '0'
        option log_size '64'
        option urandom_seed '0'
        option compat_version '2.0'

config timeserver 'ntp'
        option enabled '1'
        option enable_server '0'
        list server '0.openwrt.pool.ntp.org'
        list server '1.openwrt.pool.ntp.org'
        list server '2.openwrt.pool.ntp.org'
        list server '3.openwrt.pool.ntp.org'

wireless Config (/etc/config/wireless)

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '100'
        option band '5g'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/a000000.wifi'
        option channel '1'
        option band '2g'
        option htmode 'HT20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/a800000.wifi'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'

Network config (/etc/config/network)

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd81:b3b9:ef19::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config device
        option name 'lan1'
        option macaddr 'abc'

config device
        option name 'lan2'
        option macaddr 'abc'

config device
        option name 'lan3'
        option macaddr 'abc'

config device
        option name 'lan4'
        option macaddr 'abc'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr 'xyz'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

Should we assume it is routing to the primary router? Have you consider setting it as an AP?

What is running is unclear.

I don't know if this can really help, but set radio0 to channel auto. It will behave according to DTS in your area.

Can you elaborate on that? In OpenWRT that is per-radio setting.

Most radios prermit only one region change per poweron.

What are those "devices" say on android unencrypted wifi is sorted 10dbm down in the list, like 3x further than really is.

Would help to set wpa2+ccmp or wpa3 for cipher.

The EA8300 has its own subnet and DHCP is active on it.

Should we assume it is routing to the primary router? Have you consider setting it as an AP?

Response: Yes, it is routing through the primary router. I havent yet explored setting this up as an AP. However, would give it a try as well and circle back.

What is running is unclear.

Response:

  • Firmware version: OpenWrt 23.05.5 r24106-10cc5fcd00 / LuCI openwrt-23.05 branch git-24.264.56413-c7a3562
  • Kernel version: 5.15.167

I don't know if this can really help, but set radio0 to channel auto. It will behave according to DTS in your area.

Response:
Changed the Channel to Auto for radio0. No difference

Thanks for your response Brada4

Can you elaborate on that? In OpenWRT that is per-radio setting.

Response: I set the setting for each of the radios

What are those "devices" say on android unencrypted wifi is sorted 10dbm down in the list, like 3x further than really is.

Response: I am not sure I am following what you are saying. That being said, I had tried initially with WPA2+ccmp and it did not make a difference. I went ahead and did change it again to WPA2+ccmp. I will post the revised configuration shortly.

Revised configs

system config

config system
        option hostname 'OpenWrt'
        option timezone 'UTC'
        option ttylogin '0'
        option log_size '64'
        option urandom_seed '0'
        option compat_version '2.0'

config timeserver 'ntp'
        option enabled '1'
        option enable_server '0'
        list server '0.openwrt.pool.ntp.org'
        list server '1.openwrt.pool.ntp.org'
        list server '2.openwrt.pool.ntp.org'
        list server '3.openwrt.pool.ntp.org'

wireless config

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel 'auto'
        option band '5g'
        option htmode 'VHT80'
        option country 'US'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'test1234'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/a000000.wifi'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option country 'US'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'test1234'
config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/a800000.wifi'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option country 'US'
        option cell_density '0'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'test1234'

network config

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd81:b3b9:ef19::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config device
        option name 'lan1'
        option macaddr 'abc'

config device
        option name 'lan2'
        option macaddr 'abc'

config device
        option name 'lan3'
        option macaddr 'abc'

config device
        option name 'lan4'
        option macaddr 'abc'
config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr 'xyz'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

Aare you in US?

What kind of clients cannot connect?

Did AI make you re-post config files?

All three radios have the same SSID. Set a different SSID for each. This allows you to know on which radio the device is attempting to connect, and how it fails.

I own a MR8300 which is a close device. It is very reliable, and nothing to complain about wifis. I'm using all three radios, I bought this device specially for this feature.

Consider using the EA8300 as an AP. It's easy to setup with a few clicks in Luci. There will have no routing on it so the performance will be better.
https://openwrt.org/docs/guide-user/network/wifi/wifiextenders/bridgedap#wireless_access_point_-_dumb_access_point

yes, in the US.

the clients that cannot connect are

  1. samsung mobile (supports 6gh, 5Gh, 2.4Gh wireless)
  2. android tablet (supports 5Gh, 2.4Gh wireless)
  3. debian based laptop (supports 2.4Gh wireless)
  4. windows based laptop (supports 5Gh, 2.4Gh wireless)

on AI making me repost config files - No. just wanted to have the latest one visible.

2g network will show immediately, use WPA2 and enable PMF/11w or use plain WPA3 (not mixed mode)
5 and 6 GHz need country code absolutely, 1st will be limited to ch36 without, and 2nd will not start at all.

Then from wired observe the logs after one client connects (and fails)

There are no known problems with your (very default and straightforward) setup or device itself.

1 Like

Thanks Badulesia. As suggested, I changed the SSID to be different for each of the radios and restarted router and reconfigured router to be in AP mode.

I see the 2.4Gh SSID, but connections keep spinning

1 Like

My working config for reference

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option channel '128'
	option htmode 'VHT80'
	option cell_density '0'
	option country 'DE'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'UA_Free_5GHz'
	option encryption 'psk2'
	option key '12345678abcde'
	
config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option band '2g'
	option channel '6'
	option htmode 'HT20'
	option cell_density '0'
	option noscan '1'
	option txpower '20'
	option country 'DE'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'UA_Free_2GHz'
	option encryption 'psk2'
	option key '12345678abcde'
	option wds '1'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option band '5g'
	option channel '36'
	option htmode 'VHT80'
	option cell_density '0'
	option country 'DE'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'UA_Free_5GHz'
	option encryption 'psk2'
	option key '12345678abcde'
:~$ nmcli dev wifi list | grep C6:41*
        C6:41:1E:22:6F:1B  UA_Free_2GHz                       Infra  6     130 Mbit/s  62      ▂▄▆_  WPA2     
        C6:41:1E:22:6F:1C  UA_Free_5GHz                       Infra  36    270 Mbit/s  54      ▂▄__  WPA2     
        C6:41:1E:22:6F:1D  UA_Free_5GHz                       Infra  128   270 Mbit/s  40      ▂▄__  WPA2     
:~$

Running on OpenWrt 24.10-SNAPSHOT (r28019-e39f5d4b36)

edit: with the country code set to US the same, Well less signal at 128 Ch at the moment.

:~$ nmcli dev wifi list | grep C6:41*
        C6:41:1E:22:6F:1B  UA_Free_2GHz                       Infra   6     130 Mbit/s  54      ▂▄__  WPA2     
        C6:41:1E:22:6F:1C  UA_Free_5GHz                       Infra   36    270 Mbit/s  54      ▂▄__  WPA2     
        C6:41:1E:22:6F:1D  UA_Free_5GHz                       Infra   128   270 Mbit/s  39      ▂▄__  WPA2     
:~$

Brada4 - AFter making each ssid unique, I do see the 2.4gh on my debian based laptop. I also set the 802.11/W to be required and set encryption to be WPA2.

the laptop never connects to wifi. i dont see anything in the logs either


Thu Dec 19 10:44:56 2024 daemon.notice netifd: Wireless device 'radio1' is now up
Thu Dec 19 10:44:56 2024 daemon.notice netifd: Wireless device 'radio0' is now up
Thu Dec 19 10:44:56 2024 daemon.notice netifd: Wireless device 'radio2' is now up
Thu Dec 19 10:44:56 2024 daemon.notice hostapd: Switch own primary and secondary channel to get secondary channel with no Beacons from other BSSes
Thu Dec 19 10:44:56 2024 kern.info kernel: [ 3126.176637] IPv6: ADDRCONF(NETDEV_CHANGE): phy2-ap0: link becomes ready
Thu Dec 19 10:44:56 2024 kern.info kernel: [ 3126.176903] br-lan: port 8(phy2-ap0) entered blocking state
Thu Dec 19 10:44:56 2024 kern.info kernel: [ 3126.182141] br-lan: port 8(phy2-ap0) entered forwarding state
Thu Dec 19 10:44:56 2024 daemon.notice netifd: Network device 'phy2-ap0' link is up
Thu Dec 19 10:44:57 2024 daemon.notice hostapd: phy2-ap0: interface state HT_SCAN->ENABLED
Thu Dec 19 10:44:57 2024 daemon.notice hostapd: phy2-ap0: AP-ENABLED
Thu Dec 19 10:45:07 2024 daemon.notice hostapd: phy0-ap0: ACS-COMPLETED freq=5700 channel=140
Thu Dec 19 10:45:07 2024 daemon.notice hostapd: phy0-ap0: interface state ACS->HT_SCAN
Thu Dec 19 10:45:08 2024 daemon.notice hostapd: phy0-ap0: interface state HT_SCAN->DFS
Thu Dec 19 10:45:08 2024 daemon.notice hostapd: phy0-ap0: DFS-CAC-START freq=5700 chan=140 sec_chan=1, width=1, seg0=138, seg1=0, cac_time=60s
Thu Dec 19 10:46:08 2024 daemon.notice hostapd: phy0-ap0: DFS-CAC-COMPLETED success=1 freq=5700 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5690 cf2=0
Thu Dec 19 10:46:08 2024 kern.info kernel: [ 3197.901120] ath10k_pci 0000:01:00.0: mac flush null vif, drop 0 queues 0xffff
Thu Dec 19 10:46:08 2024 kern.info kernel: [ 3197.982895] IPv6: ADDRCONF(NETDEV_CHANGE): phy0-ap0: link becomes ready
Thu Dec 19 10:46:08 2024 kern.info kernel: [ 3197.983147] br-lan: port 7(phy0-ap0) entered blocking state
Thu Dec 19 10:46:08 2024 kern.info kernel: [ 3197.988344] br-lan: port 7(phy0-ap0) entered forwarding state

You have to remove saved wpa3 connections on other devices.

What is in /etc/config/firewall ?

1 Like

deleted all wifi connections on device

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'
config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'
1 Like

Nothing out of the ordinary

That's a start.
For example this is the config for my MR8300. radio2 is used for a WDS bridge.
Another solution for debugging is disabling all wifis. Than enabling only one, perform tests. Enable another, perform tests, etc.

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel 'auto'
	option band '5g'
	option htmode 'VHT80'
	option country 'FR'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'badulesia5'
	option encryption 'psk2'
	option key 'somepasswd'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option channel '1'
	option band '2g'
	option htmode 'HT40'
	option txpower '17'
	option country 'FR'
	option cell_density '0'
	option noscan '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'badulesia2'
	option encryption 'psk2'
	option key 'somepasswd'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option txpower '22'
	option country 'FR'
	option cell_density '0'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'badulesia_bridge'
	option encryption 'psk2'
	option wds '1'
	option key 'somepasswd'

is PMF/11w same as 802.11/w setting?

1 Like

Thank you for the config. I tested each of the 5ghz radios by changing the channels manually. bringing the wifi down and up. unfortunately, didnt see either of the 5ghz ssid's show up in my devices.

Is there a test/check to see if the hardware is degraded.
The 2.4gh ssid's barely show up as well, so thinking there is a more systemic issue.

It takes up to 10 minutes for 5GHz device to do DFS survey in ~36 channel. ie before wifi appears on the air.

1 Like