EA8300 not showing for clients

Hi. I have OpenWRT on 22.03. Some clients (laptops, Android phones) see it, others don't (laptops, Android phones, wireless printer). I've tried changing the beacon interval time, but that doesn't seem to impact it.

There isn’t enough info for us to help you.

Is this device a dumb ap? Or the main router? Are there any other APs in your network?

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
2 Likes

Sorry. Main router, I want to add APs eventually but this is just connecting directly to it as main router. I'll have to connect again over the weekend, it's all unplugged at the moment.

no really

connect LAN<>WAN to the live router, it's bad because of the double NAT, but perfectly adequate for looking into the issue at hand.

just make sure the two LAN subnets don't overlap.

Sorry for delay. Here are the configs. All I have done is setup one SSID (New_Network). I have a DSL modem from my ISP, that I plug into the "Internet" port on this EA8300. Then I plug in a line for PiHole and one for a local only server. I don't need VPN on, just need the SSID to be visible for devices.

 ubus call system board
{
        "kernel": "5.10.146",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 5 (v7l)",
        "model": "Linksys EA8300 (Dallas)",
        "board_name": "linksys,ea8300",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "22.03.2",
                "revision": "r19803-9a599fee93",
                "target": "ipq40xx/generic",
                "description": "OpenWrt 22.03.2 r19803-9a599fee93"
        }
}

 cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd77:a486:890c::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'
        option type 'bridge'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '100'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'
        option country 'US'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/a000000.wifi'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/a800000.wifi'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-iface 'wifinet5'
        option device 'radio0'
        option mode 'ap'
        option encryption 'psk2'
        option key 'password'
        option ssid 'New_Network'
        option network 'lan wan'

cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name '.family.lan'
        option dns '1'
        option mac 'A1:1A:A1:11:1A:11'
        option ip '192.168.1.104'

cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
root@OpenWrt:~# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  111.11.1.111
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  111.11.1.111
#       option dest_port        120
#       option proto    tcp

Looking at your config, there are a few things that come to mind:

First...

This version is out of date. You should be at least at 22.03.6, but better yet 23.05.2. I'd recommend upgrading.

Next...
There are some errors in your configuration. They can probably be fixed pretty easily, but...
The config itself is not very far from the default state. With that in mind, and when considering the need to upgrade, my recommendation would be:

  • Upgrade to the latest version of either 22.03 or 23.05
  • During the upgrade process, uncheck the "keep settings" checkbox and let the device return to the default configuration. (you might actually have to do this anyway for the 23.05 upgrade because I think this device has migrated to DSA)
  • when the upgrade is complete, enable wifi simply by these steps:
    • set your country code
    • set your desired SSID name
    • set your desired encryption method and corresponding passphrase
    • enable the wifi radios.

At that point, it should 'just work.'

If it doesn't, we'll take a look at your configuration again.

1 Like

Thanks. What's the easiest way to upgrade? Reflash or can you upgrade from CLI?

Download the latest from the firmware-selector -- grab the sysupgrade image.
https://firmware-selector.openwrt.org/?version=23.05.2&target=ipq40xx%2Fgeneric&id=linksys_ea8300

Then, you can use either the LuCI web interface or the CLI (sysupgrade -n <filename>) to perform the upgrade.

1 Like

I tried to update from LuCI using the .bin you linked. it says

Image check failed:

Tue Jan 16 02:01:48 UTC 2024 upgrade: The device is supported, but this image is incompatible for sysupgrade based on the image version (1.0->2.0). Tue Jan 16 02:01:48 UTC 2024 upgrade: Kernel partition size must be increased for this OpenWrt version. Before continuing, you MUST issue either the command "fw_setenv kernsize 500000" from the OpenWrt command line, or "setenv kernsize 500000 ; saveenv" from the U-Boot serial console. Instead of the sysupgrade image, you must then install the OpenWrt factory image, setting the force flag and wiping the configuration. (e.g. "sysupgrade -n -F openwrt-squashfs-factory.bin" on command line) Image check failed. 

Follow the directions it provides so that you can upgrade to the latest. Let us know if you have followup questions or difficulties.

I issues fw_setenv kernsize 500000 and it was fine. I downloaded the factory image from your link, it was fine. I forced update from the next screen, and now when I visit 192.168.1.1 it gives me the Linksys stock login page, and I can't connect over SSH

That device is a dual-partition system... I believe it will switch to the other partition when it has had 3 unsuccessful/partial boot cycles.

Try unplugging it from power, then plugging it in again for about 10 second (enough to get a boot cycle started, but not to finished), then unplug it again. Repeat two more times and then on the 4th power-on cycle, let it boot fully -- it should boot back into OpenWrt.

1 Like

That didn't work, same version installed. Going to read through this and try again later: https://openwrt.org/toh/linksys/ea8300#upgrading_openwrt_from_22035_into_23xx_or_snapshot_images

I would suggest to install (the latest version of-) 22.03.x again, to confirm that the kernel size is set correctly - and then start over with 23.05.x again (I think to remember successful reports about that on 23.05.x).

I downloaded 22.03.2 from here.

Where do I get 23.05.x? And do you want me to just install that or upgrade from 22?

https://downloads.openwrt.org/releases/22.03.6/targets/ipq40xx/generic/
https://downloads.openwrt.org/releases/23.05.2/targets/ipq40xx/generic/

So just Install 22.03.6

Then install 23.05.2 all from LuCI?

Install 22.03.6, check the u-boot environment for the kernel size, sysupgrade -n /tmp/image.bin to 23.05.2.

Downloaded 22.03.6. Installed it. It went to the other partition. I did the partition cycling like before and got back to OpenWRT....still version 22.03.2. Downloading the file linksys_ea8300-squashfs-factory.bin

I'm installing by System -> Backup/Flash Firmware -> Flash new firmware image -> Flash image, then uploading from my laptop.

I tried from CLI and it errors out with

Tue Jan 16 02:05:07 UTC 2024 upgrade: Image metadata not present
Tue Jan 16 02:05:07 UTC 2024 upgrade: Use sysupgrade -F to override this check when downgrading or flashing to vendor firmware
Image check failed.

I've done the override from LuCI, but it doesn't want to work any which way.

Any thoughts?