EA7500-V1 with SNAPHOT => WAN port is not working

I have a LINKSYS EA7500-V1:

when the router is running 23.05.5 , wan port is working the router get a IP and everything is working .

when the router is running SNAPHOT , wan port does not work , he can send packets , but does not process received packets.
the router can not process DHCP reply .

This is happening without any changes in the configuration .

i created this issue : https://github.com/openwrt/openwrt/issues/16604

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

i am testing just after running firstboot -y && reboot

ubus call system board

root@OpenWrt:~# ubus call system board
{
	"kernel": "6.6.54",
	"hostname": "OpenWrt",
	"system": "ARMv7 Processor rev 0 (v7l)",
	"model": "Linksys EA7500 V1 WiFi Router",
	"board_name": "linksys,ea7500-v1",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "SNAPSHOT",
		"revision": "r27694-0b05cc7048",
		"target": "ipq806x/generic",
		"description": "OpenWrt SNAPSHOT r27694-0b05cc7048"
	}
}

cat /etc/config/network | sed 's|\([0-9a-f]\)\([0-9a-f]:[0-9a-f][0-9a-f]:[0-9a-f][0-9a-f]:[0-9a-f][0-9a-f]:[0-9a-f][0-9a-f]:[0-9a-f]\)\([0-9a-f]\)|\1X:XX:XX:XX:XX:X\3|'

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdc8:58d:d67a::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config device
	option name 'lan1'
	option macaddr '1X:XX:XX:XX:XX:Xc'

config device
	option name 'lan2'
	option macaddr '1X:XX:XX:XX:XX:Xc'

config device
	option name 'lan3'
	option macaddr '1X:XX:XX:XX:XX:Xc'

config device
	option name 'lan4'
	option macaddr '1X:XX:XX:XX:XX:Xc'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr '1X:XX:XX:XX:XX:Xc'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

cat /etc/config/firewall | grep -v '^#'

config defaults
	option syn_flood	1
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

cat /etc/config/wireless | grep -v '^#'

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '2g'
	option channel '1'
	option htmode 'VHT20'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option band '5g'
	option channel '36'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

Nothing looks out of place here... but a few thoughts:

  1. Do you have another router that you can try upstream of this EA7500? Specifically, if you connect the wan of this device to an upstream LAN where there is a DHCP server, does it obtain an IP address?

  2. What type of physical internet service do you have? (Cable/DSL/Cellular/Fiber/etc.). If the MAC address of the EA7500's wan port has changed due to the upgrade (there are a number of reasons that this could happen), it may not get an IP from the upstream service until the previously "learned" MAC address is cleared. Have you tried doing that?

I can see the dchp uplink reply .

The EA7500-v1 is running in a lab context .

This is a network diagram

EA7500-V2 is working and can get a DHCP address
EA7500-V1 is not working and can not get a DHCP address

         |                  /------------------------------\
/-------[1]----\            |                              |
|   SWITCH   [6]------------[1] 192.168.2.66   MINI PC     |
\_[8]_[7]______/            |                              |
   |   |                    |  192.168.3.66   192.168.4.66 |
   |   |                    \_______[2]____________[3]_____/
   |   |                             |              |       
   |   |                             |              |       
   |   | /-------------------------\ |              |       
   |   | |    192.168.3.1/24       | |              |       
   |   | |    Linksys EA7500 v2    | |              |       
   |   \-[wan]                     | |              |       
   |     \_______[lan3]_____[lan4]_/ |              |       
   |               |           \-----/              |       
   |               |                                |       
   |               |           /--------------------/       
   |      /------[lan3]-----[lan4]-\                          
   \------[wan]                    |                          
          |    Linksys EA7500 V1   |                          
          |    192.168.4.1/24      |                          
          \________________________/

Is the Mini PC running a DHCP server? Or is that upstream on port 1 of the switch?

What do you see in the v1:

logread -e udhcpc

I did notice the mac addresses for LAN and WAN
are the same witch flags a problem to me
ea7500 and ea8500 but this was v23

The same MAC on the wan and lan actually doesn't cause a problem. That's because the only critical rule for MAC addresses is that each device has a unique MAC on their respective networks.

dhcp server is outside of the diagram feeding via port lan1

root@OpenWrt:~# logread -e udhcpc
Mon Oct  7 17:29:48 2024 daemon.notice netifd: wan (1974): udhcpc: started, v1.36.1
Mon Oct  7 17:29:48 2024 daemon.notice netifd: wan (1974): udhcpc: broadcasting discover
Mon Oct  7 17:29:51 2024 daemon.notice netifd: wan (1974): udhcpc: broadcasting discover
Mon Oct  7 17:29:54 2024 daemon.notice netifd: wan (1974): udhcpc: broadcasting discover

And if i set a static IP , that does not work too .

i did a test , and change the mac address for WAN , from 1X:XX:XX:XX:XX:Xc to 1X:XX:XX:XX:XX:Xd .

That's work , so this is a work around .

I tried 23.05.5 , 23.05.2 this is working without changing the mac address .

@Lucky1 do you remember in which version you had / see the problem ?

@Ansuel may be you are interessed by my problem !

I need to manually to change the mac address .

@bdleonard , just saw your post Linksys EA8500 issues on recent snapshots

I went from V19 to V23 so an early v23 .0 or .1
I think it was firewall related but can't remember
just know from then on I just make sure all the MAC addresses are different
and the problems go away so always had it changed since