EA6350v3 "Override MTU" Field Populating with "root"

This looks like a minor bug in the EA6350v3 OpenWrt 19.07-SNAPSHOT r10554-26c0bec13b / LuCI openwrt-19.07 branch (git-19.263.64892-befe994). In the LuCI Interfaces>Common Configuration>Advanced Settings, the "Override MTU" field is populating with the login username "root" saved in my Firefox browser (69.0.1 running on Manjaro linux). Clearing my saved login in Firefox clears the problem - its just an annoyance, but one not present in 18.06.4 on my EdgeRouter-X or EA8500. Looks like a bug.

1 Like

No bug. Just clear your browser's auto-complete cache.

May want to inform Mozilla; but a few threads note this with browsers.

Although it might be a Firefox specific issue, I think it would be unwise to ignore.
Especially when the workaround requires to simply add the id attribute to the input field.

@eginnc, you can report it here:

All luci inputs already have id attributes.

1 Like

Fixed how? We keep adding stupid workarounds like hidden dummy fields, random attributes etc. and Firefox keeps inventing new ways of autofilling crap. I couldn't find a reliably working solution to this.

1 Like

How would changing these affect putting “root” into the mtu field?

Thank you for the link to report the issue. I did. Also to others for the replies. Looks like a mildly controversial issue. No problem with that. If it doesn't merit attention that's fine - figured I'd at least report it to flag it if it does.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.