EA6350 v3 Debricking via U-Boot

Hi I am new to OpenWRT, and just installed it on my Linksys EA6350v3 router. I read the wiki, and the Recovery (Automatic) section says

U-boot will switch back to the last working firmware

Can someone shed some light on this step? What exactly do I need to do here to switch back to the other partition if my device is bricked and cannot be reached by ethernet or wifi? This is different from using a USB-TTL adapter + soldering 4 pins on the PCB board + serial COM connection, correct?

Appreciate your help!

You don't need a USB-TTL adapter. Your device has a dual boot feature which means there should be still a working installation left on the device. Just follow the steps:

If the device fails to boot after install or upgrade, turned on the router:

  1. Wait 15 seconds
  2. Switch Off and Wait 10 seconds
  3. Switch on
  4. Repeat steps 1 to 3, 3 times then go to 5.
  5. U-boot will switch back to the last working firmware - you should be able to access your router on LAN.

Maybe you have missed the "3 times".

1 Like

Hello thank you for your response. I did repeat 3 times here.

What I don't understand is "U-boot". What exactly do I need to do a "U-boot"?

Just a regular power on? Or something like download and compile U-boot source code and change some configuration files and install to a USB drive and boot from there? I am new to OpenWrt and embedded world. Did some research but still unclear of things here.

fwiw, you don't need to do anything with U-boot. U-boot is the bootloader. No need to use a USB-TTL adapter for serial access unless the EA6350 is truly bricked beyond all recognition.

Did you install the Openwrt 'squashfs-factory' image onto the EA6350?

The 'Recovery (Automatic)' procedure using just the Power Switch should have worked if you just installed OpenWrt from original Linksys firmware. ie.

15 sec ON
10 sec OFF
15 sec ON
10 sec OFF
15 sec ON
10 sec OFF
turn on router and it should boot up 'previous' working firmware.

1 Like

Thanks a lot for your explanation (and thank for your very detailed PDF instructions on the BackToStock script).

Yes I just installed the stock OpenWRT squashfs-factory image a few days ago. Attempted to configure VLAN in LuCI but turned out it didn't work. The first time LuCI reverted back automatically after 90 seconds. The 2nd time I was not lucky anymore. It did not come back after 90 seconds and I lost connection. Then I tried the method you described, still no luck. So I thought my understanding of the U-boot part was wrong.

Finally I got the access back by press and hold the reset button at the back of the device. It resets the configuration files. But I'm still in the fear of bricking it as I am new to this world. A bailout method for the worst case scenario would be very helpful.

You previously said you tried the 'Recovery (Automatic)' method 3 times.

I've personally not had any issues returning any of my collection of EA6350 to Linksys stock firmware using the method. One thing I have observed is when I reverted to previous Linksys firmware, it is how it was 'configured' prior to installing OpenWrt. ie. not factory default settings.

Another observation when performing a factory reset of Linksys stock firmware, the resulting default LAN IP can be totally random! ie. not default 192.168.1.1.

I don't think anyone has ever totally bricked their EA6350 v3, which is probably why there is no documented 'bailout method' yet. I think I did try using linksys's own TFTP windows utility for curiosity but never got it to work.

Issues with VLAN tagging is a known problem/feature with IPQ40xx devices at this time. It is mentioned at bottom of the owrt wiki for EA6350 v3.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.