EA4500 v1 OpenWrt 17.01.4 No WAN/Internet Connection

Flashed firmware, can access router GUI, but I cannot get a WAN connection established no matter what.

My ISP is Comcast. I can connect the modem to my router with the default firmware, and I can even connect directly to my PC, but nothing I do creates a connection between the modem and the OpenWRT-flashed router.

I've tried restarting both together and independently, disconnecting and reconnecting cables. Even tried changing the MAC address on the WAN connection in the settings. Nothing works.

I have followed the steps here: https://openwrt.org/docs/guide-quick-start/ts-internetconnectivity

Neither WAN connection shows an IP address.

I should add that my modem is a Motorola sb6121.

Any help would be appreciated.


Could be alot of thing, first you have to check & read https://openwrt.org/toh/linksys/ea4500 carefully.
(serial) Logs would be appreciated as well as some config.
If serial does not return any info when connecting to WAN, the physical port could be defect.
It's possible that eth0 and eth1 are mixed-up after running openWrt and you need to change config files, although i doubt that in this case as you can get to GUI, you wrote.

There's also a note @ the bottom of the link:
The EA4500 runs a bit warm hence it may not reboot when warm (hot). It's important for the EA4500 to stay cool with a fan blowing cool air straight at it during flashing and rebooting to avoid any complication!
Be aware of that too, as complications can be anywhere.