E8350 why not supported by OpenWrt

I've been using the latest version with the correct model name in the past few days. It's 5G signal has been stable and I haven't had any issue so far.

I've installed the image on my R7500 v1 right now and I'm very impressed so far. The 5GHz wi-fi is working perfectly and stable.
When will the driver be added to the master branch? (I'm missing wireguard in packages :wink: )

i got a problem with 5ghz wifi.
it must be power off completely to make it works again after reboot or make changes that need to reboot.
im on e8350 squashfs-factory last build date 2sep2020
before im using pandorabox version and cannot use 5ghz wifi
on linksys original firmware (every version have spesific bug) and the 5ghz wifi got random disconnect and off some times

kmod-ata-marvell-sata_5.4.52-1_arm_cortex-a15_neon-vfpv4.ipk is not match the version of this firmware cause i can not use the esata port ,will you guys give me the right driver for esata?

Is there any way to make 5G led flash on connection or not supported in driver

Also tried to install manually via ssh dependency from google drive/packages for qos but they are not compatible
root@OpenWrt:~# opkg install /tmp/kmod-sched-connmark_5.4.66-1_arm_cortex-a15_ne
on-vfpv4.ipk
Installing kmod-sched-connmark (5.4.66-1) to root...
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-sched-connmark:
  •  kernel (= 5.4.66-1-b6ce88a6e4cc7e9e71eb457e1eb001f2)
    
  • opkg_install_cmd: Cannot install package kmod-sched-connmark.
    What am I doing wrong?

2 posts were merged into an existing topic: Is it possible to use LEDE on Zyxel NBG6816?

I'm currently running your R7500v1 image for a couple of days and 5GHz WiFi is working like a charm! After I bought this router (and found out it was a v1 instead of a v2) I tried to integrate the driver and firmware myself but I couldn't get it to work. So thank you so much for your work on this router, and I sincerely hope that this is getting merged.

1 Like

Hi,

Is there any easy way just to install the driver for Quantenna QT3840BC + QT2518B on R7500v1?
or install OPKG

or any way to install the driver? I tried the image but I couldn't set a password...

  • At the moment e8350 patches are submitted for official inclusion into openwrt.
  • Quantenna wifi driver will be the next as part of the package section. Some work on the LUCI web UI has to be done so that can be configured natively for openwrt.
    ( and yes quantenna driver is the same for R7500v1 and E8350)
2 Likes

@tcolov
Thx for info, will You also maintain support for netgear r7500v1 or only asus?

Quantenna wifi driver is the same for both Netgear R7500v1 and Linksys E8350. It will be part of the package section.

1 Like

Hi @tcolov,

Thank you for putting together and sharing the images!

A quick question about usage: I flashed the E8350 with the factory.bin, configured the network, then reboot -- all the settings were gone.
I then sysupgrade it with the ubi, then further configs can survive the reboots.

Is this behavior normal?

Thanks!

Nand driver is buggy. (Sync command and reboot can cause the error). You can see the error on dmesg.
As workaround, you can use rootfs on external USB flash drive.

Is this driver already included in openwrt or just on Google drive snapshot? Is any ETA for full support in main trunk for netgear r7500 v1. Will I loose 5Ghz if upgrade to newest openwrt via sysupgrade

The issues with the nand flash memory are Linksys E8350 specific and are already part of the openwrt kernel.

I've already submitted patches to include Linksys E8350 into the openwrt.

Wifi 5G driver is another driver, which I intend to submit after E8350 inclusion as part of the openwrt packages.

1 Like

Hi @tcolov,

Do you know where to get offical Quantenna FW? I see linux kernel driver shows the FW name is "qtn/fmac_qsr1000.img". But I did not find the FW from https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/

tony@tony-desktop /project/kernel/git/torvalds/linux/drivers/net/wireless/quantenna/qtnfmac
 % grep FW_NAME . -r        
./qtn_hw_ids.h:#define QTN_PCI_PEARL_FW_NAME            "qtn/fmac_qsr10g.img"
./qtn_hw_ids.h:#define QTN_PCI_TOPAZ_FW_NAME            "qtn/fmac_qsr1000.img"
./pcie/topaz_pcie.c:            ret = qtnf_topaz_fw_upload(ts, QTN_PCI_TOPAZ_FW_NAME);
./pcie/pearl_pcie.c:    const char *fwname = QTN_PCI_PEARL_FW_NAME;

The firmware is not published yet. There are two different drivers: the one you mentioned is included into the main kernel but without firmware. The other, which is 'with' firmware is from the Netgear GPL code of R7500. The firmware is not compatible between the two drivers.

First off thank you so much for your work!

I have an E8350 and the 5ghz is working, but the 2.4ghz does not. It stays stuck on obtaining ip address for about 1 minute, then if it does connect there is no internet. Did anyone else have to configure 2.4ghz in any special way?

Thanks for your help.

Update 1: 2.4ghz works on the older image but manages around 0.10 mbps. As someone else mentioned earlier, the settings do not stick on the older version.

Update 2: on the newest version the 5ghz works great out of the box thanks to the rc.local script. Now I did get the 2.4ghz to work by not using luci and just enabling it in /etc/config/wireless, but the speeds are really bad still. I'm getting around 2 mbps down and 5 up. Any ideas here? What else everyone else getting? Let me know if you need me to post anything.

Update 3: On 2.4ghz, I tweaked the settings by disabling legacy rates and dissoc_low_ack to 0. If I'm right next to the router the speeds are great, but if I get about 10 feet away, the speed goes back down to 2mbps or less. Which is strange to me because the dbm is still around -25dbm.

#Current wireliess config (using rc.local to set 5ghz):
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option disabled '0'
        option legacy_rates '0'
        option country 'US'
        option txpower '20'
        option noscan '1'
        option bursting '1'
        option ff '1'
        option compression '1'
        option xr '1'
        option ar '1'
        option channel '8'
        option htmode 'HT40-'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt2'
        option encryption 'psk2'
        option key ''
        option disassoc_low_ack '0'

config wifi-device 'radio1'
        option type 'quantenna'
        option channel '36'
        option hwmode '11ac'
        option phy 'host0'
        option disabled '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

Update 4: Replaced the driver ath10k-firmware-qca988x-ct with ath10k-firmware-qca988x and it looks like I got wifi speeds up to where they should be.

Update 5: Settings no longer stick :frowning: Not sure what happened but I can't get anything to stay on the nand.

On 5ghz I'm also having dropped packets and disconnects while utilizing ssh forwarding. I tunnel through termux to my home debian machine and it cannot maintain a connection. Not sure if there is a fix for this, but thought I'd mention it. Again, thank you so much @tcolov for working on this!