E4200 v2 High Ping/Latency on 2.4 ghz

Installed 22.03.5 last night. Came directly from the Stock firmware. Everything seems to work fine except the 2.4 ghz. Just being used as an AP. It mostly gets consistent pings like the example below. I've even seen it go as 4500 ms. Test with quite a few devices, IoT plugs/switches, Phones, Laptops, etc. The 5 ghz works fine.

64 bytes from seq=76 ttl=254 time=731.981 ms
64 bytes from seq=77 ttl=254 time=240.672 ms
64 bytes from seq=78 ttl=254 time=879.409 ms
64 bytes from seq=79 ttl=254 time=903.166 ms
64 bytes from seq=80 ttl=254 time=443.914 ms
64 bytes from seq=81 ttl=254 time=438.901 ms
64 bytes from seq=82 ttl=254 time=871.508 ms
64 bytes from seq=83 ttl=254 time=895.352 ms
64 bytes from seq=84 ttl=254 time=919.211 ms
64 bytes from seq=85 ttl=254 time=840.874 ms
64 bytes from seq=86 ttl=254 time=863.616 ms
64 bytes from seq=87 ttl=254 time=376.583 ms
64 bytes from seq=88 ttl=254 time=11.251 ms
64 bytes from seq=89 ttl=254 time=414.087 ms
64 bytes from seq=90 ttl=254 time=856.898 ms
64 bytes from seq=91 ttl=254 time=880.470 ms
64 bytes from seq=92 ttl=254 time=905.263 ms

I tried flashing every major release of OpenWRT except for 18 and they all have the same issue. Doesn't have the problem on stock firmware and I've also tested the same devices connected to different routers that have either Tomato or DD-WRT on them. I've set the country code and tried different power levels. All of the device that connect are within 5-10 meters. When testing other routers I configured the WiFi to use the same settings and channel. This even happens when there's only one device connected to the WiFi.

CPU Load Average usually sits between 0.00, 0.00, 0.00 to 0.08, 0.03, 0.01

There have been a couple of times that it had normal pings for a few minutes. One time it lasted about 20 minutes before I rebooted to see if it would work afterwards. Which it didn't. The first time it started working briefly was after changing the Beacon Interval which I seen others recommend on here for the high pings. But usually for the first few seconds after making any change to the router config, the pings will drop down to a normal range then go back up. See below...

64 bytes from seq=18 ttl=254 time=886.056 ms
64 bytes from seq=19 ttl=254 time=808.775 ms
64 bytes from seq=20 ttl=254 time=881.463 ms
64 bytes from seq=29 ttl=254 time=6.408 ms
64 bytes from seq=30 ttl=254 time=6.298 ms
64 bytes from seq=31 ttl=254 time=6.185 ms
64 bytes from seq=32 ttl=254 time=4.971 ms
64 bytes from seq=33 ttl=254 time=4.601 ms
64 bytes from seq=34 ttl=254 time=5.621 ms
64 bytes from seq=35 ttl=254 time=5.343 ms
64 bytes from seq=36 ttl=254 time=4.958 ms
64 bytes from seq=37 ttl=254 time=417.929 ms
64 bytes from seq=38 ttl=254 time=849.645 ms
64 bytes from seq=39 ttl=254 time=464.467 ms
64 bytes from seq=40 ttl=254 time=900.295 ms

The below are pings to a Windows Laptop. These were similar on an Android phone, done while the phone was unlocked/screen on...

64 bytes from seq=0 ttl=127 time=418.915 ms
64 bytes from seq=1 ttl=127 time=171.575 ms
64 bytes from seq=2 ttl=127 time=421.423 ms
64 bytes from seq=3 ttl=127 time=171.977 ms
64 bytes from seq=4 ttl=127 time=4187.917 ms
64 bytes from seq=5 ttl=127 time=3187.737 ms
64 bytes from seq=6 ttl=127 time=2187.540 ms
64 bytes from seq=7 ttl=127 time=1188.119 ms
64 bytes from seq=8 ttl=127 time=187.691 ms
64 bytes from seq=9 ttl=127 time=4136.617 ms
64 bytes from seq=10 ttl=127 time=3137.496 ms
64 bytes from seq=11 ttl=127 time=2137.303 ms
64 bytes from seq=12 ttl=127 time=1137.101 ms
64 bytes from seq=13 ttl=127 time=136.923 ms

Another thing, pings initiated from these devices are normal. It only seems to happen when the pings are initiated from other devices to them.

Any thoughts? Am I overlooking something or is this just a issue with OpenWRT and this chipset?

Maybe this applies:

Even though mine is Marvell and not Broadcom, that's what I was thinking too. Just a limitation with the FOSS driver. I don't have much experience with OpenWRT since I've mostly used Broadcom routers in the past. Since I haven't used it much, I wasn't sure if I was overlooking something for a possible fix or workaround. I also don't want to keep trying to fix something that is a known compatibility issue/limitation.


Played around with it a little more. What I've noticed is that once a device drops down to an RX/TX rate of 6.0/1.0, is when the Pings skyrocket. You can log into the device and try to initiate more traffic, but the Rate never increases again and the Pings stay high until it will randomly jumps back up to 54 Mbit/s.