E3372 change mode

I have a Huawei e3372 153 stick version which is able to work with openwrt after some package installations...
Now I need to plug this modem on an Asus rt ac66u modem. But there is no internet connection. In the past, I make that run with a e3372 hilink router. I think this asus router cannot run ndis modem.

My question: does anyone know if it is possible to install hilink firmware on this USB key and the way to do that? I think it is possible after having saw the opposite installation, and a lot of comments.
It would be nice to have a complete description on w7 because I am not at home for the moment!
Thank you

Witch version is? E3372h or E3372s.
H stand for hilink, S stand for serial.

Might want to look into alternative AC68U firmwares, like Tomato or Merlin.

DC unlocker / Putty :

Found modem         : E3372
Model               : Huawei E3372 / MTC 827F
IMEI                : xxxxxxxxxxxxx
Serial NR.          : 0123456789ABCDEF
Firmware            :
Compile date / time : Aug 20 2014 17:30:11
Hardware ver.       : CL1E3372SM
Dashboard version   : UTPS23.
SIM Lock status     : unlocked
Wrong codes entered : 0 (unlock attempts left : 10)

Thank you for your help!

I downloaded Advanced Tomato and ASUSWRT Merlin. Same result. Not possible with my RT AC66U.

My E3372 is able to connect to APN with DashBoard/ Mobile partner on W7 .
I was also able to have a connection with OpenWRT on x86.

Thank you for your help!


Check the sticker on the E3372, but if you get a 192.168 IP on it's LAN side, it's probably the h model.

Problem with the AC68U is it doesn't run openwrt, it's using Broadcom hardware :frowning:

if you don't need wifi, r00ter will probably work - https://www.ofmodemsandmen.com/routers.html

Converting the modem from h to s, doesn't really guarantee any success, unless google says otherwise.

I'd buy a 2nd router, just something with an ethernet and USB port, which is openwrt supported,
and run the LTE stick through it.

This thread claims the E3372 should work in RMerlin and Asus FW - https://www.snbforums.com/threads/asuswrt-merlin-4g-modems-support.30840/

Firmware V21.x is a S version, serial stick.
Converting from H to S is a easy job. Done a few of them for myself.
Converting S to H is nearly impossible.

yes I saw a lot of successful description from H to S.
some start of description from S to H but nothing complete.

Do you know if it is the same hardware S and H?
The method (GND on a specific pad) which make enter the e3372 in a bootloader mode is not sufficient for S to H conversion?

Thank you!

Sorry can´t say for sure..
But I can tell you I own a H version, with Stick mode provided from the ISP, never needed to convert this one ( marked as H ) but with v21.x firmware, maybe was my ISP request from huawei. But in other hand, I got some E3372 with S marked but with Hlink firmware v22. ( got them from some aliexpress dealer )
In fact the ones marked as S ( from aliexpress ), I just follow the H steeps ( balong usb loader ) to get it in stick mode.
These 2 are mine, never been modified, H and S version marked on sticker, but both are in S mode from ISP, pretty same external case, one black other white case.



it's true, I saw that, and it is ambiguous. E3372s with S brand and H firmware and vice versa.

I would try the 'Balong' manipulation but I'm afraid of wasting my time!

I have another RT AC56U router that accepts newer ASUSWRT Merlin FWs than the RT AC66U. I will try the e3372 Stick on it.
But I read also somewhere that older versions of ASUSWRT Merlin worked with the S, but not the newer ones. And I read the opposite too...

Thanks again!