E3000 Upgrade -- missing bin? [Solved]

I'm trying to upgrade an E3000 from 14.0.x to LEDE. (HW page: https://lede-project.org/toh/hwdata/linksys/linksys_e3000_v1)

The hardware matrix, https://lede-project.org/toh/views/toh_fwdownload has a factory install image, but is missing the sysupgrade image.

I tried using the factory image as an upgrade image, and LuCI rejected it as "The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

Are there some special instructions to follow for that case?

Have you tried using sysupgrade, yet? Upload the image to the router's /tmp, then do a sysupgrade -n 'image'. You'll be reconfiguring it from scratch, of course..

Failing that, you can always try mtd..

As described in:
E3000 is based on same hardware as WRT610N, as stated in their page (please read entire section):

If sysupgrade does not support this router, use the following commands.

cd /tmp/
wget http://downloads.openwrt.org/latest/brcm-2.4/openwrt-brcm-2.4-squashfs.trx
mtd write /tmp/openwrt-brcm-2.4-squashfs.trx linux && reboot
1 Like

So I tried that, that is what I saw. I wget-ed http://downloads.openwrt.org/releases/18.06.1/targets/brcm47xx/generic/openwrt-18.06.1-brcm47xx-generic-linksys-e3000-v1-squashfs.bin (the latest e3000 image) to /tmp/ and ran mtd write openwrt-18.06.1-brcm47xx-generic-linksys-e3000-v1-squashfs.bin linux and mtd failed, and I checked and I have no partition named 'linux' on my 14.04 install.

These are the partitions I do have

root@OpenWrt:/tmp# cat /proc/mtd
dev: size erasesize name
mtd0: 00040000 00010000 "boot"
mtd1: 007b0000 00010000 "firmware"
mtd2: 000008f0 000008f0 "loader"
mtd3: 001122f4 00010000 "linux"
mtd4: 0069d400 00010000 "rootfs"
mtd5: 00450000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "nvram"

... but I'm not sure which to write to. I tried writing to "firmware" and I think I narrowly escaped bricking the router, because it overwrote some sort of settings partition and the router rebooted with some FS read error messages in dmesg and reset its configuration.

Do you have any idea which partition I should write that image to?

Hope this follow up is useful to someone.

I realized I missed a direction on the e3000 wiki page, you are supposed to convert the squashfs.bin into a "trx" by running e.g. nathan@debian:~/t$ dd of=firmware.trx bs=32 skip=1 if=lede-17.01.2-brcm47xx-generic-linksys-e3000-v1-squashfs.bin 123008+0 records in 123008+0 records out 3936256 bytes (3.9 MB, 3.8 MiB) copied, 0.194182 s, 20.3 MB/s nathan@debian:~/t$ scp firmware.trx root@

... then you can run sysupgrade firmware.trx, and it will upgrade.

And that got me to 17.0.2. If I'm feeling adventurous I might even try upgrading to 18.xx :stuck_out_tongue:

sysupgrade is supposed to take *.bin files as well, but there was a bug breaking this automated header stripping that only got fixed ~half a year(?) ago, it should work again from 18.06.0 upwards.

1 Like

Awesome, thanks for the heads up

@nmr If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

OK, one more necro for the sake of posterity.

I tried dd'ing the 'snapshot install image' from the file matrix (nathan@debian:~/Downloads$ md5sum firmware.trx acc041e55c3bbaf615fa424b1c98b282 firmware.trx nathan@debian:~/Downloads$ md5sum openwrt-brcm47xx-generic-linksys-e3000-v1-squashfs.bin abdb46931f1292a5540aa75e78f19274 openwrt-brcm47xx-generic-linksys-e3000-v1-squashfs.bin)

And while that installed Luci no longer worked.

I then tried installing the "open wrt install image" nathan@debian:~/Downloads$ md5sum openwrt-brcm47xx-generic-linksys-e3000-v1-squashfs.bin firmware.trx abdb46931f1292a5540aa75e78f19274 openwrt-brcm47xx-generic-linksys-e3000-v1-squashfs.bin b754e8d676044330b8d20bf257cd7f18 firmware.trx and that also installed overtop the previous install and Luci came up after reboot. I'm not sure which one I should have used, so hopefully this final note helps someone else.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.