Dynamic VLAN tagging error

Stripped config elements:

> user@openwrt:/etc/config# cat network
> 
> ...
> 
> config interface 'wan'
>         option proto 'dhcp'
>         option device 'eth0.10'
>         option type 'bridge'
> 
> config switch
>         option name 'switch0'
>         option reset '1'
>         option enable_vlan '1'
> 
> ...
> 
> config switch_vlan
>         option device 'switch0'
>         option vlan '2'
>         option ports '6t 1'
>         option vid '10'
>         option description 'VLAN10'
> 
> config switch_vlan
>         option device 'switch0'
>         option vlan '3'
>         option vid '172'
>         option description 'VLAN172'
>         option ports '6t 5 1t'
> 
> ...
> 
> config switch_vlan
>         option device 'switch0'
>         option vlan '5'
>         option ports '6t 3 1t'
>         option vid '1723'
>         option description 'VLAN1723'
> 
> ...
> 
> config interface 'vlan1723'
>         option proto 'none'
>         option device 'br-vlan1723'
> 		
> config device
>         option name 'br-vlan1723'
>         option type 'bridge'
>         list ports 'eth0.1723'
> ...
> 
> config interface 'VLAN172'
>         option proto 'none'
>         option type 'bridge'
>         option device 'br-vlan172'
> 
> config device
>         option type 'bridge'
>         option name 'br-vlan172'
>         list ports 'eth0.172'
> 		
> ...
> 
> 
> user@openwrt:/etc/config# cat wireless
> 
> config wifi-device 'radio0'
>         option type 'mac80211'
>         option hwmode '11a'
>         option path 'pci0000:00/0000:00:00.0'
>         option cell_density '0'
>         option country ' *redacted* '
>         option channel '56'
>         option htmode 'VHT40'
>         option txpower '18'
> 
> config wifi-iface 'default_radio0'
>         option device 'radio0'
>         option mode 'ap'
>         option encryption 'wpa2'
>         option auth_server ' *redacted* '
>         option auth_port ' *redacted* '
>         option auth_secret ' *redacted* '
>         option dynamic_vlan '2'
>         option vlan_tagged_interface 'eth0'
>         option vlan_bridge 'br-vlan'
>         option vlan_naming '0'
>         option ieee80211r '1'
>         option mobility_domain ' *redacted* '
>         option ft_over_ds '1'
>         option ft_psk_generate_local '0'
>         option nasid ' *redacted* '
>         option r1_key_holder ' *redacted* '
>         list r0kh ' *redacted* '
>         ...
>         list r1kh ' *redacted* '
>         option reassociation_deadline '20000'
>         option rsn_pairwise 'CCMP'
>         option rsn_preauth '1'
>         option ieee80211k '1'
>         option bss_transition '1'
>         option pmk_r1_push '1'
>         option ssid ' *redacted* '

user@openwrt:/etc/config# cat /etc/hostapd.vlan

  • wlan0.#
  • wlan1.#

user@openwrt:~# brctl show
bridge name bridge id STP enabled interfaces
...
br-vlan172 7fff.14cc2091841b no wlan0-1
eth0.172
wlan1.172
...

Updated packages:
wpad	2020-06-08-5a8b3662-40
hostapd-common	2020-06-08-5a8b3662-40

All on  OpenWrt 21.02.2, r16495-bf0c965af0