Dynamic routing with OSPFv3

I have a problem that i don't find any page to properly configure my ospf6d.conf and zebra.conf files in OSPFv3. I want to set dynamic routes between these 3 routers to, at least, make a ping from one router to another in all of their IPv6 adresses interfaces. I have already set IPv6 addresses on each interface of each VLAN.

Any reason why you use ospf6d? I find bird2 far more modern any elegant to use, but just my personal opinion, and it fits in around 1 MB on OpenWRT, including the bird-client (birdc) to interact with the daemon.

Either way, you have

  • IPv6 Link Local Addresses on all interfaces you want to use for OSPFv3? In theory and practice you do not need anything else. Only link local addresses on routes on these interfaces.
  • A /128 addresses used as an (internal/local) unique router address assigned on lo (loopback), and have loopback configured as an stub-interface?
  • (Because it could be an issue) have set the proper interface type? Like point-to-point, or multicast?
  • Your routing daemon is aware of all interfaces and necessary interface routes?
  • any daemon or log you like to share where we might can spot an issue?

It would also help me and others who want you offer help, if you share your openwrt interface config and the config of ospf6d.

I just saw the reply, here are my files that you asked earlier. Hope it helps to solve my problem and i will dig into bird2 to know more about that daemon :slight_smile: this is my ospf6d.conf file

password whatever
router ospf6
interface eth0.10 area 0.0.0.1
 area 0.0.0.1 range 2001:1328:0056:e800::1/127

interface eth0.40 area 0.0.0.1
 area 0.0.0.1 range 2001:1328:0056:e800::4/127

interface eth0.80 area 0.0.0.1
 area 0.0.0.1 range 2001:1328:56:e800::1f0/123
 
interface eth0.90 area 0.0.0.1
 area 0.0.0.1 range 2001:1328:56:e800::30/123

And this one is my network file


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd6a:3d39:1a47::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config device
	option name 'eth0.2'
	option macaddr 'a4:2b:b0:03:9d:67'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 1'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '0t 3'
	option vid '10'
	option description 'primer vlan VLAN 10'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '0t 4'
	option vid '40'
	option description 'cuarta vlan vlan40'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option ports '0t 5'
	option vid '80'
	option description 'vlan80 a-1'

config interface 'wwan'
	option proto 'dhcp'

config interface 'vlan80'
	option proto 'static'
	option device 'eth0.80'
	option ipaddr '10.3.80.161'
	option netmask '255.255.255.224'
	option broadcast '10.3.80.191'
	list ip6addr '2001:1328:56:e800::30/123'

config interface 'valn10'
	option proto 'static'
	option device 'eth0.10'
	option ipaddr '10.3.80.1'
	option netmask '255.255.255.252'
	option broadcast '10.3.80.3'
	list ip6addr '2001:1328:0056:e800::1/127'

config interface 'vlan40'
	option proto 'static'
	option device 'eth0.40'
	option ipaddr '10.3.80.9'
	option netmask '255.255.255.252'
	option broadcast '10.3.80.11'
	list ip6addr '2001:1328:0056:e800::4/127'

config switch_vlan
	option device 'switch0'
	option vlan '6'
	option ports '0t 2'
	option vid '90'
	option description 'vlan90 a-2'

config interface 'vlan90'
	option proto 'static'
	option device 'eth0.90'
	option ipaddr '10.3.80.193'
	option netmask '255.255.255.224'
	option broadcast '10.3.80.223'
	list ip6addr '2001:1328:56:e800::30/123'

this is the router that connects to the VPN.

I'm only with my phone the next days....

Ok, can you ping all interface addresses from each peer to the other?

Again, if you have ipv6 link local addresses on all interfaces and multicast is enables on these interfaces you need nothing more. Just assign a /128 address to loopback and you should everything as in you want to be able to ping each router. After ospf startup you need to wait for about half a minute to a full minute till all states are in sync and the ospf database have formed properly.

Why do you need area 0.0.0.1 and do not have everything in area 0.0.0.0? If there is no reason for not using area 0, please do so because it makes initial config easier.

Does your daemon provide any status information? Where you could see the current status/state of the ospf.

If you give bird a try, checkout it's wiki for a minimal config and examples. Their Mailinglist is also quiet friendly and responsive to n00b questions. I can send you a config example next week because I'm on vacation without PC :wink: