Dynamic DNS does not change the IP address on openwrt itself/other devices

Since I upgraded to v21 and had some problems with it that were solved super fast with the help of the forum. Thanks for that again!
I would like to fix another problem that has been there for a while.

I use dnscrypt and adguard home. Everything works fine. But every time I reboot the IP changes. So I use dynamic DNS to push my new IP address to the provider. This also works fine.
The problem now is that nslookup shows me the old IP on the router itself. When I restart adguard it changes but I would like to have that without a restart if possible.
This fixes openwrt but not the other connected devices. I usually add the IP address manually to the "Hostnames" and domain. This is annoying after a while.

My questions are:

  1. Do I have to restart AdGuard every time the IP changes?
  2. Do I need to change the IP address manually?
  3. Is it possible to do all this without a script? Actually just another option?

I have it this way because I also use VPN on my local network.


It sounds like a caching issue. Can you verify that resolving directly from a public nameserver, e.g gives the correct response? nslookup www.example.com

Sorry I was very busy.

I think it has something to do with AdGuard Home.
nslookup is fine for this domain. But for my specific problem it redirects to This is only the case if I have not added the "hostnames" manually. Everything is fine on the router itself. Only the devices behind the router get a redirection to My blocklist (StevenBlack....) in adguard are quite many. So I will try to disable one by one. Maybe it is blocked somewhere there.

So that wasn't the problem.
The router gives me the correct IP, but everything behind the router gives me an old/wrong IP.

I just restarted adguard .... nothing.
I restarted dnscrypt and now it works. Must be a cache problem there or something.

This is probably my solution:
Disable cache in AdGuard Home (cache size = 0) and restart dnscrypt when Dynamic DNS has received a new IP address.
I'm not 100% sure how I'm going to do this, but when I have a solution I'll leave a comment here.

1 Like