Dynalink WRX36 - sporadic wireless clients ping issue

Reagrdiong:

I do it too to preserve the default route it is actually what OpenVPN does by default and also a lot of other third party firmwares.

regarding

That is to signal to e.g. PBR you have this openvpn interface

I do agree maybe reset to default and start fresh could help, but there are also some wifi driver problems reported and under investigation.

There is an option in the wifi to isolate wifi clients from each other so isolation can be something which is/can be done on the wireless driver

3 Likes

OK so I followed your instruction
1/ removed dnsmasq

install dnsmasq-full...
Configuring libnfnetlink0.
Configuring kmod-nf-conntrack-netlink.
Configuring libnetfilter-conntrack3.
Configuring dnsmasq-full

reboot
2G<=>5G OK
5G<=>5G Destination host unreachable

2/ removed wpad-basic-mbedtls

install wpad-openssl...
Configuring wpad-openssl

reboot
2G<=>5G OK
5G<=>5G Destination host unreachable

3/ removed libustream-mbedtls20201210

install libustream-openssl20201210...
Configuring libustream-openssl20201210

reboot
2G<=>5G OK
5G<=>5G Destination host unreachable

4/ disabled 'delegate IPv6 prefixes' on both lan & wg0 interfaces
reboot
2G<=>5G OK
5G<=>5G OK! :dizzy_face: OK for approximately ~1hour then Destination host unreachable

I have the VPN wireguard/openvpn DNS listed in wan section...

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option peerdns '0'
	list dns '10.0.0.243'
	list dns '10.0.0.242'

That's how my VPN provider rolls, Yes I'm aware of 0.0.0.0/0 though.

Not disabled, only Not started on boot, as I have a script which brings up wg0 / tun0 via a cron job.

That just it...
I started from scratch barebone install, left the dhcp / network / firewall / wireless and config files intact, then added packages and only adding snippets of what I thought was safe to add to each config.

The majority/backbone of each config file is intact, i.e. I haven't just transplanted everything over from the TP-Link c2600.

I'll keep the config how it is for the time being, let's see how this pans out.
Thanks for the help @frank92735 :star:

My hunch it's a WiFi issue, and it seems the latest WiFi drivers (WLAN.HK.2.9.0.1-01837) addition has caused more issues. Looking back I think 4 days on the old driver, was about the most time without error, with the new driver I had immediate issues.

1 Like

Nice catch. I also forgot to advise @otnert to uci export wireless. Ooops sorry!

Roll back and watchcat/cron every 3 days?

I went back to 1835 see: Ath11k possible firmware bug - traffic interruptions when a client disconnects from WLAN - #18 by egc

With that build I had no trouble pinging from my phone to my laptop (both on 5 GHz, 80 MHz see above) but the other way around from laptop to phone I got some strange results it starts with host unreachable but after some 4 pings it started to work with ping times alternating between 4 and 400 ms.

Turns out the phone is on very aggressive power saving, if I run a ping test from the phone itself to the internet to get it up and active I have consistent ping times from laptop to phone of 4ms.

Have not investigated how to disable the powersavings on the phone, there might be a setting on the router to do something in that department, I think :slight_smile:

1 Like

Haha I was going to show it to you anyway!

root@OpenWrt:~# uci export wireless
package wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option country 'US'
	option channel '149'
	option band '5g'
	option htmode 'HE80'
	option cell_density '0'
	option txpower '30'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrX_5GHz'
	option encryption 'psk2+ccmp'
	option key 'xxxxxxxxxx'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+1'
	option channel '6'
	option band '2g'
	option htmode 'HE20'
	option cell_density '0'
	option txpower '30'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrX'
	option encryption 'psk2+ccmp'
	option key 'xxxxxxxxxx'
	option disassoc_low_ack '0'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrX_5GHz_G'
	option encryption 'psk2+ccmp'
	option key 'xxxxxxxxxx'
	option network 'guest'
	option isolate '1'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'OpenWrX_G'
	option encryption 'psk2+ccmp'
	option key 'xxxxxxxxxx'
	option network 'guest'
	option isolate '1'

Since the c2600 has a switch config, and the WRX36 DSA, could you just take a look at the guest components in network, dhcp, firewall & wireless. Just want to make sure I did that correctly, and it isn't contributing to this ping issue.

As an end-user it all seems to work.

Yes I have this set for both guest SSID's

Yes! so did I (just between posts)... as the same ping issue started to occur using the 01837 rc2 version.

It's strange that if you where to change from 5G to 2G and pinging the remote 5G host, the ping issue disappears. From here if you then move back to 5G, to ping the same remote 5G host it somehow resets the 5G ping issue.

The problem is not knowing how long before the 5G connection will remain in a working condition.

Just before moving over to 01835, my remote PC went to sleep, upon waking it from sleep, the issue appeared again.

Yes I also have 2x androids, and as soon as the screen goes blank, it gives you the impression the ping issue has started. I run a speedtest on the phone to wake it up long enough to ping it.

It is even possible that a wifi client disconnects after a period of inactivity so you cannot ping it at all unless you wake it up. So that makes it hard to see what is going on and where the problem lies, my quick test did not show a problem but that is what it is just a quick test.

To be honest I seldom have wifi<>wifi traffic as my house is cabled, of course phones and tablets are on wifi but PC's and laptops are using ethernet :slight_smile:

1 Like

This is true for all wireless devices. I hope you are considering this in regards to your "sporadic" ping issue.

Is there an actual issue with devices and their Internet connectivity when doing things (e.g. stream, gaming, talking to the spouse on WiFi calling, etc.)?

2 Likes

There's the unperceived issue that all is working 'under the hood'. All devices seem to operate as intended toward internet connectivity. My phones, TV's, PC's, tablet work in this regard.

Windows shared folder access/connectivity is broken if PC's cannot ping each other.

I have one 2GHz device that loses WiFi connection and cannot reestablish it without turning it off/on again even after adding option disassoc_low_ack '0' in wireless.

As I've noted above, all these devices work correctly if I'm using my TP-Link c2600 on 22.03.5

1 Like

So I clean installed 23.05.0-rc2 with the requested packages, and removal of ipv6 on the interfaces.

Windows.
2.4G<=>2.4G is OK
2.4G<=>5G & 5G<=>2.4G OK

5G<!>5G not OK
-can get ping replies by moving to 2.4G, then back onto 5G on the same Windows PC.
-if rebooting the router both windows devices connect, but no ping replies

Android mobiles
-2.4G & 5G not OK, no ping replies

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.118",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "Dynalink DL-WRX36",
        "board_name": "dynalink,dl-wrx36",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.0-rc2",
                "revision": "r23228-cd17d8df2a",
                "target": "ipq807x/generic",
                "description": "OpenWrt 23.05.0-rc2 r23228-cd17d8df2a"
        }
}
root@OpenWrt:~# uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3d:ffb5:b8c6::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option delegate '0'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option auto '0'
        option reqaddress 'none'
        option reqprefix 'no'
        option delegate '0'
root@OpenWrt:~# uci export dhcp
package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
root@OpenWrt:~# uci export firewall
package firewall

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'
root@OpenWrt:~# uci export wireless
package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/c000000.wifi'
        option channel '149'
        option band '5g'
        option htmode 'HE80'
        option disabled '0'
        option country 'US'
        option txpower '30'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrX_5GHz'
        option encryption 'psk2+ccmp'
        option key 'xxx'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/c000000.wifi+1'
        option channel '6'
        option band '2g'
        option htmode 'HE20'
        option disabled '0'
        option country 'US'
        option txpower '30'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrX'
        option encryption 'psk2+ccmp'
        option key 'xxx'
ath11k-firmware-ipq8074 - 2023-07-06-69f6b734-1
attendedsysupgrade-common - 8
attr - 2.5.1-1
avahi-dbus-daemon - 0.8-8
base-files - 1537-r23228-cd17d8df2a
block-mount - 2023-02-28-bfe882d5-1
busybox - 1.36.1-1
ca-bundle - 20230311-1
cgi-io - 2022-08-10-901b0f04-21
coreutils - 9.3-1
coreutils-base64 - 9.3-1
curl - 8.1.2-1
dbus - 1.13.18-12
dnsmasq-full - 2.89-4
dropbear - 2022.82-5
f2fs-tools - 1.16.0-1
f2fsck - 1.16.0-1
firewall4 - 2023-03-23-04a06bd7-1
fstools - 2023-02-28-bfe882d5-1
fwtool - 2019-11-12-8f7fe925-1
gdisk - 1.0.9-1
getrandom - 2022-08-13-4c7b720b-2
hostapd-common - 2023-06-22-599d00be-1.2
htop - 3.2.2-1
ip-full - 6.3.0-1
ipq-wifi-dynalink_dl-wrx36 - 2023-06-03-cd9c30ca-1
iw - 5.19-1
iwinfo - 2023-05-17-c9f5c3f7-1
jansson4 - 2.14-3
jq - 1.6-2
jshn - 2023-05-23-75a3b870-1
jsonfilter - 2018-02-04-c7e938d6-1
kernel - 5.15.118-1-1dcfa3a505bce2d100655fb06322f372
kmod-asn1-decoder - 5.15.118-1
kmod-ath - 5.15.118+6.1.24-3
kmod-ath11k - 5.15.118+6.1.24-3
kmod-ath11k-ahb - 5.15.118+6.1.24-3
kmod-cfg80211 - 5.15.118+6.1.24-3
kmod-crypto-acompress - 5.15.118-1
kmod-crypto-aead - 5.15.118-1
kmod-crypto-ccm - 5.15.118-1
kmod-crypto-cmac - 5.15.118-1
kmod-crypto-crc32 - 5.15.118-1
kmod-crypto-crc32c - 5.15.118-1
kmod-crypto-ctr - 5.15.118-1
kmod-crypto-gcm - 5.15.118-1
kmod-crypto-gf128 - 5.15.118-1
kmod-crypto-ghash - 5.15.118-1
kmod-crypto-hash - 5.15.118-1
kmod-crypto-hmac - 5.15.118-1
kmod-crypto-kpp - 5.15.118-1
kmod-crypto-lib-chacha20 - 5.15.118-1
kmod-crypto-lib-chacha20poly1305 - 5.15.118-1
kmod-crypto-lib-curve25519 - 5.15.118-1
kmod-crypto-lib-poly1305 - 5.15.118-1
kmod-crypto-manager - 5.15.118-1
kmod-crypto-michael-mic - 5.15.118-1
kmod-crypto-null - 5.15.118-1
kmod-crypto-rng - 5.15.118-1
kmod-crypto-seqiv - 5.15.118-1
kmod-crypto-sha256 - 5.15.118-1
kmod-crypto-sha512 - 5.15.118-1
kmod-fs-f2fs - 5.15.118-1
kmod-gpio-button-hotplug - 5.15.118-3
kmod-hwmon-core - 5.15.118-1
kmod-ipt-core - 5.15.118-1
kmod-ipt-raw - 5.15.118-1
kmod-leds-gpio - 5.15.118-1
kmod-lib-crc-ccitt - 5.15.118-1
kmod-lib-crc32c - 5.15.118-1
kmod-lib-lzo - 5.15.118-1
kmod-lib-textsearch - 5.15.118-1
kmod-libphy - 5.15.118-1
kmod-mac80211 - 5.15.118+6.1.24-3
kmod-nf-conntrack - 5.15.118-1
kmod-nf-conntrack-netlink - 5.15.118-1
kmod-nf-conntrack6 - 5.15.118-1
kmod-nf-flow - 5.15.118-1
kmod-nf-ipt - 5.15.118-1
kmod-nf-log - 5.15.118-1
kmod-nf-log6 - 5.15.118-1
kmod-nf-nat - 5.15.118-1
kmod-nf-nathelper-extra - 5.15.118-1
kmod-nf-reject - 5.15.118-1
kmod-nf-reject6 - 5.15.118-1
kmod-nfnetlink - 5.15.118-1
kmod-nft-core - 5.15.118-1
kmod-nft-fib - 5.15.118-1
kmod-nft-nat - 5.15.118-1
kmod-nft-offload - 5.15.118-1
kmod-nls-base - 5.15.118-1
kmod-phy-aquantia - 5.15.118-1
kmod-ppp - 5.15.118-1
kmod-pppoe - 5.15.118-1
kmod-pppox - 5.15.118-1
kmod-qca-nss-dp - 5.15.118+2022-04-30-72e9ec41-1
kmod-qca-ssdk - 5.15.118+2022-09-12-628b22bc-2
kmod-qrtr - 5.15.118-1
kmod-qrtr-smd - 5.15.118-1
kmod-scsi-core - 5.15.118-1
kmod-slhc - 5.15.118-1
kmod-thermal - 5.15.118-1
kmod-tun - 5.15.118-1
kmod-udptunnel4 - 5.15.118-1
kmod-udptunnel6 - 5.15.118-1
kmod-usb-core - 5.15.118-1
kmod-usb-dwc3 - 5.15.118-1
kmod-usb-dwc3-qcom - 5.15.118-1
kmod-usb-ehci - 5.15.118-1
kmod-usb-ohci - 5.15.118-1
kmod-usb-printer - 5.15.118-1
kmod-usb-storage - 5.15.118-1
kmod-usb-storage-uas - 5.15.118-1
kmod-usb-uhci - 5.15.118-1
kmod-usb-xhci-hcd - 5.15.118-1
kmod-usb2 - 5.15.118-1
kmod-usb3 - 5.15.118-1
kmod-wireguard - 5.15.118-1
libatomic1 - 12.3.0-4
libattr - 2.5.1-1
libavahi-client - 0.8-8
libavahi-dbus-support - 0.8-8
libblobmsg-json20230523 - 2023-05-23-75a3b870-1
libbpf1 - 1.2.2-1
libbz2-1.0 - 1.0.8-1
libc - 1.2.4-4
libcap - 2.69-1
libcurl4 - 8.1.2-1
libdaemon - 0.14-5
libdbus - 1.13.18-12
libelf1 - 0.189-1
libevdev - 1.13.0-1
libexif - 0.6.24-1
libexpat - 2.5.0-1
libf2fs6 - 1.16.0-1
libffmpeg-mini - 5.1.2-1
libflac - 1.3.4-1
libgcc1 - 12.3.0-4
libgmp10 - 6.2.1-1
libgnutls - 3.8.0-3
libid3tag - 0.15.1b-4
libiwinfo-data - 2023-05-17-c9f5c3f7-1
libiwinfo20230121 - 2023-05-17-c9f5c3f7-1
libjpeg-turbo - 2.1.4-2
libjson-c5 - 0.16-3
libjson-script20230523 - 2023-05-23-75a3b870-1
liblua5.1.5 - 5.1.5-10
liblucihttp-lua - 2023-03-15-9b5b683f-1
liblucihttp-ucode - 2023-03-15-9b5b683f-1
liblucihttp0 - 2023-03-15-9b5b683f-1
liblzo2 - 2.10-4
libmbedtls12 - 2.28.3-1
libmnl0 - 1.0.5-1
libncurses6 - 6.4-2
libnetfilter-conntrack3 - 1.0.9-2
libnettle8 - 3.9-1
libnfnetlink0 - 1.0.2-1
libnftnl11 - 1.2.6-1
libnghttp2-14 - 1.51.0-1
libnl-tiny1 - 2023-07-27-bc92a280-1
libogg0 - 1.3.5-1
libopenssl3 - 3.0.9-2
libpam - 1.5.2-1
libpcap1 - 1.10.4-1
libpopt0 - 1.19-1
libpthread - 1.2.4-4
libreadline8 - 8.2-1
librt - 1.2.4-4
libsqlite3-0 - 3410200-1
libstdcpp6 - 12.3.0-4
libtasn1 - 4.19.0-2
libtirpc - 1.3.3-1
libubox20230523 - 2023-05-23-75a3b870-1
libubus-lua - 2022-06-15-9913aa61-1
libubus20220615 - 2022-06-15-9913aa61-1
libuci20130104 - 2023-03-05-04d0c46c-1
libuclient20201210 - 2023-04-13-007d9454-1
libucode20220812 - 2023-04-03-51638672-1
libudev-zero - 1.0.1-1
liburing - 2.3-1
libusb-1.0-0 - 1.0.26-3
libustream-openssl20201210 - 2023-02-25-498f6e26-1
libuuid1 - 2.39-2
libvorbis - 1.3.7-2
logd - 2022-08-13-4c7b720b-2
lua - 5.1.5-10
luci - git-23.051.66410-a505bb1
luci-app-attendedsysupgrade - git-23.132.65998-fa9fb2f
luci-app-firewall - git-23.208.40260-9504081
luci-app-minidlna - git-22.069.45071-315a592
luci-app-openvpn - git-23.013.73089-25983b9
luci-app-opkg - git-23.009.82915-ec3aac4
luci-app-p910nd - git-20.108.38431-8f34e10
luci-app-samba4 - git-23.142.65904-c0478f0
luci-base - git-23.118.79121-6fb185f
luci-compat - git-22.297.83017-673f382
luci-lib-base - git-22.308.54612-9118452
luci-lib-ip - git-20.250.76529-62505bd
luci-lib-jsonc - git-22.079.54693-45f411b
luci-lib-nixio - git-22.222.71555-88b9088
luci-light - git-23.024.33244-34dee82
luci-lua-runtime - git-23.119.80867-2a9c3a3
luci-mod-admin-full - git-19.253.48496-3f93650
luci-mod-network - git-23.207.47173-895a508
luci-mod-status - git-23.210.72323-b6dc2f2
luci-mod-system - git-23.118.78765-58f7b27
luci-proto-ipv6 - git-21.148.48881-79947af
luci-proto-ppp - git-21.158.38888-88b9d84
luci-proto-wireguard - git-23.073.81399-59a6f06
luci-theme-bootstrap - git-23.085.34270-d94a728
minidlna - 1.3.2-1
mkf2fs - 1.16.0-1
mtd - 26
netifd - 2023-06-04-ec9dba72-1
nftables-json - 1.0.8-1
odhcp6c - 2023-05-12-bcd28363-20
odhcpd-ipv6only - 2023-06-24-52112643-1
openssh-sftp-server - 9.3p1-3
openvpn-openssl - 2.5.8-3
openwrt-keyring - 2022-03-25-62471e69-2
opkg - 2022-02-24-d038e5b6-2
p910nd - 0.97-9
ppp - 2.4.9.git-2021-01-04-4
ppp-mod-pppoe - 2.4.9.git-2021-01-04-4
procd - 2023-01-16-190f13a7-1
procd-seccomp - 2023-01-16-190f13a7-1
procd-ujail - 2023-01-16-190f13a7-1
rpcd - 2023-03-14-d9788300-1
rpcd-mod-file - 2023-03-14-d9788300-1
rpcd-mod-iwinfo - 2023-03-14-d9788300-1
rpcd-mod-luci - 20230123-1
rpcd-mod-rpcsys - 2023-03-14-d9788300-1
rpcd-mod-rrdns - 20170710
rpcd-mod-ucode - 2023-03-14-d9788300-1
samba4-libs - 4.18.0-1
samba4-server - 4.18.0-1
tcpdump - 4.99.4-1
terminfo - 6.4-2
ubi-utils - 2.1.5-1
uboot-envtools - 2023.04-1
ubox - 2022-08-13-4c7b720b-2
ubus - 2022-06-15-9913aa61-1
ubusd - 2022-06-15-9913aa61-1
uci - 2023-03-05-04d0c46c-1
uclient-fetch - 2023-04-13-007d9454-1
ucode - 2023-04-03-51638672-1
ucode-mod-fs - 2023-04-03-51638672-1
ucode-mod-html - 1
ucode-mod-lua - 1
ucode-mod-math - 2023-04-03-51638672-1
ucode-mod-ubus - 2023-04-03-51638672-1
ucode-mod-uci - 2023-04-03-51638672-1
uhttpd - 2023-06-25-34a8a74d-1
uhttpd-mod-ubus - 2023-06-25-34a8a74d-1
urandom-seed - 3
urngd - 2020-01-21-c7f7b6b6-1
usbutils - 014-1
usign - 2020-05-23-f1f65026-1
wireguard-tools - 1.0.20210914-2
wireless-regdb - 2023.05.03-1
wpad-openssl - 2023-06-22-599d00be-1.2
zlib - 1.2.13-1

Things to try:
use WPA2/WPA3
use channel 36 to test

One of my clients (stupid intel Ax200) had difficulty to connect and show intermittent loss with WPA2 only.

Yes, I've already tried channel 149 and WPA2/WPA3, same deal.

This isn't an authentication issue where dealing with, there isn't any problem connecting wirelessly to the router, it's the connection between devices once connected that's flaked.

Check this post. It's about the local wireless connection issues and not only this.
See my last findings too.
Hope they help.

1 Like

So the clean 23.05.0-rc2 build containing the newer WiFi drivers WLAN.HK.2.9.0.1-01837 still had the 'no reply ping' issue (i.e. no reply to pinging WiFi devices within the same br-lan).


Swapped to the older WiFi drivers WLAN.HK.2.9.0.1-01385 and kept adding to my config, testing in between, so far so good.

During the addition of 2x guest WiFi (the last config required to complete my setup), I enabled the setting Isolate Clients for each, saved.

Immediately experienced the 'no ping reply' issue on the 2x default non-guest WiFi's.

I unchecked both Isolate Clients settings, then re-enabled them, now a working configuration! :dizzy_face: :face_with_open_eyes_and_hand_over_mouth:

So this solved this issue:
1/ using older WiFi drivers WLAN.HK.2.9.0.1-01385 and
2/ the WiFi guest isolate setting requires to be done twice

It's been running OK for just over 1 day now, will post if the same issues reoccur. :pray:

edit using the 01837 drivers again, the issue appeared immediately

2 Likes

Well I spoke too soon, the no ping issue raised its ugly head again.

I then toggled the Isolate Clients settings on both br-guest SSID's, then the 2x br-lan SSID's clients were able to obtain their respective ping replies from each other.

Using the wifi command brings back all the non replying WiFi devices!

I used the multicast_to_unicast workaround listed within the link in @crect's post:

Adding the option multicast_to_unicast_all '1' setting for both 5GHz & both 2.4GHz radios, has resolved the:

  • no ping reply issue
  • no Windows shared folder access
  • disconnect of 2.4G devices, unable to reconnect

I'm now also using the most recent ath11k firmware: WLAN.HK.2.9.0.1-01862 with 23.05.0-rc2

2 Likes

I'm glad that you got rid of the issue. Can you test with your current setup for this Ath11 bug.

Just did, disconnected my phone while pinging router from wireless PC, no ping loss/delay whatsoever.

Hope it helps.

1 Like

I will have to try it too then.

Edit
@otnert
I've just returned to the latest (at the moment) Ath11k firmware WLAN.HK.2.9.0.1-01862.
Rebooted the router and tested once again without multi to unicast option. Confirmed the loss of both Ping and Iperf3 traffic.

I've turned on multi to unicast option. I've tested once again with multi to unicast option turned on.
There is no more loss of both Ping and Iperf3 traffic.

So as I suggested in my earlier post these issues were connected. That is now confirmed, I think.