Dynalink DL-WRX36 slow wifi

I got openwrt installed on the dynalink the other day. Got it up and running without any issues. I am running the 23.05.04 release, not the snapshot. Here's what my configuration looks like. Should be hitting 500 mbps but I'm barely hitting 100 on 5g, 4g gets up to 150 and I'm literally sitting 10 ft away from router while setting up. another question: could I switch from stable to snapshot? Any help would be appreciated.


       "kernel": "5.15.162",
       "hostname": "********",
       "system": "ARMv8 Processor rev 4",
       "model": "Dynalink DL-WRX36",
       "board_name": "dynalink,dl-wrx36",
       "rootfs_type": "squashfs",
       "release": {
               "distribution": "OpenWrt",
               "version": "23.05.4",
               "revision": "r24012-d8dd03c46f",
               "target": "ipq807x/generic",
               "description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
 
config interface 'loopback'
       option device 'lo'
       option proto 'static'
       option ipaddr '127.0.0.1'
       option netmask '255.0.0.0'

config globals 'globals'
       option ula_prefix 'fd67:2f07:886c::/48'

config device
       option name 'br-lan'
       option type 'bridge'
       list ports 'lan1'
       list ports 'lan2'
       list ports 'lan3'
       list ports 'lan4'

config interface 'lan'
       option device 'br-lan'
       option proto 'static'
       option ipaddr '192.168.1.1'
       option netmask '255.255.255.0'
       option ip6assign '60'

config interface 'wan'
       option device 'wan'
       option proto 'dhcp'

config interface 'wan6'
       option device 'wan'
       option proto 'dhcpv6'

config wifi-device 'radio0'
       option type 'mac80211'
       option path 'platform/soc/c000000.wifi'
       option channel 'auto'
       option band '5g'
       option htmode 'HE40'
       option cell_density '0'
       option country 'US'

config wifi-iface 'default_radio0'
       option device 'radio0'
       option network 'lan'
       option mode 'ap'
       option ssid '*****'
       option encryption 'psk2'
       option key '******'
       option hidden '1'

config wifi-device 'radio1'
       option type 'mac80211'
       option path 'platform/soc/c000000.wifi+1'
       option channel 'auto'
       option band '2g'
       option htmode 'HE20'
       option cell_density '0'
       option country 'US'

config wifi-iface 'default_radio1'
       option device 'radio1'
       option network 'lan'
       option mode 'ap'
       option ssid '*****'
       option encryption 'psk2'
       option key '*******'
       option hidden '1'

config dnsmasq
       option domainneeded '1'
       option boguspriv '1'
       option filterwin2k '0'
       option localise_queries '1'
       option rebind_protection '1'
       option rebind_localhost '1'
       option local '/lan/'
       option domain 'lan'
       option expandhosts '1'
       option nonegcache '0'
       option cachesize '1000'
       option authoritative '1'
       option readethers '1'
       option leasefile '/tmp/dhcp.leases'
       option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
       option nonwildcard '1'
       option localservice '1'
       option ednspacket_max '1232'
       option filter_aaaa '0'
       option filter_a '0'

config dhcp 'lan'
       option interface 'lan'
       option start '100'
       option limit '150'
       option leasetime '12h'
       option dhcpv4 'server'
       option dhcpv6 'server'
       option ra 'server'
       option ra_slaac '1'
       list ra_flags 'managed-config'
       list ra_flags 'other-config'

config dhcp 'wan'
       option interface 'wan'
       option ignore '1'

config odhcpd 'odhcpd'
       option maindhcp '0'
       option leasefile '/tmp/hosts/odhcpd'
       option leasetrigger '/usr/sbin/odhcpd-update'
       option loglevel '4'

config defaults
       option syn_flood '1'
       option input 'REJECT'
       option output 'ACCEPT'
       option forward 'REJECT'

config zone
       option name 'lan'
       list network 'lan'
       option input 'ACCEPT'
       option output 'ACCEPT'
       option forward 'ACCEPT'

config zone
       option name 'wan'
       list network 'wan'
       list network 'wan6'
       option input 'REJECT'
       option output 'ACCEPT'
       option forward 'REJECT'
       option masq '1'
       option mtu_fix '1'

config forwarding
       option src 'lan'
       option dest 'wan'

config rule
       option name 'Allow-DHCP-Renew'
       option src 'wan'
       option proto 'udp'
       option dest_port '68'
       option target 'ACCEPT'
       option family 'ipv4'

config rule
       option name 'Allow-Ping'
       option src 'wan'
       option proto 'icmp'
       option icmp_type 'echo-request'
       option family 'ipv4'
       option target 'ACCEPT'

config rule
       option name 'Allow-IGMP'
       option src 'wan'
       option proto 'igmp'
       option family 'ipv4'
       option target 'ACCEPT'

config rule
       option name 'Allow-DHCPv6'
       option src 'wan'
       option proto 'udp'
       option dest_port '546'
       option family 'ipv6'
       option target 'ACCEPT'

config rule
       option name 'Allow-MLD'
       option src 'wan'
       option proto 'icmp'
       option src_ip 'fe80::/10'
       list icmp_type '130/0'
       list icmp_type '131/0'
       list icmp_type '132/0'
       list icmp_type '143/0'
       option family 'ipv6'
       option target 'ACCEPT'

config rule
       option name 'Allow-ICMPv6-Input'
       option src 'wan'
       option proto 'icmp'
       list icmp_type 'echo-request'
       list icmp_type 'echo-reply'
       list icmp_type 'destination-unreachable'
       list icmp_type 'packet-too-big'
       list icmp_type 'time-exceeded'
       list icmp_type 'bad-header'
       list icmp_type 'unknown-header-type'
       list icmp_type 'router-solicitation'
       list icmp_type 'neighbour-solicitation'
       list icmp_type 'router-advertisement'
       list icmp_type 'neighbour-advertisement'
       option limit '1000/sec'
       option family 'ipv6'
       option target 'ACCEPT'

config rule
       option name 'Allow-ICMPv6-Forward'
       option src 'wan'
       option dest '*'
       option proto 'icmp'
       list icmp_type 'echo-request'
       list icmp_type 'echo-reply'
       list icmp_type 'destination-unreachable'
       list icmp_type 'packet-too-big'
       list icmp_type 'time-exceeded'
       list icmp_type 'bad-header'
       list icmp_type 'unknown-header-type'
       option limit '1000/sec'
       option family 'ipv6'
       option target 'ACCEPT'

config rule
       option name 'Allow-IPSec-ESP'
       option src 'wan'
       option dest 'lan'
       option proto 'esp'
       option target 'ACCEPT'

config rule
       option name 'Allow-ISAKMP'
       option src 'wan'
       option dest 'lan'
       option dest_port '500'
       option proto 'udp'
       option target 'ACCEPT'

config redirect
       option dest 'lan'
       option target 'DNAT'
       option src 'wan'
       option src_dport '3074'
       option dest_port '3074'
       option enabled '0'

Unhide your access points, it is opposite of security as all clients will broadcast its name forever after.

1 Like

It was unhidden when I did the initial setup and was testing. I hid them when I pulled it off so I could have my older router put back in place and I could play with configuration when connected directly to my laptop. Thanks for that bit of info though as I didn't know that.

That won't work the way you expected it to either. Once a phone has been configured to connect to a conventional AP it will still try to connect to that same AP if it is changed to hidden.

1 Like

Post result links from https://www.waveform.com/tools/bufferbloat
1/ connected to wrx36 wired
2/ wireless
3/ directly to providers port (if possible)

I will do that. A little info on my isp connection, I have a 500 mbps from xfinity and just from speedtest.net through wired connection it was 600+, wifi was around 100. I will go to the waveform site and get those results.

First thing hiding APs there is no chance it ever roams to higher band, 100Mbps is a good speed for 2.4GHz.
Rest of config looks quite sane, you should be getting in range of 400-500 with ac and 500-700 on AX client in 5GHz

You can also use speed.cloudflare.com, waveform's advantage is that it shows just technicals, not your location.

I'm seeing similar values on my WRX36s, running as APs.
client is using an Intel AC 8275.

Set channel 36 and htmode HE80

1 Like

Here's the results. Client is using realtek rtl8852AE wifi 6 AX. I've included the waveform report for my netgear r7800 router running openwrt. i will try your suggestion egc.




Link to visualised test results please.

https://drive.google.com/drive/folders/1bJAO3XBo-sFpHveUO5zzZe2lwZdoX55W?usp=drive_link

I can retest if you want direct links from waveform. I didn't see the share link before even though its right next to download. :man_facepalming:

It is between permalink and csv download button

Yeah, saw that after the fact. I will redo test and share links.

direct to cable modem

wired to router

2.4g dynalink

5g dynalink

5g R7800 router

Made the changes ECG recommended. Much faster now.

You can improve latency by adding SQM and tuning down download speed. But as long as you dont torrent and game at same moment you are good to go.