Dynalink DL-WRX36 killing WiFi

I've got a strange issue. So I've been using the Dynalink DL-WRX36 for about a week. Had it on firmware from the info page, and added some basic packages, like nano, and some other system utilities. I set up my networks and wifi ssids, and I did some testing before moving the router into the main role, and everything was fine.

Since moving it to be my main router, over the last couple of days, I find myself needing to reboot. WiFi will work for about 10 minutes, then drop all devices. Thought maybe I would update to the latest version, 23.05.2, and now the wifi drops withing minutes of reboot

/etc/config/system

 config system
 	option hostname 'HomeRouter'
 	option timezone 'EST5EDT,M3.2.0,M11.1.0'
 	option ttylogin '0'
 	option log_size '64'
 	option urandom_seed '0'
 	option zonename 'America/New York'
 	option log_proto 'udp'
 	option conloglevel '8'
 	option cronloglevel '5'
 
 config timeserver 'ntp'
 	list server '0.openwrt.pool.ntp.org'
 	list server '1.openwrt.pool.ntp.org'
 	list server '2.openwrt.pool.ntp.org'
 	list server '3.openwrt.pool.ntp.org'

df -h

 Filesystem                Size      Used Available Use% Mounted on
 /dev/root                 7.5M      7.5M         0 100% /rom
 tmpfs                   434.4M    116.0K    434.3M   0% /tmp
 /dev/ubi0_2              69.2M    196.0K     65.5M   0% /overlay
 overlayfs:/overlay       69.2M    196.0K     65.5M   0% /
 tmpfs                   512.0K         0    512.0K   0% /dev

/etc/config/wireless

 config wifi-device 'radio0'
 	option type 'mac80211'
 	option path 'platform/soc/c000000.wifi'
 	option band '5g'
 	option htmode 'HE80'
 	option cell_density '2'
 	option country 'US'
 	option channel 'auto'
 
 config wifi-device 'radio1'
 	option type 'mac80211'
 	option path 'platform/soc/c000000.wifi+1'
 	option channel 'auto'
 	option band '2g'
 	option cell_density '0'
 	option htmode 'HE40'
 
 config wifi-iface 'wifinet3'
 	option device 'radio0'
 	option mode 'ap'
 	option ssid 'NothingToSeeHere'
 	option encryption 'psk2+tkip+ccmp'
 	option key 'pass'
 	option network 'lan'
 
 config wifi-iface 'wifinet1'
 	option device 'radio1'
 	option mode 'ap'
 	option ssid 'NothingToSeeHere'
 	option encryption 'psk2+tkip+ccmp'
 	option key 'pass'
 	option network 'lan'
 
 config wifi-iface 'wifinet2'
 	option device 'radio1'
 	option mode 'ap'
 	option ssid 'Don'\''t Panic'
 	option encryption 'psk2+tkip+ccmp'
 	option key 'pass'
 	option network 'iot'

/etc/config/network

 config interface 'loopback'
 	option device 'lo'
 	option proto 'static'
 	option ipaddr '127.0.0.1'
 	option netmask '255.0.0.0'
 
 config globals 'globals'
 	option ula_prefix 'fd28:a829:7d16::/48'
 
 config device
 	option name 'br-lan'
 	option type 'bridge'
 	list ports 'lan1'
 	list ports 'lan2'
 	list ports 'lan3'
 	list ports 'lan4'
 	option ipv6 '0'
 
 config interface 'lan'
 	option device 'br-lan.10'
 	option proto 'static'
 	option ipaddr '192.168.0.1'
 	option netmask '255.255.255.0'
 	option ip6assign '60'
 	option delegate '0'
 	list dns '192.168.0.2'
 
 config interface 'wan'
 	option device 'wan'
 	option proto 'dhcp'
 	option delegate '0'
 	option peerdns '0'
 	list dns '1.1.1.1'
 	list dns '1.0.0.1'
 
 config bridge-vlan
 	option device 'br-lan'
 	option vlan '10'
 	list ports 'lan1'
 	list ports 'lan2'
 	list ports 'lan3'
 	list ports 'lan4'
 
 config bridge-vlan
 	option device 'br-lan'
 	option vlan '20'
 
 config bridge-vlan
 	option device 'br-lan'
 	option vlan '30'
 
 config bridge-vlan
 	option device 'br-lan'
 	option vlan '40'
 
 config interface 'guest'
 	option proto 'static'
 	option device 'br-lan.20'
 	option ipaddr '192.168.20.1'
 	option netmask '255.255.255.0'
 	option delegate '0'
 
 config interface 'iot'
 	option proto 'static'
 	option device 'br-lan.30'
 	option ipaddr '192.168.30.1'
 	option netmask '255.255.255.0'
 	option delegate '0'
 
 config interface 'test'
 	option proto 'static'
 	option device 'br-lan.40'
 	option ipaddr '192.168.40.1'
 	option netmask '255.255.255.0'
 	option delegate '0'
 
 config device
 	option name 'lan1'
 	option drop_v6_unicast_in_l2_multicast '0'

Any help, or guidance would be greatly appreciated

Start by not using auto wifi chan.

Please use the "Preformatted text </>" button for logs, scripts, configs and general console output.
grafik
Please edit your post accordingly. Thank you! :slight_smile:

Thanks for that, I changed the channels, restarted the wifi radios, and now, my dmesg looks like this

 4261.609543] device phy0-ap0 left promiscuous mode
[ 4261.609677] br-lan: port 5(phy0-ap0) entered disabled state
[ 4261.723121] phy0-ap0: failed to remove key (1, ff:ff:ff:ff:ff:ff) from hardware (-108)
[ 4261.723517] ath11k c000000.wifi: failed to clear rx_filter for monitor status ring: (-108)
[ 4261.930385] ath11k c000000.wifi: failed to enable PMF QOS: (-108
[ 4262.013216] phy1-ap1: failed to remove key (1, ff:ff:ff:ff:ff:ff) from hardware (-108)
[ 4262.014802] br-lan: port 7(phy1-ap1) entered disabled state
[ 4262.073478] device phy1-ap1 left promiscuous mode
[ 4262.073524] br-lan: port 7(phy1-ap1) entered disabled state
[ 4262.189422] device phy1-ap0 left promiscuous mode
[ 4262.189535] br-lan: port 6(phy1-ap0) entered disabled state
[ 4267.323083] ath11k_warn: 197 callbacks suppressed
[ 4267.323106] ath11k c000000.wifi: failed to flush transmit queue, data pkts pending 1
[ 4267.326997] ath11k c000000.wifi: failed to send WMI_REQUEST_STATS cmd
[ 4267.334648] ath11k c000000.wifi: could not request fw stats (-108)
[ 4267.340946] ath11k c000000.wifi: failed to request fw pdev stats: -108
[ 4267.383117] ath11k c000000.wifi: failed to send WMI_VDEV_INSTALL_KEY cmd
[ 4267.383159] ath11k c000000.wifi: ath11k_install_key failed (-108)
[ 4267.388888] phy1-ap0: failed to remove key (1, ff:ff:ff:ff:ff:ff) from hardware (-108)
[ 4267.395955] ath11k c000000.wifi: failed to send WMI_PEER_DELETE cmd
[ 4267.402694] ath11k c000000.wifi: failed to delete peer vdev_id 1 addr <dev mac> ret -108
[ 4267.408892] ath11k c000000.wifi: failed to submit AP self-peer removal on vdev 1: -108
[ 4267.417924] ath11k c000000.wifi: failed to submit WMI_VDEV_DELETE_CMDID
[ 4267.426285] ath11k c000000.wifi: failed to clear rx_filter for monitor status ring: (-108)
[ 4267.634716] ath11k c000000.wifi: failed to enable PMF QOS: (-108
[ 4353.244962] ath11k_warn: 4 callbacks suppressed
[ 4353.244984] ath11k c000000.wifi: failed to send WMI_PDEV_SET_PARAM cmd
[ 4353.248330] ath11k c000000.wifi: failed to enable PMF QOS: (-108
[ 4358.316913] ath11k c000000.wifi: failed to send WMI_PDEV_SET_PARAM cmd
[ 4358.316957] ath11k c000000.wifi: failed to enable PMF QOS: (-108

I've tried reinstalling the OpenWrt image, and the issue still persists. I decided I'm just going to return the router.

Any recommendations for an AX router, supporting OpenWrt, in the US?

Is that the first thing that happened or were there events before that?

If you use a DFS channel specify a range of channels. If you only specify one channel and radar is detected, the radio will shut down permanently since there is no channel to switch to.

I have this router and it runs stable for weeks, I do not have vlans and guest wifi (but I do have a lot of WG and OpenVPN running).

My phone and laptop are always connect to the 5 GHz, it is fast and without problems of course you might have a hardware defect or maybe it does not handle the guest wifi or vlans very well but for me with a price of E 100 it is an unbeatable offer

same here, my WRX36 APs had an uptime of 8-10 months, but then there was a power outage.
currently they're at 30 days.