Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion

Yeah I clicked on the wrong file, and was able to update now. But still having issues with 5Gz radio. I have it enabled now, and selected country and channel, but I don't see it showing up on any devices or wifi analyzer.

phy#0
        Interface phy0-ap0
                ifindex 11
                wdev 0x2
                addr a4:97:33:df:a4:b4
                type AP
                channel 56 (5280 MHz), width: 20 MHz, center1: 5280 MHz
                txpower 29.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       0       0       0       0       0       0               0

Have you set an SSID, country (set both radios the same country) and WPA2/CCMP security?

Yes both set to US, and WPA2-PSK security.

I did not have CCMP enabled, just auto. Enabling CCMP and it is working now. Thanks again.

1 Like

Will a release build for the WRX36 become available soon?

Once the dev team decides 23.05 is stable enough, which should, hopefully, be later this year.

2 Likes

Ok still having some problems with 5Ghz radio. When I connect to 5Ghz radio, I get slow pings and then it disconnects after 10 seconds, whereas with the 2.4Ghz radio I get 1ms pings and stable connection. With router 1m away. All settings are defaults except WPA2-PSK/CCMP for both, country code US. I have tried various channels and width to no avail. Latest is at AC-100channel-80MHz. Nothing in that range on wifi scanner. Any ideas?

These are my settings now up a week with no problems using firmware 1835.
But note it is only very lightly used, two modern Samsung phones a Samsung Tablet and a new LG OLED TV :slight_smile:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option channel '52'
	option band '5g'
	option htmode 'HE80'
	option cell_density '0'
	option country 'US'
	option txpower '24'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'dl-5'
	option encryption 'sae-mixed'
	option key 'notmygirlfriendsname'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+1'
	option channel '11'
	option band '2g'
	option htmode 'HE20'
	option txpower '30'
	option country 'US'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'dl-24'
	option encryption 'psk2'
	option key 'notmygirlfriendsname'
1 Like

Settings look similar here, What is firmware 1835? I am using "OpenWrt SNAPSHOT r23685-7e7eb5312d / LuCI Master git-23.158.78004-23a246e"

Take note of the encryption settings, my devices are all Wifi6 and that is necessary for Wifi6 to work.

1835 is the radio firmware, Snapshot main is on 186X something I think.
You can check with dmesq | grep WLAN
root@DL-WRX36:~# dmesg | grep WLAN
[ 13.761787] ath11k c000000.wifi: fw_version 0x290c84a5 fw_build_timestamp 2023-03-25 07:34 fw_build_id WLAN.HK.2.9.0.1-01385-QCAHKSWPL_SILICONZ-1

I'm on latest OpenWrt SNAPSHOT r23694-daed3322d3 and just noticed a strange issue.
When I disable a wireless network in luci, that wifi radio is not turned off and any connected device is kept connected, but without network access.

It works for me using 23.05.
Radio is disabled after disabling 2.4 GHz even when a client is attached

1 Like

I think the issue I describe is recent, I didn't had it before.
It also happens with today snapshot r23708-d1427863ba.

Hello,
I had a search/read through this thread, so apologies if this question has already been asked. Would anyone be able to provide any feedback on the DL-WRX36 2.4ghz range capabilities? I'm considering purchasing one of these to replace a trusty r7800. I currently have several 2.4 cameras quite a distance from the r7800, with the r7800 performing well over the distance.
Some sources are saying up to 4,800 sq. ft for the DL-WRX36 vs 3,000 sq. ft for r7800. But these numbers don't always hold in real world tests, especially when going through walls etc.
Thanks!

I have both an R7800 and a DL-WRX36, I did not make any formal comparison or measurements but in daily use I did not see much difference in range.

1 Like

Mine arrives today! Is this install instruction up-to-date? (other than updating the filename from ipq807x-generic to qualcommax-ipq807x). I'm planning to do option 2. Thank you

If the router is already on latest stock fw v1.10.01.254 would it still work?

Cannot answer that as I setup mine about 2 months ago.

I used option 2 which worked without a problem as long as you understand that the OpenWrt factory image should be downloaded from the download section (it has the .ubi extension) it is not on the install page

Your special attention to the quote below from the install page, adding that makes it possible to always start from an USB stick with the initramfs file, saved my *ss when I did something stupid.

The code below, provided by hnyman, is to be used to verify that the relevant U-Boot variables are set correctly:

bootcmd=run openwrtusb; run openwrtboot openwrtboot=setenv bootargs console=ttyMSM0,115200n8 ubi.mtd=rootfs rootfstype=squashfs rootwait; ubi part fs; ubi read 0x44000000 kernel; bootm 0x44000000#config@rt5010w-d350-rev0 openwrtusb=usb start && fatload usb 0:1 0x44000000 openwrt-ipq807x-generic-dynalink_dl-wrx36-initramfs-uImage.itb && bootm 0x44000000

The same changes can be made from within OpenWRT using ssh, by running.

fw_setenv bootcmd 'run openwrtusb; run openwrtboot' fw_setenv openwrtboot 'setenv bootargs console=ttyMSM0,115200n8 ubi.mtd=rootfs rootfstype=squashfs rootwait; ubi part fs; ubi read 0x44000000 kernel; bootm 0x44000000#config@rt5010w-d350-rev0' fw_setenv openwrtusb 'usb start && fatload usb 0:1 0x44000000 openwrt-ipq807x-generic-dynalink_dl-wrx36-initramfs-uImage.itb && bootm 0x44000000'

More details about this failsafe method is in post comment #1317.

1 Like

Try, and let us know ,)

TBH, haven't seen any post about failed migrations due to stock fw revision.

Ah... never mind, found it! For those confused like I did below, the .ubi can be found here. Also to clarify, you would still need the .itb file for the first 3 steps of option 2, then the .ubi factory image.

[quote="egc, post:2018, topic:110454"]
...as long as you understand that the OpenWrt factory image should be downloaded from the download section (it has the .ubi extension) it is not on the install page
[/quote]

so it's not this .itb file as provided in the instruction?? https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/openwrt-qualcommax-ipq807x-dynalink_dl-wrx36-initramfs-uImage.itb

do you have the link to the .ubi?

1 Like

itb link is on the wiki page, ubi can be found in the same place (URL) as the itb.
that's how it's written in the wiki, and (still) correct, AFAIK.

1 Like