Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion

there is a fix for this issue (i also got it if i was enabling it at boot start)

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=f1c9bd6f6f41d12c2f503e165cb22c465ecf7534

1 Like

I have managed to track down 160MHz regression and made a PR for a temporary fix:

8 Likes

@greem Still curious about the radio firmware... should we be updating it manually? And are you doing it via serial connection?

Strange i don't have these kernel errors. Do you have multiple WAN interaces?

edit: nevermind im on r22400

I updated it manually over SSH and rebooted.

I was throwing things at the wall to see what stuck, tbh. It'll get overwritten when I next update.

Still hasn't crashed, though!

I have no multiple wan interfaces

Is anyone else using the updated radio firmware from QCA?
WLAN.HK.2.7.0.1-01744-QCAHKSWPL_SILICONZ-1

I've done some searching around and it appears some are having success while others are not. Thoughts?

Working on a fix... trying to optimize odhcpd, had report of the feature broken some days ago but the user wrongly reported that it was fixed... my bad for not waiting more feedback from others.

1 Like

only works on some devices due to outdated BDF. qnap and dynalink should work fine. xiaomi will crash on start.

3 Likes

Since r22400, IPv6 works fine. I use PPPoE, everything "auto"/default

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd94:5975:bee4::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'VDSL'
	option proto 'pppoe'
	option device 'wan'
	option username 'X@X.X'
	option password 'X'
	option ipv6 'auto'
	option delegate '0'

config device
	option name 'wan'


root@OpenWrt:~# ifstatus VDSL_6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": true,
        "uptime": 131694,
        "l3_device": "pppoe-VDSL",
        "proto": "dhcpv6",
        "device": "pppoe-VDSL",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2a02:85f:cffc:74e1:b5f8:caaf:4314:1234",
                        "mask": 64,
                        "preferred": 3559,
                        "valid": 86359
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2a02:85f:fcb8:7600::",
                        "mask": 56,
                        "preferred": 3460,
                        "valid": 86260,
                        "class": "VDSL_6",
                        "assigned": {
                                "lan": {
                                        "address": "2a02:85f:fcb8:7600::",
                                        "mask": 60
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::6aab:9ff:fe2a:e401",
                        "metric": 512,
                        "valid": 4459,
                        "source": "2a02:85f:fcb8:7600::/56"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::6aab:9ff:fe2a:e401",
                        "metric": 512,
                        "valid": 4459,
                        "source": "2a02:85f:cffc:74e1:b5f8:caaf:4314:1234/64"
                }
        ],
        "dns-server": [
                "2a02:858::8844",
                "2a02:858::8888"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "zone": "wan",
                "passthru": "001700202a0208580000000000000000000088442a020858000000000000000000008888",
                "zone": "wan"
        }
}

Thanks for the confirmation. I went ahead and flashed it over, then rebooted... all booted well and it appears to have taken fine. No errors.

[    8.726768] ath11k c000000.wifi: fw_version 0x270204a5 fw_build_timestamp 2022-08-04 13:05 fw_build_id WLAN.HK.2.7.0.1-01744-QCAHKSWPL_SILICONZ-1

Based on what I believe I understand correctly, the default board-2.bin file does not need to be updated in the Dynalink - and is sufficient - correct?

Did you ever try it ?
It would be a nice recovery method, for those lacking USB TTL.

I'd like to put it in the wiki, assuming it works.

1 Like

I haven't yet tested it.
I was thinking that it might be more clear if it is divided into three lines, in style of e8450 pstore check.

Something like

normalboot=...
usbopenwrt=...
bootcmd=usbopenwrt; normalboot
1 Like

I agree, but splitting it up could generate more C&P errors from users, you're pasting three lines instead of one.

Perhaps the setenv console_unlock 1 should be added too, even though most people probably won't ever upgrade their devices to a newer versions of the stock fw, once migrated to openwrt.

I use it since day one:

1 Like

... Sorry for being lazy to check. Is there some (ram, flash) pstore implemented for DL-WRX36 (or in the whole ipq807x target)?
If it's not implemented: is the device capable for such function?

I'm lost now... It should have worked before in theory

It should be capable. But it might also depend on the bootloader in use.

I haven't really tested pstore with DL-WRX36 , as I (deviating from my normal practice) have used imagebuilder for this device until now, so I haven't much looked at the device sources. I only initialised the full toolchain for this device last weekend (so that I could test ansuel's PR mentioned above).

But a quick look to the source code (ipq807x image config and DTS) makes me to believe that @ansuel and @robimarko have not yet initialised ramoops/pstore for ipq807x.

Anybody can add it, there is nothing special about ramoops on this platform, its just a matter of finding a good place in RAM

1 Like

Let me explain with more details

Snapshot r22260, ipv6 was working

Then i tried Snapshot r22392 and r22396, ipv6 was partially working. Router had IPv6 address but LAN clients not. I tried both with keep settings and clean install.

Back to r22260, ipv6 was working again.

Then r22400, ipv6 working as expected.