Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion

I did not know

I already tried turning off the router and then connecting the router to electricity while pressing and holding:

  • reset button
  • wps button
  • reset and wps button

I also had serial connected and noticed u-boot did nothing, it went straight into OpenWRT

1 Like

my personal experience is that schedutil is rubbish vs ondemand with a higher incentive to be more aggressive

echo 60 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor
echo 25 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold

schedutil is too slow to turn demand active .. note - this is against the overall consensus of this entire openwrt forum that schedutil is best !

1 Like

Just started a Attended SysUpgrade from R20036 to R20063 .

However, the installation takes more than 5 minutes (previously it only take 2 minutes at most) now, and my wrx36 still not rebooted.

How to find out what is going on? How to decide if it is OK to force reboot? How to abort it?

I've noticed this as well - it stays at 1ghz the vast majority of the time and even causes processor usage spikes up to 40% sometimes during minuscule tasks. I'm going to test with both ondemand and performance to see how they compare. With my R7800's I always ran performance because the power consumption differences were so negligible and the router temps only increased a degree or two. Curious how this will respond as well. I know that many stock firmware's don't allow so many frequencies to be selected, but rather two or three at most and most stock firmware have very aggressive up sampling as well.

1 Like

I see the ondemand governor isn’t baked in to default snapshot… just schedutil and performance. Interesting…

2 Likes

You wait some more, then you investigate using serial console.

1 Like

I guess I was hit by the same issue. Used serial to recover

I sysupgraded yesterday quite normally from 20036 to 20063, with an image self-built with imagebuilder.

"recover"? What was the actual situation? Something shown in the console?
Did the router not boot at all? Was serial really needed?

Sysupgrade is just scripts that checks compatibility do the flashing in certain pieces (kernel + rootfs separately). If it gets stuck before any flashing is done, normal reboot should be enough)

I described it earlier: used root+ssh to install OpenWrt in memory then by using ubi. All went ok and I had luci installed. Then upgraded to a new snapshot via UI and rebooted. It was stuck on purple led no matter what I tried. I had to disassemble the unit and hook up to the console port. Was able to go though steps all the way this time. A bit hesitant to upgrade again though :smirk:

Its a minor issue though. The biggest one is the inability to use 160mhz channels normally and missing upper 5ghz channels. I dunno why people turn other way from this problem in a supposedly 'recommended' WiFi router.

Just for comparison. My phicomm K3 which I got for 40 bucks shipped 3 years ago is based on (shunned) Broadcom and still works perfectly with OpenWrt since 19.x (after tweaks) - irqbalance works, 1gbps nat works, 3(!) 160mhz channels work, no hardcoded regdb. Uptime is till next power loss.

I hoped for upgrade to ax (no real need, just curiosity, I guess) but oh well...

Is it though?

Not really a fair comparison, imho, you're comparing a device that's been supported since LEDE, with something that got added three weeks ago, or so.

Well, to give some perspective:
I have sysupgraded my R7800 about 1340 times since 2016 (for testing my community builds), and about 20-30 upgrades have failed. Some times due to bugs (to be debugged) in OpenWrt, but a few times just for unexplained reasons, as the next sysupgrade try with the same image has succeeded.

1 Like

I'm using 160MHz on channel 36 and I have the ability to use channels 100-165, albeit that some of those are DFS channels but it'd be illegal in the States for me to transmit on those frequencies if it would interfere with radar.

Im able to use 36 only too but it's congested (other folks are stuck with 149? only) Dfs doesn't work on this router it seems? In my area I see several provider-issued routers working in DFS range with no problem. Meaning they detect no radars.

Also possible that they just ignore radars or they are set to the wrong country code... very common...

1 Like

I guess, I tried to express this point: unfortunately, this platform currently is, and very likely will ever have crippled WiFi. Which makes me sad.

I see Verizon, Xfinity and Optimum SSIDs all from different hardware vendors all operating in DFS range. I got Verizon cr1000a (another toy, same platform as this router) and it doesn't work with DFS in the same way: only 160mhz channel is 36 and no upper 5hz channels available

Set the channel to 36, width to 160MHz, raise the max TX power to 29dBm and show your neighbors who's boss.

1 Like

probably under the hood all using the same broadcom chip/wifi soc. isp provided modem are 90% broadcom supplied

Anyway ath11k is not enough mature currently but honestly the only alternative is the mtk driver... everything else is either not opensource or works half way or is trash and you need to use downstream stuff to make it work....

Not mature enough 'yet' is all right. But being forever on vendors mercy with hardcoded reg db and what else is a red flag. I'm not even sure how could this be called open source driver.. even Broadcom s proprietary drive is not that ugly.