Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion

When I choose country (HK), Channel as Auto, then 160MHz.

Will OpenWrt auto select a channel that is valid for 160MHz (if the router hardware / driver supports it) ?

no idea, sorry.

my guess is it won't, but it's still just a guess.

1 Like

From intel AX210 to WRX36:

- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-30.01  sec  5.20 GBytes  1.49 Gbits/sec                  receiver
-----------------------------------------------------------

PS: My desk space doesn't allow more tests, as I have many other things here. Country US and chan 36 was randomly choose by me for this test. I don't use 160Mhz, so I didn't test more.

In my previous experience with AX3600, 160Mhz also worked.

3 Likes

Will this restore the lower version of uboot, the new version blocks the uboot output

are you on stock firmware?
I am just curious because I bricked mine
see Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion - #627 by missingcharacter

Thank you for this context. I just recovered my device; I just entered the commands "blindly" by following the timing (someone said it takes 20 seconds for the u-boot menu to show up)
I am running openwrt now :tada:

1 Like

Appears like this router will do:
4x4/80 MHz
or
2x2/160 MHz contiguous

So 160 MHz is only possible with 2x2 connections. Of course, most PCs and IoT devices are 1 or 2 streams anyway.

1 Like

Was able to successfully root. Great job everyone involved! New device to tinker around.

However, the rooting instructions on wiki need fixing.

  1. I got CRC error mentioned in this thread. Rerunning command fixed that

  2. Ubiformat step needs a clarification that .ubi image is needed and it's not available on the wiki page. I erroneously tried to use sysupgrade image and got errors. That made me scratch my head and find 3rd(!) Image. I had to dig it up from the build folder, direct link would be helpful

1 Like

I want Device firmware v1.10.01.155,Do you have this fiemware?

it does support channel 120 with width 160mhz country US ... the issue is not with the build but old embedded regdb ...@robi has an outstanding request to externalise the regdb with an up to date country list...

2 Likes

no i don't

1 Like

The latest version V1.10.01.231 firmware has blocked the information output in uboot, is there a way to solve it ???

And the official does not allow downgrading from a high version to a low version through the webpage

what are you trying to achieve ?

if you're lucky, the output is only disabled by u-boot parameter,
in a worst case scenario, downgrade the uboot via ssh using dd.
the second option could however brick your device, if done wrong.

uboot turned off the information output, how to open it, how to replace uboot

that's the cause, not the goal.

try answering the questions, instead of posting counter questions.

Please check your U-Boot version.
Mine is showing:

U-Boot 0.0.1-1-80112-CS (May 21 2021 - 09:29:10 +0800)

As far as I know, U-Boot output has always been blocked when starting to load the kernel with messages:

Starting kernel ...

Jumping to AARCH64 kernel via monitor

Please check your serial connection as it could be loose / floating.

Additionally, as far as I could tell, the OEM update images I checked were not updating U-Boot, just the kernel, rootfs, and some "wifi firmware".

If you really want to downgrade the OEM firmware to test, you would have to obtain root access on the OEM firmware as a first step.
It's doing checks on the images being flashed and rejects downgrading the firmware.
Then, you would have modify the OEM sysupgrade script (/sbin/sysupgrade) and remove the part doing the check for downgrading, which on the script I reviewed on V1.10.01.222 is:

type check_downgrade_image > /dev/null 2>/dev/null && {
...
#end

Then, you can flash a downgraded OEM image from the OEM web UI.

I tested this several times when I was doing tests to understand how the OEM firmware works.
Having said that, be careful and use it at your own risk, as I cannot guarantee it will work on your device.

2 Likes

there shouldn't really be any additional uboot output after those lines though, should there ?
the linux kernel takes over ...

On the OEM firmware there is no output after that (not kernel output, no console input).

When booting OpenWrt, there is kernel input, and then console input/output.

the magic word in my last post would be uboot ...