Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion

Channel 36 has the same problem with 160 Mhz. It looks like @samspson is right and the router does not support 160 Mhz in any channel. I will test more and write back unless someone is already using 160 Mhz?

that's perfectly fine, it's also not a 160MHz chan.

if you're going to report issues (assuming it's one, and not work as designed),
at least make sure you're testing it using the correct scenario/configuration, and no
"I can't eat my soup with my fork".

I'm not using 160, because I don't need that speed, but I just tried it and it's working here:
(I connected with my mobile that only does 80Mhz, but router was at 160Mhz)

Maybe/probably the qualcomm radio driver doesn't have an updated country database, so that's a factor.
The factors that limit 160MHz are the country/channel/power and DFS.

But I could eat my cold soup with my fork before I cooked the new soup :slight_smile: Point taken.

May I ask which driver country did you choose in your test of 160 Mhz? so I can also try that.

it says US, in the screen shot.

but it shouldn't work ... question is, is it really using 160 ? :slight_smile:

some links and info in Xiaomi AX3600: 160 MHz not possible on ch36, radio1 (IPQ8074 802.11acaxn)


The driver is the default one shipped in openwrt snapshot image, it's qualcomm proprietary and we can't change it, we are waiting for an update from qualcomm. The other parameters are in the screenshot.

I think it's working because qualcomm BDF in radio FW is wrong.
I could try to connect at 160Mhz later today.


The thing is that my old router has ath79, and the channel Mhz combinations work there. This one uses ath11k. I think that the country database should be the same for both chipsets or may be I am wrong.

Great discussion, thanks for the link

When I choose country (HK), Channel as Auto, then 160MHz.

Will OpenWrt auto select a channel that is valid for 160MHz (if the router hardware / driver supports it) ?

no idea, sorry.

my guess is it won't, but it's still just a guess.

1 Like

From intel AX210 to WRX36:

- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-30.01  sec  5.20 GBytes  1.49 Gbits/sec                  receiver

PS: My desk space doesn't allow more tests, as I have many other things here. Country US and chan 36 was randomly choose by me for this test. I don't use 160Mhz, so I didn't test more.

In my previous experience with AX3600, 160Mhz also worked.


Will this restore the lower version of uboot, the new version blocks the uboot output

are you on stock firmware?
I am just curious because I bricked mine
see Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion - #627 by missingcharacter

Thank you for this context. I just recovered my device; I just entered the commands "blindly" by following the timing (someone said it takes 20 seconds for the u-boot menu to show up)
I am running openwrt now :tada:

1 Like

Appears like this router will do:
4x4/80 MHz
2x2/160 MHz contiguous

So 160 MHz is only possible with 2x2 connections. Of course, most PCs and IoT devices are 1 or 2 streams anyway.

1 Like

Was able to successfully root. Great job everyone involved! New device to tinker around.

However, the rooting instructions on wiki need fixing.

  1. I got CRC error mentioned in this thread. Rerunning command fixed that

  2. Ubiformat step needs a clarification that .ubi image is needed and it's not available on the wiki page. I erroneously tried to use sysupgrade image and got errors. That made me scratch my head and find 3rd(!) Image. I had to dig it up from the build folder, direct link would be helpful

1 Like

I want Device firmware v1.10.01.155,Do you have this fiemware?

it does support channel 120 with width 160mhz country US ... the issue is not with the build but old embedded regdb ...@robi has an outstanding request to externalise the regdb with an up to date country list...


no i don't

1 Like