Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion

I have found an issue with WiFi. Possible Ath11k bug.
Please check it.
I'm not sure if this is a mass bug or only issue found in my setup.

1 Like

I am trying to build a custom MAIN / MASTER SNAPSHOT image using Image Builder and I am getting the following error. Any idea how to fix this? Thanks in advance.

Target: qualcommax/ipq807x

Image Builder command

make image PROFILE="dynalink_dl-wrx36" PACKAGES="-dnsmasq -libustream-mbedtls -odhcpd-ipv6only -wpad-basic-mbedtls ath11k-firmware-ipq8074 base-files busybox ca-bundle dropbear firewall4 fstools ipq-wifi-dynalink_dl-wrx36 kmod-ath11k-ahb kmod-gpio-button-hotplug kmod-leds-gpio kmod-nft-offload kmod-phy-aquantia kmod-qca-nss-dp kmod-usb-dwc3 kmod-usb-dwc3-qcom kmod-usb3 libc libgcc logd mtd netifd nftables odhcp6c opkg ppp ppp-mod-pppoe procd procd-seccomp procd-ujail uboot-envtools uci uclient-fetch urandom-seed urngd odhcpd ip-full ethtool ca-certificates ca-bundle openssh-sftp-server block-mount e2fsprogs dosfstools kmod-fs-ext4 kmod-fs-vfat kmod-usb-storage kmod-usb2 nano wget-ssl curl bridge htop atop tcpdump iwinfo luci-app-uhttpd iputils-ping fping luci-app-wol kmod-tcp-bbr file usbutils pciutils luci-app-ttyd https-dns-proxy luci-app-https-dns-proxy pciids usbids vsftpd-tls auc luci-app-attendedsysupgrade speedtest-netperf arp-scan arp-scan-database kmod-macvlan kmod-ipvlan kmod-veth iptables-nft ip6tables-nft 6in4 parted tune2fs resize2fs fdisk gdisk f2fs-tools kmod-fs-f2fs diffutils irqbalance libustream-openssl wpad-openssl luci-app-sqm luci-app-ddns luci-proto-wireguard luci-app-wireguard openvpn-openssl luci-app-openvpn vnstat2 luci-app-vnstat2 kmod-mtd-rw qosify tc-bpf kmod-crypto-chacha20poly1305 netperf iperf iperf3-ssl irtt flent-tools luci-ssl-openssl nmap-full ntp-utils ntpdate ntpd batctl-full kmod-batman-adv tar zerotier kmod-mppe pppdump pppoe-discovery luci-app-nextdns bash luci-app-opkg dnscrypt-proxy2 chrony-nts"

Error

Collected errors:
 * opkg_install_cmd: Cannot install package file.
make[2]: *** [Makefile:189: package_install] Error 255
make[1]: *** [Makefile:144: _call_image] Error 2
make: *** [Makefile:262: image] Error 2
make image PROFILE="dynalink_dl-wrx36"   23.05s user 6.81s system 5% cpu 8:33.10 total

EDIT: SOLUTION: Looks like the package "file" is missing from the repos. I was confused about which package file is causing the issue, but turns out it is the package named "file" itself causing the issue. Removing "file" from the list of packages solved the issue.

ok so i tried to follow the installation manual line by line and now im with a bricked router. is there an explanation on how to perform a recovery? i am unsure where something went wrong but i can no longer connect to the router in any way even after factory resetting it from the pin-hole on the back. any help would be appreciated :slight_smile:

That would be the serial port, it's also in the wiki.
You can redo the install, once you've got serial access.

@Crect @otnert do you still have this issue? i went back to firwmare WLAN.HK.2.7.0.1-01744 and this issue dissapeared together with a number of other issues like disconnects

Not quite sure if I had that same issue, I was getting a...

It's been 3 days since that post, and all seems to be behaving as expected, however there is one 2.4G troublesome device that seems to disconnect randomly.

1 Like

Tried 2.7 to no avail and 2.6 after but both fail to bring up the wifi interfaces on AX3600. Might be because of the vlan patch I'm using but I don't know.

Luckily more and more Filogic devices are popping up. Planning to buy one of those and finally leave that Qualcomm misery behind me once and for all.

I was able to follow this guide and get openwrt installed. I am having an issue though when trying to enable both radios. And I don't see how to change channels. I had the 5Ghz working at first, but then I enabled the 2.4 radio, and now the 5Ghz doesn't show up. What am I missing? And on both, I see other screenshots, that there should be a dropdown for channel next to channel width, but I don't see that here.

Make sure that you upgrade to the latest FW version, an issue with radios not turning on after boot appeared with a recent change a few days ago, but is fixed in the last FW version.
Also see if you have the same country in both radios.
Everything is working here.

Ok yes I think this is my problem. I installed image from June-15 which was linked from @borgqueenx noob-friendly post https://downloads.openwrt.org/snapshots/targets/ipq807x/generic/, but I see that the newer version is a different image now at https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/

I downloaded sysupgrade but am getting some warnings, so am scared to hit flash. What is best way to swtich to this new image? I don't need any settings from the old one really.

Did you download https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/openwrt-qualcommax-ipq807x-dynalink_dl-wrx36-squashfs-sysupgrade.bin? Seems you show compex image above.

Yeah I clicked on the wrong file, and was able to update now. But still having issues with 5Gz radio. I have it enabled now, and selected country and channel, but I don't see it showing up on any devices or wifi analyzer.

phy#0
        Interface phy0-ap0
                ifindex 11
                wdev 0x2
                addr a4:97:33:df:a4:b4
                type AP
                channel 56 (5280 MHz), width: 20 MHz, center1: 5280 MHz
                txpower 29.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       0       0       0       0       0       0               0

Have you set an SSID, country (set both radios the same country) and WPA2/CCMP security?

Yes both set to US, and WPA2-PSK security.

I did not have CCMP enabled, just auto. Enabling CCMP and it is working now. Thanks again.

1 Like

Will a release build for the WRX36 become available soon?

Once the dev team decides 23.05 is stable enough, which should, hopefully, be later this year.

2 Likes

Ok still having some problems with 5Ghz radio. When I connect to 5Ghz radio, I get slow pings and then it disconnects after 10 seconds, whereas with the 2.4Ghz radio I get 1ms pings and stable connection. With router 1m away. All settings are defaults except WPA2-PSK/CCMP for both, country code US. I have tried various channels and width to no avail. Latest is at AC-100channel-80MHz. Nothing in that range on wifi scanner. Any ideas?

These are my settings now up a week with no problems using firmware 1835.
But note it is only very lightly used, two modern Samsung phones a Samsung Tablet and a new LG OLED TV :slight_smile:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option channel '52'
	option band '5g'
	option htmode 'HE80'
	option cell_density '0'
	option country 'US'
	option txpower '24'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'dl-5'
	option encryption 'sae-mixed'
	option key 'notmygirlfriendsname'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+1'
	option channel '11'
	option band '2g'
	option htmode 'HE20'
	option txpower '30'
	option country 'US'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'dl-24'
	option encryption 'psk2'
	option key 'notmygirlfriendsname'
1 Like

Settings look similar here, What is firmware 1835? I am using "OpenWrt SNAPSHOT r23685-7e7eb5312d / LuCI Master git-23.158.78004-23a246e"