DWR-M960 Router Bricked after fimrware upgrade

I having Dlink DWR-M960 router and after the FOTA upgrade router got bricked.Now the router only power LED is glowing ..

Router page is also not accessible.Any option to recover?

I tried following steps.

1)Pressed hard reset for 30 seconds and tried -- No changes
2)Pressed hard reset for 60 seconds and tried -- No changes
3)Pressed hard reset and power off , Then power up with Reset button pressed.-- No changes.
4)WIth power off condition , pressed the reset button , Then power up the device and -- no changes.

Any body have any experience for recovering the router then , Please guide me to recover on the same.
Dlink router Details as below:

Hook up a serial console (see https://openwrt.org/toh/d-link/dwr-960) and post a bootlog.

This device is not supported by OpenWrt, AFAICT. (The DWR-960 is supported, but the M960 is not).

What firmware are you working with? What was the upgrade you ran?

I ran FOTA update from the Web UI of router.

This is not related to openwrt, and therefore is out of scope for this forum.

Please ask your question to the dlink support resources.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.