Dumping and flashing VMG4005-b60a via UART

Hello everyone,
I need help with how to flash this modem (ZYXEL VMG4005-b60a) it is managed by ISP and I wanna take control of it, sadly can't access 192.168.1.1 as the website says, so there comes UART, I found it on the motherboard, pins are already pre-soldered, so I made a "diagram" what I think each port is.
I have firmware for VMG4005-b50a, but when I look into changelogs it is also for B60A.
Can anyone check this? I don't want to ruin it and wanna take control over it.

You could take a multimeter to test it. It's also unlikely 1.8 or 3.3v will damage anything.

If you touch a probe to a metal part of the board (RF shield or alike) and the other to GND, you will see continuity. Then of course you can just measure 1.8V or 3.3V on the VCC pin. TX and RX just try both to find out, it won't break anything.

I tried the GND and it matched, now I need USB to UART and figure out how to flash clean firmware without the lock from ISP.
Thank you :slight_smile:

Also, will this be usable? https://pajenicko.cz/prevodnik-prolific-pl2303-usb-na-ttl-uart Not sure if it is suitable for my needs, I tried Arduino as UART->USB but since I have the Chinese version it doesn't work (I would need the to remove some resistors which are no-go for me.)

Just be aware that there won't be xDSL modem support for Broadcom hardware (rendering this endeavour slightly useless).