Dumb AP with ipv6 client address

HI
I'm trying to configure V18.06.1 to be a dumb Access Point
get it's address via DHCP but to have an IPV6 client address as well
this sounds easy but i can't get it to work
whenever I change LAN from single interface it to bridge mode by adding wlan or other wan-lan ports
it all falls apart with lots of different outcomes
some just not getting an ipv6 address
others getting any address from DHCP server "another openwrt device" & being uncontactable
I have tried this on a few devices dir-825 mynet N750 & EA8500
if i remove the ipv6 part It all just works as an access point but can't be contactable via IPV6
I use this as a reference https://openwrt.org/docs/guide-user/network/wifi/dumbap

I'm interested to know if others have got this to work successfully ?

1 Like

I have aps with nothing but a static ipv6 in my ULA range, works great. Needs access to my proxy for getting packages Is there any reason you need ipv4 really?

uci set network.lan6="interface"
uci set network.lan6.proto="dhcpv6"
uci set network.lan6.ifname="$(uci get network.lan.ifname)"
uci set network.lan6.reqprefix="no"
uci commit network
service network restart

i just wanted it to be able to work with and get both ipv4 & ipv6 address of a dhcp server
it's nice when i set it up here & take it else where

thanks vgaettera
that the same result as what i already have

option ifname 'eth1' it works and get dhcp ipv4 & ipv6 from that port
option ifname 'eth0.1' it works and get dhcp ipv4 & ipv6 from the ports
option ifname 'eth0.1 eth1' it fails
option ifname 'eth0.1 eth1 wlan0' it fails
option ifname 'eth1 wlan0' it fails
just adding the wifi to lan makes if fail
it's like any type of bringing breaks it
for the time I'll leave it as ipv4 only
was i little challenge for my self but it was not to be
thank for looking

I suspect the possibility that the bridge is breaking neighbor discovery or router advertisement. turning off igmp snooping might help. There seems to have been a bug related to that. I chased it down at one point but it was with older kernels. yet I could imagine that it never quite got fixed properly and then also pops up again in later kernels.

@Lucky1 maybe you can get some inspiration from here: https://openwrt.org/docs/guide-user/network/wifi/relay_configuration - see the IPv6 chapter at the end. I got a WIFI extender working with IPv6 SLAAC that way.

Dual Stack LAN+WLAN-bridge: DHCP+DHCPv6

uci -q delete firewall.@zone[0].network
uci add_list firewall.@zone[0].network="lan"
uci add_list firewall.@zone[0].network="lan6"
uci commit firewall
service firewall restart

uci -q delete network.lan
uci set network.lan="interface"
uci set network.lan.type="bridge"
uci set network.lan.ifname="eth0"
uci set network.lan.proto="dhcp"
uci -q delete network.lan6
uci set network.lan6="interface"
uci set network.lan6.ifname="@lan"
uci set network.lan6.proto="dhcpv6"
uci commit network
service network restart

uci set wireless.default_radio0.network="lan"
uci commit wireless
wifi reload

https://openwrt.org/docs/guide-user/network/network_interface_alias

3 Likes

When configuring alias interfaces you can use "@interface" as ifname, i.e. "@lan" in your case instead of "br-lan". This works both for bridges and other interfaces.

1 Like

thankyou vgaettera
You example has educated me all about how & why there is the alias interfaces

and thankyou mikma for giving me the luci happy name as bl-lan is not like so much by luci

Turns out I had lots of problems I’m going to put them down to lesions learned
I have been misled by a lot of my own assumptions
I thought I had sorted it out but as I wake up this morning the ipv6 side is not working as is was last night
I’ll keep pushing on I’m sure it’s me who is missing something simple

Hi vgatera
I think i have it sorted
my only differences with your config atm is
uci set network.lan6.reqprefix="no" as this stops it allocating a group of ip's that are not needed
uci set notwork.lan.igmp_snooping '1' as i think the firewall in my modem was blocking it this seem to let it know it's part of the lan
it's not clear to my why but sine i turned it on the ipv6 side is not blocked & can ping & traceroute out now
1 of the 3 I had setup keep say i don't have permission or just failing
I do have igmpproxy installed in my modem for iptv but not the access points

the other thing i had problems with was when the wifi came up after DFS scan I lost access to the lan side
the only difference in my config seems to be in the luci file with the following

config ifstate
	option interface 'lan'
	option ifname 'eth0.1 radio0.network1 radio1.network1'
	option bridge 'true'

I'm sure this is a visual thing and it maybe i just didn't have the
uci set network.lan.type="bridge"
as with most of these thing I can't repeat the problems to verify exactly what it was
1st you can't fix it then you can't break it when you try
anyway working still been a full day now :slight_smile:
thanks for you help vgaetera

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.